Neuinstallation 10.1-Yast update- Fehler libzypp-patch-...

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Fred
Newbie
Newbie
Beiträge: 42
Registriert: 23. Mai 2005, 15:29

Neuinstallation 10.1-Yast update- Fehler libzypp-patch-...

Beitrag von Fred » 6. Okt 2006, 17:09

Hallo,
ich habe bei meiner SUSE 10.1 Neuinstallation über Yast das Onlineupdate
durchgeführt.
Daraufhin wurde auch irgend ein Packet installiert.
(Sorry kann nicht mehr sagen ob es eins oder mehrer waren, da die Installation nebenher lief und ich
nicht immer ein Auge dafür hatte)
Nachdem wollte ich die übrigen Updates installieren. Wobei immer folgender Fehler aufrat:

#### YaST2 conflicts list - generated 2006-10-05 17:33:21 ####
Dies wrde script:libzypp-patch-zmdrestart.sh-2-1533-1.noarch ungltig machen.
script:libzypp-patch-zmdrestart.sh-2-1533-1.noarch weist nicht erfllte Anforderungen auf
Konfliktl�ung:
( ) libzypp-patch-zmdrestart.sh-2 l�chen
#### YaST2 conflicts list END ###

Es war nun völlig egal welche auswahl ich getroffen habe,
das Fenster popte immer wieder auf. Nichts ging mehr.
Habe darafhin versucht mit ZEN die Updates zu installieren.
ZEN meldete eine latte von Fehlern und verabschiedete sich ins nirvana.

Habe mir nun wie folgt geholfen.
Den Packetmenager SMART und die SMART GUI installiert.
Folgende Quellen verwendet:

-----------------------------------------------------------------------------
[packman-101-yum]
type = rpm-md
name = Packman 10.1 YUM Repository
baseurl = ftp://ftp.links2linux.de/pub/packman/suse/10.1

[suse-101-yast-base]
type = yast2
name = SUSE Linux 10.1 YaST Base Repository
baseurl = ftp://ftp.gwdg.de/pub/opensuse/distribu ... nst-source

[suse-101-yast-extra]
type = yast2
name = SUSE Linux 10.1 YaST Extra Repository
baseurl = ftp://ftp.gwdg.de/pub/opensuse/distribu ... nst-source

[suse-101-yum-update]
type = rpm-md
name = SUSE Linux 10.1 YUM Update Repository
baseurl = ftp://ftp.gwdg.de/pub/linux/suse/ftp.su ... pdate/10.1
----------------------------------------------------------------------------------

Mit SMART habe ich alle Yast-Packete auf den aktuellen Stand gebracht.
(Achtung, unter SMART sieht man auch ältere Versionen.
Daher immer die aktuellste auswählen, ist ein wenig Handarbeit)

Dannach haben die restlichen Updates mit Yast anstandlos funktioniert.

Habe das hier gepostet um allen die ein ähnliches Problem haben einen
Lösungsweg zu geben.
Warum der Fehler auftrat ist mir aber unklar.
Hatte bei keiner SUSE Installation bisher solche Probleme gehabt.

Fred

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 6. Okt 2006, 18:06

Der Fehler ist inklusive mehrerer Lösungsmöglichkeiten im Forum allgemein bekannt.
openSUSE Factory - GNOME 2.32.1

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste