[gelöst] Updates über YOU können nicht eingespielt werden

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
banit-alex
Newbie
Newbie
Beiträge: 13
Registriert: 4. Apr 2006, 13:52
Wohnort: Coburg

[gelöst] Updates über YOU können nicht eingespielt werden

Beitrag von banit-alex » 3. Okt 2006, 16:37

Hallo,

habe folgendes Problem:

Wenn ich über YOU ein Update einspielen will, erhalte ich folgende Fehlermeldung:
ERROR(InstTarget:E_RpmDB_subprocess_failed)
package curl-32bit-7.14.0-2.4 is intended for a x86_64 architecture

Mit uname -a erhalte ich folgendes:
Linux linux 2.6.13-15.12-smp #1 SMP Thu Aug 24 11:23:58 UTC 2006 i686 i686 i386 GNU/Linux

Wie ich vermute hat das Problem mit dem Thema 32bit/64bit Suse zu tun.

Kann mir jemand helfen, wo ich zur Problemlösung ansetzen könnte.

Vielen dank...
Zuletzt geändert von banit-alex am 3. Okt 2006, 22:10, insgesamt 1-mal geändert.

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 3. Okt 2006, 19:06

Lustig - diesen Fall hatten wir schon mal, aber genau umgekehrt.

Poste mal die Ausgabe von

Code: Alles auswählen

rpm -q --queryformat '%{N}-%{V}-%{R}.%{ARCH}\n' rpm
sowie

Code: Alles auswählen

rpm -qa 'arch=x86_64'
openSUSE Factory - GNOME 2.32.1

banit-alex
Newbie
Newbie
Beiträge: 13
Registriert: 4. Apr 2006, 13:52
Wohnort: Coburg

Beitrag von banit-alex » 3. Okt 2006, 19:17

auf Ersteres erhalte ich:

incorrect format: unknown tag

auf Zweiteres:

gpg-pubkey-0dfb3188-41ed929b
gpg-pubkey-1abd1afb-450ef738
gpg-pubkey-1abd1afb-450ef738
libacl-32bit-2.2.31-3
gpg-pubkey-1abd1afb-450ef738
libusb-32bit-0.1.10a-4
glib-32bit-1.2.10-595
krb5-32bit-1.4.1-5
openssl-32bit-0.9.7g-2
powersave-32bit-0.10.15-5
gpg-pubkey-1abd1afb-450ef738
libxslt-32bit-1.1.14-3
gpg-pubkey-1dfa8f0c-41540ae2
libgcrypt-32bit-1.2.1-5
gpg-pubkey-1dfa8f0c-41540ae2
libgpg-error-32bit-1.0-5
sysfsutils-32bit-1.3.0-3
curl-32bit-7.14.0-2
gpg-pubkey-1abd1afb-450ef738
gpg-pubkey-1dfa8f0c-41540ae2
popt-32bit-1.7-221
file-32bit-4.14-3
gpg-pubkey-1dfa8f0c-41540ae2
gpg-pubkey-1dfa8f0c-41540ae2
parted-32bit-1.6.24-3
expat-32bit-1.95.8-5
gpg-pubkey-1dfa8f0c-41540ae2
gpg-pubkey-15c17deb-3f9e80c9
glibc-locale-32bit-2.3.5-40
pam-32bit-0.80-6
libxml2-32bit-2.6.20-4
cracklib-32bit-2.8.3.0.7-2
gpg-pubkey-1abd1afb-450ef738
gpg-pubkey-1dfa8f0c-41540ae2
gpg-pubkey-1abd1afb-450ef738
perl-32bit-5.8.7-5
pam-modules-32bit-10.0-11
gpg-pubkey-1abd1afb-450ef738
ncurses-32bit-5.4-71
gpg-pubkey-1dfa8f0c-41540ae2
db-32bit-4.3.27-7
irqbalance-0.09-43
openldap2-client-32bit-2.2.27-6
gpg-pubkey-1abd1afb-450ef738
tcpd-32bit-7.6-717
bzip2-32bit-1.0.3-5
libselinux-32bit-1.23.11-3
gpg-pubkey-9c800aca-40d8063e
libcap-32bit-1.92-487
gpg-pubkey-1abd1afb-450ef738
gettext-32bit-0.14.3-6
zlib-32bit-1.2.3-3
gpg-pubkey-1dfa8f0c-41540ae2
utempter-32bit-0.5.5-5
pcre-32bit-6.2-2
dbus-1-glib-32bit-0.35.2-8
gpg-pubkey-1dfa8f0c-41540ae2
gpg-pubkey-1abd1afb-450ef738
readline-32bit-5.0-9
binutils-32bit-2.16.91.0.2-8
hal-32bit-0.5.4-6
gpm-32bit-1.20.1-309
gpg-pubkey-3d25d3d9-36e12d04
gpg-pubkey-1dfa8f0c-41540ae2
gpg-pubkey-1dfa8f0c-41540ae2
gpg-pubkey-1dfa8f0c-41540ae2
libcom_err-32bit-1.38-4
libattr-32bit-2.4.24-2
e2fsprogs-32bit-1.38-4
cyrus-sasl-32bit-2.1.21-3
bind-libs-32bit-9.3.1-8
gdbm-32bit-1.8.3-232
glib2-32bit-2.8.1-3
gpg-pubkey-1abd1afb-450ef738
libxcrypt-32bit-2.2-5
alsa-32bit-1.0.9-23
gpg-pubkey-1dfa8f0c-41540ae2
gpg-pubkey-1abd1afb-450ef738
glibc-32bit-2.3.5-40
gpg-pubkey-1abd1afb-450ef738
gpg-pubkey-1dfa8f0c-41540ae2
dbus-1-32bit-0.35.2-8
gpg-pubkey-1abd1afb-450ef738
resmgr-32bit-0.9.8_SVNr57-2

Vielen Dank das du dich des Problems annimmst :-)

Grüsse

PS: der Fehler entstand nachdem ich nach einer XP-Installation mit der automatischen Reparatur den Bootloader wieder installiert habe...

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 3. Okt 2006, 19:46

Hm, schwierig.

Also, zum einen hast Du eindeutig SUSE 10.0, nicht 10.1. Über 10.0 weiß ich wesentlich weniger als über 10.1.

Als nächstes wundert es mich doch sehr, dass doch so viele x86_64-Pakete installiert sind. Was soll Dein System denn "eigentlich" sein bzw. was war es vor der Sache mit der Bootloader-Installation: 32-Bit oder 64-Bit?

Poste zusätzlich mal die Ausgabe von

Code: Alles auswählen

cat /etc/SuSE-release
Und noch eine Frage: Kann es zufällig sein, dass dieses System durch das Update einer 64-Bit-9.3 auf eine 32-Bit-10.0 entstanden ist?
openSUSE Factory - GNOME 2.32.1

banit-alex
Newbie
Newbie
Beiträge: 13
Registriert: 4. Apr 2006, 13:52
Wohnort: Coburg

Beitrag von banit-alex » 3. Okt 2006, 19:58

Das ist die Ausgabe:

SUSE LINUX 10.0 (i586)
VERSION = 10.0

Das System ist als 32bit Version installiert worden. Als Prozessor kommt ein Dual Pentium D zum Einsatz.
Ich habe das System von der original CD als 32bit 10.0 installiert, also kein Update.
Ich vermute das beim automatischen Reparieren die 64bit Version mit der 32 vermischt wurde...

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 3. Okt 2006, 20:21

Sowas in der Art wird wohl passiert sein. Der Dual Pentium D ist ja wohl eine EM64T-CPU, wenn mich nicht alles täuscht, also scheint dieses "Reparatur"-Programm die CPU (korrekt) als x86_64 erkannt und damit effektiv das System zerstört zu haben.

Auf "sauberen" 32-Bit-Systemen darf

Code: Alles auswählen

rpm -qa 'arch=x86_64'
nur die gpg-pubkey-Pseudopakete zurückliefern.

Versuch mal alle Pakete in der Liste außer den gpg-pubkey-Pseudopaketen zu deinstallieren, die haben nämlich auf Deinem System überhaupt nichts verloren. Der Fehler beim Update ist nur ein Folgefehler der Tatsache, dass sie überhaupt installiert sind.
openSUSE Factory - GNOME 2.32.1

banit-alex
Newbie
Newbie
Beiträge: 13
Registriert: 4. Apr 2006, 13:52
Wohnort: Coburg

Beitrag von banit-alex » 3. Okt 2006, 22:09

Hach, perfekt... das war`s....

Vielen dank für deine Unterstützung.

Ich habe über Yast alle Pakete entfernt und nu geht´s.

Gruss Alex

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast