yast2 absturtz problem. (glaube ein anderes wie bereits besc

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
simonse
Newbie
Newbie
Beiträge: 41
Registriert: 21. Sep 2006, 17:39
Wohnort: Berlin

yast2 absturtz problem. (glaube ein anderes wie bereits besc

Beitrag von simonse » 27. Sep 2006, 23:12

MOin moin,

tut mir leid wenn ich hier wieder irgend ne frage stelle die irgendwo schon beantwortet ist, aber ich dachte bevor ich durchdreh stelle ich sie einfach.

Problem.
ich würde gern den nvidia treiber über yast installieren, ich hab die dazu nötige Quelle angegeben (download.nvidia.com/novel), und einen der zwei nötigen "dingsbums" schon installiert,(x11-video-nvidia) und beim anderen (nvidia-gfx-kmp-default) schaltet sich yast direkt nachdem ich auf "übernehmen" geklickt habe einfach ohne installation ab. ..unverschämt!
dieses problem tritt soweit ich mich erinnern kann nicht nur beim nvidia treiber auf sondern bei anderen auch. ich hab heute ein update mit smart durchgeführt, welches den anschein machte erfolgreich gewesen zu sein.

what should i do?

Bitte formuliert eure antworten so als müsstet ihr es über einen Chat eurer 3jährigen Tochter vermitteln.


vielen vielen dank,

simon

Werbung:
b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 27. Sep 2006, 23:47

Wie immer:
Starte YaST aus der Konsole

Code: Alles auswählen

/sbin/yast2 sw_single
und poste die Fehlermeldungen hier.
ich hab heute ein update mit smart durchgeführt, welches den anschein machte erfolgreich gewesen zu sein.
Was genau heißt das?
Welche Pakete wurden denn aktualisiert?
Welche channel hast du überhaupt aktiviert?

Ich empfehle dir, nicht verschiedene Paketmanager durcheinander zu benutzen.
Entweder smart oder YaST (die Treiber gibt es auch aus einem smart-channel)
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

simonse
Newbie
Newbie
Beiträge: 41
Registriert: 21. Sep 2006, 17:39
Wohnort: Berlin

Beitrag von simonse » 28. Sep 2006, 18:12

Also, inzwischen hab ich die Kiste runtergefahren und und neu gestartet, und nun geht er nicht mehr in die grafische oberfläche... schade, liegt wohl daran das der zwei Teil des nvidia treibers nich drauf ist.

wenn ich nun über das konsolen yast2 versuche den "nvidia-gfx-kmp-default" installieren will kommt:

Code: Alles auswählen

 /sbin/yast: line 233: 8038 Speicherzugriffsfehler $ybindir/y2base menu ncurses $NCTHREADS
die sache mit dem smart hab nur gemacht, weil das yast online update erst nicht ging, und es hieß nach man müsse so ein update mit smart machen. damit das yast online update geht. (geht trotzdem nicht)
Ich hab eine Channel liste eines vermeintlich seriösen Anbieters verwendent, weil leider nicht mehr wo die stand.

danke im vorraus

simon

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 28. Sep 2006, 18:32

Was gibt denn

Code: Alles auswählen

rpm -qa | grep yast2-nurses
rpm -qa | grep yast2-qt
aus?
die sache mit dem smart hab nur gemacht, weil das yast online update erst nicht ging, und es hieß nach man müsse so ein update mit smart machen. damit das yast online update geht. (geht trotzdem nicht)
Der Tipp ist auch Grundsätzlich richtig.
Allerdings blind smart zu installieren und irgendetwas zu aktualisieren ... :roll:

Btw: Du kannst auch den OSS-NVIDIA-Treiber wieder aktivieren, um wieder graphisch zu arbeiten.

Code: Alles auswählen

sax2 -m 0=nv
(ungetestet - Mal im Unterforum Grafikkarten und Monitore umschauen)

Und deine SuSE Version darfst du auch angeben :wink:
SuSE 10.1? i386? x86_64?
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

simonse
Newbie
Newbie
Beiträge: 41
Registriert: 21. Sep 2006, 17:39
Wohnort: Berlin

Beitrag von simonse » 28. Sep 2006, 19:13

Alsio

Code: Alles auswählen

 rpm -qa | grep yast2-nurses
"ergibt nix
rpm -qa | yast2-qt 
=> yast2-qt-2.13.53-4
meine Version ist Suse Linux 10.1 x86_64

Danke für den Tipp für die grafische oberfläche. jetzt muss nicht ständig durchs haus rennen um foren einträge zu lesen... juhu

Danke

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 28. Sep 2006, 19:23

Uhps :oops:
Hätte
rpm -qa | grep ncurses
heißen müssen.

Versuch mal die Pakete neu zu installieren:

Code: Alles auswählen

rpm -Uhv http://ftp.tu-chemnitz.de/pub/linux/suse/ftp.suse.com/suse/update/10.1/rpm/x86_64/yast2-qt-2.13.60-0.5.x86_64.rpm
rpm -Uhv http://ftp.tu-chemnitz.de/pub/linux/suse/ftp.suse.com/suse/update/10.1/rpm/x86_64/yast2-ncurses-2.13.40-1.4.x86_64.rpm
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

simonse
Newbie
Newbie
Beiträge: 41
Registriert: 21. Sep 2006, 17:39
Wohnort: Berlin

Beitrag von simonse » 28. Sep 2006, 19:35

Code: Alles auswählen

rpm -qa | grep yast2-ncurses
ergibt

Code: Alles auswählen

yast2-ncurses-2.13.27-3
kommt beim ersten link die Meldung:

Code: Alles auswählen

Retrieving http://ftp.tu-chemnitz.de/pub/linux/suse/ftp.suse.com/suse/update/10.                    1/rpm/x86_64/yast2-qt-2.13.60-0.5.x86_64.rpm
error: Failed dependencies:
        libzypp >= 1.0.0 is needed by yast2-qt-2.13.60-0.5.x86_64
und beim zweiten:

Code: Alles auswählen

Retrieving http://ftp.tu-chemnitz.de/pub/linux/suse/ftp.suse.com/suse/update/10.                    1/rpm/x86_64/yast2-ncurses-2.13.40-1.4.x86_64.rpm
error: Failed dependencies:
        libzypp >= 1.0.0 is needed by yast2-ncurses-2.13.40-1.4.x86_64
        libzypp.so.1()(64bit) is needed by yast2-ncurses-2.13.40-1.4.x86_64
Danke für dein Bemühen

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 28. Sep 2006, 19:49

Dann installier vorher noch die libzypp:

Code: Alles auswählen

rpm -Uhv http://ftp.tu-chemnitz.de/pub/linux/suse/ftp.suse.com/suse/update/10.1/rpm/x86_64/libzypp-1.3.2-0.6.x86_64.rpm
Wenn du da auch ungelöste Abhängigkeiten hast, solltest du dich doch etwas eingehender mit smart beschäftigen und damit ein Update machen.
In diesem Fall mal deine channels posten:

Code: Alles auswählen

smart channel --show
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

simonse
Newbie
Newbie
Beiträge: 41
Registriert: 21. Sep 2006, 17:39
Wohnort: Berlin

Beitrag von simonse » 28. Sep 2006, 19:58

Also, die Abhängigkeiten wären:

Code: Alles auswählen

error: Failed dependencies:
        libzypp.so.0()(64bit) is needed by (installed) libzypp-zmd-backend-7.1.1.0-40.x86_64
        libzypp.so.0()(64bit) is needed by (installed) yast2-ncurses-2.13.27-3.x86_64
        libzypp.so.0()(64bit) is needed by (installed) yast2-perl-bindings-2.13.4-17.x86_64
        libzypp.so.0()(64bit) is needed by (installed) yast2-pkg-bindings-2.13.68-4.x86_64
Zu den Channels, ich gebe zu, ich habe keine Ahnung was ich da rein kopiert habe, da ich zu diesem Zeitpunkt ziemlich angeschissen war, und blind (wie du sagtest) rum gedatet.
Vielen vielen dank für deine Hilfe.

Code: Alles auswählen

[suse-101-apt-suse-projects]
type = apt-rpm
name = SUSE Linux 10.1 APT SuSe Projects Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = suse-projects

[Java]
type = rpm-md
name = Java
baseurl = http://download.opensuse.org/distribution/SL-10.1/non-oss-inst-source/suse/

[suse-101-apt-extra]
type = apt-rpm
name = SUSE Linux 10.1 APT Extra Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = extra

[jpackage-1.6]
type = apt-rpm
name = JPackage 10.1 apt repository (1.6)
baseurl = http://mirrors.sunsite.dk/jpackage/1.6/generic
components = free

[jpackage-1.7]
type = apt-rpm
name = JPackage 10.1 apt repository (1.7)
baseurl = http://ftp.heanet.ie/pub/jpackage/1.7/generic
components = free

[suse-101-apt-security-drpm]
type = apt-rpm
name = SUSE Linux 10.1 APT Security-drpm Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = security-drpm

[rpmkeys-101-apt]
type = apt-rpm
name = SUSE Linux 10.1 APT RPMKeys Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = rpmkeys

[suse-101-apt-suser-jmorris]
type = apt-rpm
name = SUSE Linux 10.1 APT Suser-JMorris Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = suser-jmorris

[suse-101-apt-ximian]
type = apt-rpm
name = SUSE Linux 10.1 APT Ximian Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = ximian

[suse-101-apt-security-prpm]
type = apt-rpm
name = SUSE Linux 10.1 APT Security-prpm Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = security-prpm

[suse-101-apt-non-oss]
type = apt-rpm
name = SUSE Linux 10.1 APT Non-oss Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = non-oss

[kde3]
type = rpm-md
name = kde3
baseurl = http://software.opensuse.org/download/KDE:/KDE3/SUSE_Linux_10.1

[NX]
type = rpm-md
name = NX
baseurl = http://software.opensuse.org/download/NX/SUSE_Linux_10.1/

[suse-101-apt-suser-tcousin]
type = apt-rpm
name = SUSE Linux 10.1 APT Suser-tcousin Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = suser-tcousin

[suse-101-apt-kernel-of-the-day]
type = apt-rpm
name = SUSE Linux 10.1 APT Kernel of the day Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = kernel-of-the-day

[enlightenment]
type = rpm-md
name = E17 window manager
baseurl = http://software.opensuse.org/download/X11:/Enlightenment/SUSE_Linux_10.1/

[XML]
type = rpm-md
name = XML
baseurl = http://software.opensuse.org/download/Archiving:/:/Backup:/:/MondoRescue/SUSE_Linux_10.1/

[suse-101-apt-update-drpm]
type = apt-rpm
name = SUSE Linux 10.1 APT Update-drpm Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = update-drpm

[rpm-sys]
type = rpm-sys
name = RPM System

[SaX2]
type = rpm-md
name = SaX2
disabled = yes
baseurl = http://software.opensuse.org/download/SaX2/SL10.1/

[GPhoto]
type = rpm-md
name = GPhoto
baseurl = http://software.opensuse.org/download/GPhoto/SUSE_Linux_10.1/

[packman-101-apt]
type = apt-rpm
name = Packman 10.1 APT Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = packman

[madwifi]
type = rpm-md
name = madwifi drivers
baseurl = http://madwifi.org/suse/

[xemini]
type = apt-rpm
name = Xemini 10.1 apt repository
baseurl = http://op4.xemini.de/linux/suse/apt/SuSE/10.1-x86_64/
components = xemini

[kde-backports]
type = rpm-md
name = kde
baseurl = http://software.opensuse.org/download/KDE:/Backports/SUSE_Linux_10.1

[Apache]
type = rpm-md
name = Apache
baseurl = http://software.opensuse.org/download/Apache/SUSE_Linux_10.1/

[Printing]
type = rpm-md
name = Printing
disabled = yes
baseurl = http://software.opensuse.org/download/Printing/SUSE_Linux_10.1/

[suse-101-apt-suse-people]
type = apt-rpm
name = SUSE Linux 10.1 APT SuSe People Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = suse-people

[Backup]
type = rpm-md
name = Backup
baseurl = http://software.opensuse.org/download/Archiving:/:/Backup:/:/MondoRescue/SUSE_Linux_10.1/

[Wine]
type = rpm-md
name = Wine
baseurl = http://software.opensuse.org/download/Emulators:/Wine/SUSE_Linux_10.1/

[suse-101-apt-suser-jengelh]
type = apt-rpm
name = SUSE Linux 10.1 APT Suser-Jengelh Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = suser-jengelh

[ruby]
type = rpm-md
name = ruby
baseurl = http://software.opensuse.org/download/ruby/SuSE_Linux_10.1/

[suse-101-apt-update-prpm]
type = apt-rpm
name = SUSE Linux 10.1 APT Update-prpm Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = update-prpm

[suse-101-apt-kraxel]
type = apt-rpm
name = SUSE Linux 10.1 APT Kraxel Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = kraxel

[suse-101-apt-update]
type = apt-rpm
name = SUSE Linux 10.1 APT Update Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = update

[suse-101-apt-samba3]
type = apt-rpm
name = SUSE Linux 10.1 APT Samba3 Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = samba3

[suse-101-apt-security]
type = apt-rpm
name = SUSE Linux 10.1 APT Security Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = security

[suse-101-apt-mozilla]
type = apt-rpm
name = SUSE Linux 10.1 APT Mozilla Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = mozilla

[nvidia]
type = rpm-md
name = latest nVidia driver
baseurl = ftp://download.nvidia.com/novell

[suse-101-apt-base]
type = apt-rpm
name = SUSE Linux 10.1 APT Base Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = base

[suse-101-apt-suser-guru]
type = apt-rpm
name = SUSE Linux 10.1 APT Suser Guru Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.1-x86_64
components = suser-guru

[QT]
type = rpm-md
name = QT
disabled = yes
baseurl = http://software.opensuse.org/download/KDE:/Qt/SUSE_Linux_10.1/
[/code]

simonse
Newbie
Newbie
Beiträge: 41
Registriert: 21. Sep 2006, 17:39
Wohnort: Berlin

Beitrag von simonse » 28. Sep 2006, 20:24

Hilfe? :cry:

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 29. Sep 2006, 00:36

simonse hat geschrieben:Hilfe? :cry:
Was soll denn das?
Abwarten - Nicht nach knapp einer halben Stunde schon anfangen zu drängeln.
Das ist hier keine Hotline, sondern die Arbeit von Freiwilligen.

Hilfe, da sind ja alle verfügbaren channels gelistet ... :shock:

An deiner Stelle würde ich erstmal alle channels löschen.

Code: Alles auswählen

smart channel --remove-all
Und dann eine minimalistische Konfiguration erstellen.
(Soll schließlich nur dazu dienen YaST zu reparieren)

Code: Alles auswählen

[rpm-sys] 
type = rpm-sys 
name = RPM System 

[suse-101-yum-update]
type = rpm-md
name = SUSE Linux 10.1 YUM Update Repository
baseurl = http://ftp.tu-chemnitz.de/pub/linux/suse/ftp.suse.com/suse/update/10.1

[suse-101-yast-base]
type = yast2
name = SUSE Linux 10.1 YaST Base Repository
baseurl = http://ftp.tu-chemnitz.de/pub/linux/opensuse/distribution/SL-10.1/inst-source

[suse-101-yast-extra]
type = yast2
name = SUSE Linux 10.1 YaST Extra Repository
baseurl = http://ftp.tu-chemnitz.de/pub/linux/opensuse/distribution/SL-10.1/non-oss-inst-source

[packman-101-yast]
type = yast2
name = Packman 10.1 YaST Repository
baseurl = http://packman.iu-bremen.de/suse/10.1
In eine Datei speichern -> /tmp/smart-channels-new.txt
Und mit

Code: Alles auswählen

smart channel --add /tmp/smart-channels-new.txt
importieren.
Ein anschließendes smart channel --show sollte dann nur diese channels anzeigen.

Dann mit

Code: Alles auswählen

smart update
die channels einlesen,
und mit

Code: Alles auswählen

smart install yast2-ncurses yast2-qt libzypp
die betroffenen Pakete aktualisieren.

PS: Das ganze ist ungetestet (sollte aber funktionieren). 8)
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste