smart gui fehler

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
sysop
Member
Member
Beiträge: 101
Registriert: 3. Mär 2006, 22:09
Kontaktdaten:

smart gui fehler

Beitrag von sysop » 9. Sep 2006, 23:49

bevor ich hier zerrissen werde, ich habe gegoogelt, und hier glaube ich alles gelesen, was zu dem thema zu finden war, komme aber nicht weiter.

smart und smart gui sind auf einem suse 9.2 installiert.
der start von smart gui verursacht diesen fehler:

Code: Alles auswählen

Das System unterstützt keine 'gtk python' Schnittstelle
ich habe aber folgednes paket mit smart installiert:

Code: Alles auswählen

python-gtk-2.4.1-1.guru.suse92@i686
dann habe ich smart und smart gui mit smart nochmals neu installiert, in der hoffnung, smart würde mir eventuelle abhängigkeitsfehler zeigen, aber essig.
das komische, auf meinem laptop geht´s auf´m pc nicht.
in einem thread wurde gesagt, man müsse PyGTK installieren, komischerweise ist das am laptop nicht der fall, PyGTK wird in den sourcen bei mir nicht aufgeführt und wurde am lappy auch nicht installiert.
nun bin ich ratlos und hänge, danke...
gruss sys ;-)

Werbung:
OmasEnkel
Hacker
Hacker
Beiträge: 572
Registriert: 19. Dez 2005, 14:59
Wohnort: Frankfurt
Kontaktdaten:

Beitrag von OmasEnkel » 10. Sep 2006, 00:40

Und was passiert, wenn Du die Konsolenversion benutzt? Kommt da der gleiche Fehler?
So long,
OmasEnkel
--------------------

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 10. Sep 2006, 12:37

Die Fehlermeldung ist relativ eindeutig: Deine python-gtk-Installation ist defekt.

python-gtk ist übrigens dasselbe wie PyGTK, PyGTK kann allerdings kein SUSE-RPM sein, weil die SUSE-RPMs alle python-gtk heißen. => Runter damit.

Teste mal die python-gtk-Installation mittels

Code: Alles auswählen

python -c "import gtk"
Wenn es keine Ausgabe gibt, dann funktioniert die python-gtk-Installation; wenn es eine Ausgabe gibt, dann poste sie bitte hier im Forum.
openSUSE Factory - GNOME 2.32.1

sysop
Member
Member
Beiträge: 101
Registriert: 3. Mär 2006, 22:09
Kontaktdaten:

Beitrag von sysop » 10. Sep 2006, 16:32

hallo und danke für die antworten.

pygtk habe ich auch nicht installiert, war nur etwas verwundert, dass in einem beitrag darauf verwiesen wird.

es kommt ein fehler, und zwar das hier:

Code: Alles auswählen

Traceback (most recent call last):
  File "<string>", line 1, in ?
  File "/usr/lib/python2.3/site-packages/PIL/__init__.py", line 37, in ?

ImportError: /opt/gnome/lib/libpangoft2-1.0.so.0: undefined symbol: g_assert_warning
ach ja, ich hatte python-gtk übrigens deinstalliert und über smart nochmal auf die platte gezogen, scheint aber den selben fehler zu verursachen.
gruss sys ;-)

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 10. Sep 2006, 16:52

Code: Alles auswählen

ImportError: /opt/gnome/lib/libpangoft2-1.0.so.0: undefined symbol: g_assert_warning
da hakt es eher in der gnome Ecke: pango, gtk2 wären da Kandidaten. Woher kommen denn diese und welche Version haben sie ?
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

sysop
Member
Member
Beiträge: 101
Registriert: 3. Mär 2006, 22:09
Kontaktdaten:

Beitrag von sysop » 10. Sep 2006, 23:38

hallo

pango ist in der version 1.10.2-10 installiert
gtk2 in der version 2.4.9-10.3

beide pakete sind von ftp.gdwg gezogen.
kde ist version 3.3.1
gruss sys ;-)

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 11. Sep 2006, 12:48

SUSE 9.2... Mahlzeit.

g_assert_warning kommt von glib2. Upgrade entweder glib2 auf eine Version, die g_assert_warning hat oder downgrade pango auf eine Version, die g_assert_warning nicht benötigt.

Woher die Pakete kommen sollen? Keine Ahnung, SUSE 9.2 nähert sich dem End-of-Life.

Probier entweder die Versionen von den Installations-CDs (passen garantiert zusammen, können aber evtl. alt sein) oder die Versionen aus supplementary (sind nicht alt, passen aber möglicherweise bzw. bei Dir bis jetzt tatsächlich) nicht zusammen.
openSUSE Factory - GNOME 2.32.1

sysop
Member
Member
Beiträge: 101
Registriert: 3. Mär 2006, 22:09
Kontaktdaten:

Beitrag von sysop » 11. Sep 2006, 19:53

danke, glib2 update und alles war gut..
thema gelöst
gruss sys ;-)

tob1as
Newbie
Newbie
Beiträge: 27
Registriert: 18. Okt 2005, 20:42

Beitrag von tob1as » 12. Sep 2006, 14:41

Kann jemand hiermit etwas anfangen? Ich schaff's irgendwie gar nicht mehr, smart-GUI zu starten..

Code: Alles auswählen

Traceback (most recent call last):
  File "/usr/bin/smart", line 194, in ?
    main(sys.argv[1:])
  File "/usr/bin/smart", line 161, in main
    forcelocks=opts.ignore_locks, loglevel=opts.log_level)
  File "/usr/lib/python2.4/site-packages/smart/__init__.py", line 122, in init
    iface.object = createInterface(ifacename, ctrl, command, argv)
  File "/usr/lib/python2.4/site-packages/smart/interface.py", line 150, in createInterface
    smart = __import__("smart.interfaces."+xname)
  File "/usr/lib/python2.4/site-packages/smart/interfaces/gtk/__init__.py", line 29, in ?
    pygtk.require("2.0")
  File "/usr/lib/python2.4/site-packages/pygtk.py", line 72, in require
    versions = _get_available_versions()
  File "/usr/lib/python2.4/site-packages/pygtk.py", line 46, in _get_available_versions
    for filename in glob.glob(os.path.join(dir, _pygtk_dir_pat)):
  File "/usr/lib/python2.4/glob.py", line 37, in glob
    sublist = glob1(dirname, basename)
  File "/usr/lib/python2.4/glob.py", line 49, in glob1
    names=filter(lambda x: x[0]!='.',names)
  File "/usr/lib/python2.4/glob.py", line 49, in <lambda>
    names=filter(lambda x: x[0]!='.',names)
IndexError: string index out of range

tob1as
Newbie
Newbie
Beiträge: 27
Registriert: 18. Okt 2005, 20:42

Beitrag von tob1as » 12. Sep 2006, 20:24

tob1as hat geschrieben:Ich schaff's irgendwie gar nicht mehr, smart-GUI zu starten..
Hm, aus heiterem Himmel funktioniert

Code: Alles auswählen

sux -c "smart --gui"
wieder..
Zuletzt geändert von tob1as am 14. Sep 2006, 16:58, insgesamt 1-mal geändert.
Bild

quedel
Member
Member
Beiträge: 53
Registriert: 4. Aug 2005, 11:16
Wohnort: Berlin
Kontaktdaten:

Beitrag von quedel » 14. Sep 2006, 04:14

ich habe auch das selbe Problem:

Code: Alles auswählen

marko:/home/marko # smart --gui
FEHLER!: Das System unterstützt keine 'gtk python' Schnittstelle
erhalte aber :

Code: Alles auswählen

 marko:/home/marko # smart install python-gtk
Lade Zwischenspeicher...
Update Zwischenspeicher...      ######################################## [100%]

WARNUNG!: python-gtk-2.9.2-3@i586 ist bereits installiert

Code: Alles auswählen

03:54 marko:/home/marko # python -c "import gtk"
Traceback (most recent call last):
  File "<string>", line 1, in ?
  File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 43, in ?
    from _gtk import *
ImportError: /usr/lib/python2.4/site-packages/gtk-2.0/gtk/_gtk.so: undefined symbol: gtk_print_settings_get_print_to_file

Code: Alles auswählen

04:09 marko:/home/marko # sux -c "smart --gui"
FEHLER!: Das System unterstützt keine 'gtk python' Schnittstelle
Hat jemand ne Idee?

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 14. Sep 2006, 16:36

Vielleicht möchtest Du uns noch die Distribution und die Versionsnummer von gtk2 verraten?

Oder aktualisier auf Verdacht einfach mal gtk2, das könnte bereits helfen.

Bei Dir passt nämlich python-gtk nicht zu gtk2, d.h. entweder ist gtk2 zu alt oder python-gtk zu neu.
openSUSE Factory - GNOME 2.32.1

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste