update von 9.3 auf 10.1 funktioniert nicht

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Netzzwerk
Newbie
Newbie
Beiträge: 4
Registriert: 30. Jul 2006, 23:04

update von 9.3 auf 10.1 funktioniert nicht

Beitrag von Netzzwerk » 9. Sep 2006, 11:53

Hallo,

Ich hab mir letztens das ct-Sonderheft über Linux gekauft. Hauptsächlich, weil Suse 10.1 beigelegt ist. Ich wollte damit mein momentanes System Suse 9.3 auf 10.1 updaten.

Um dass zu tun habe ich den PC von DVD booten lassen. Dann kam dann auch das Menu und alles; ich hab dann alles eingestellt auf Update usw.

und während der Installation bei irgendeinem Paket bleibt er dann hängen und sagt dann, dass das Paket nicht auf dem Medium zu finden sei. Dann wurde die Installation abgebrochen.

danach habe ich es nochmal versucht und ein paar Installations optionen geändert. Aber er blieb wieder hängen, diesmal an einem anderen Paket.

was soll ich tun um das System auf 10.1 up zu daten?

mfg Netzzwerk

Werbung:
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 9. Sep 2006, 12:12

Neuinstallieren.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

rue.fr
Member
Member
Beiträge: 69
Registriert: 28. Jan 2004, 11:44

Beitrag von rue.fr » 9. Sep 2006, 12:51

wie Grothesk
schon sagt neuinstall weil der sprung von 9.3 bei mir 9.2 doch zu groß ist und sich in der 10.1 versionen sehr viel verändert hat (und nicht unbedingt zum besseren) wie ich bis jetzt feststellen musste
SUSE 10.1; KDE 3.5.1; 2.6.16; AMD Sempron 2800+; ASUS a7n8x-e Deluxe; Sapphire ATi X 1600 512 MB AGP; 3ware 8006-2 RAID-Controller 2x250GB als RAID 1 :-)

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 9. Sep 2006, 14:59

LOL!

Bei einer Neuinstallation wäre es genau dasselbe. Das Problem hat nichts, aber auch wirklich gar nichts damit zu tun, dass das eine Update-Installation ist.

rue.fr, den Erklärungsversuch mit den angeblich so weit auseinanderliegenden Versionen finde ich ja wirklich niedlich und gut gemeint, aber dem Installer ist es echt völlig wurscht, welche Version installiert war; wenn er Pakete auf dem Installationsmedium nicht findet, dann liegt das an Dreck auf den Installations-CDs oder einem kaputten Laufwerk.

9.3 lässt sich problemlos auf 10.1 aktualisieren.
openSUSE Factory - GNOME 2.32.1

bike
Hacker
Hacker
Beiträge: 495
Registriert: 10. Jan 2005, 19:34

Beitrag von bike » 9. Sep 2006, 21:31

Der Fehler kommt mir bekannt vor.
Ich habe von SuSe 9.2 auf 10.1 upgedatet.
Ab dem Moment wenn ich die vorgeschlagene Software Konfiguration ändere, kommt das Problem. Es werden verschienden Pakete nicht gefunden.

Ich habe zunächst Standard installiert und dann nachinstalliert, dann ging es.

bike

Ergänzung: Bei der Paketintsallation siehst du ja bei welchem Paket das Problem auftritt. Dann bei einem neuen Versuch im Experten Modus das Programm abwählen. Später kannst du mit z.B. apt dies nachistallieren.

Netzzwerk
Newbie
Newbie
Beiträge: 4
Registriert: 30. Jul 2006, 23:04

Beitrag von Netzzwerk » 17. Sep 2006, 00:12

ich habe es nun mehrere male mit dem Update versucht, bis es mir mein Linux zerschossen hatte. Dann dachte ich mir, was solls, jetzt kannstes eh Neuinstallieren. Fehlanzeige!! bei der Neuinstallation passiert der selbe Fehler, und die Installation bricht ab.

das hat mir dann mein Bootloader zerstört, sodass ich dann wieder 9.3 installiert habe um den Bootloader wiederzustellen.

ich verstehe nicht wo das Problem liegt?

mfg Netzzwerk

Benutzeravatar
Ritschie
Member
Member
Beiträge: 138
Registriert: 22. Nov 2004, 15:56
Wohnort: Bayreuth

Beitrag von Ritschie » 17. Sep 2006, 04:03

Netzzwerk hat geschrieben:ich verstehe nicht wo das Problem liegt?
... und ich verstehe nicht, warum Du um jeden Preis auf die buggy 10.1 updaten willst!

Zudem ich oft höre, dass die Heft-CDs nicht laufen.

Zieh Dir die 10.0 (die es lang nicht so buggy, wie 10.1) oder bleib bei SuSE 9.3 - immernoch aktuell genug und wird nach wie vor mit Sicherheitsupdates versorgt.

Gruß,
Ritschie
Bild

carsten
Guru
Guru
Beiträge: 1632
Registriert: 27. Jan 2004, 13:27
Wohnort: Mittelhessen

Beitrag von carsten » 17. Sep 2006, 09:11

Die c't-Version ist eine echte DVD-Vollversion und läuft. Man muß halt die ersten updates ohne Änderungen einfach machen. und wenns durch ist nochmal, und nochmal... Dann ist es gut.

Grüße
Intel DB65ALB3, Chipsatz B65, Celeron G540, 4GB, 1x1TB System, 2x 2TB SATA RAID1, SuSE 13.2 (noch)

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 17. Sep 2006, 13:42

Netzzwerk hat geschrieben:Fehlanzeige!! bei der Neuinstallation passiert der selbe Fehler, und die Installation bricht ab.
Auch schon gemerkt? ;)

Das Problem hat nichts mit Neuinstallation vs. Update zu tun, sondern liegt entweder an einem defekten Installationsmedium oder an einem defekten Laufwerk.

Probier es mal mit der 5-CD-Version von opensuse.org anstelle der DVD, egal ob von opensuse.org oder aus irgendeiner Zeitschrift.
openSUSE Factory - GNOME 2.32.1

Netzzwerk
Newbie
Newbie
Beiträge: 4
Registriert: 30. Jul 2006, 23:04

Beitrag von Netzzwerk » 17. Sep 2006, 22:09

also mein DVD-Laufwerk ist ganz sicher nicht defekt!!
es muss also an der DVD selbst liegen. also würde es Helfen wenn ich mir einfach die Komplette Linux 10.1 Distribution aus dem Internet lade?

Benutzeravatar
JoachimUhl
Newbie
Newbie
Beiträge: 19
Registriert: 10. Apr 2006, 19:41
Wohnort: München
Kontaktdaten:

Beitrag von JoachimUhl » 18. Sep 2006, 00:20

Klar würde das helfen. Wenn Du die ISO dann noch sauber brennst müsste das locker gehen. Ich hatte diese Probleme auch mehrfach. Scheinbar sind die Medien unsauber gebrannt oder verkratzt.

Gruss

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 18. Sep 2006, 02:28

Lies mein Posting vom 2006-Sep-17, 12:42 pm nochmal und setz es um.

Ich zitiere mich mal selbst:
Probier es mal mit der 5-CD-Version von opensuse.org anstelle der DVD, egal ob von opensuse.org oder aus irgendeiner Zeitschrift.
Da der Satz offenbar nicht reicht, nochmal anders formuliert: Verwende keine DVD, weder die DVD, die man auf opensuse.org herunterladen kann noch die aus irgendeiner Zeitschrift, sondern die aus 5 herunterladbaren CDs bestehende Distribution von opensuse.org.
openSUSE Factory - GNOME 2.32.1

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast