Installation mit YAST ohne SWAP-Partition

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
samsa
Newbie
Newbie
Beiträge: 3
Registriert: 8. Sep 2006, 01:53

Installation mit YAST ohne SWAP-Partition

Beitrag von samsa » 8. Sep 2006, 02:02

Hallo,

ich habe vor kurzem einen Laptop geschenktbekommen und habe nun vor openSuSE 10.0 darauf zu installieren. Leider ist das CD-Rom-Laufwerk defekt, so habe ich mir die 7 Bootdisketten runtergeladen. Allerdings hat das Notebook nur 128 MB Ram (naja, so wenig ist das eigentlich nicht) und Yast scheint mehr zu brauchen. Gibt es eine Möglichkeit das Benutzen einer SWAP-Partition zu verhindern, da Yast ja die gesamte Festplatte neu Strukturiern will und da Yast auf die Swap-Partition während der Installation zugreift, kann es sie schlecht entfernen???
Kann man nicht die grafische Oberfläche ausschalten oder so ? Ich habe schon den Parameter textmode=1 beim Booten ausprobiert, nützt aber nichts.

cu samsa

Werbung:
jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 8. Sep 2006, 08:09

Du kannst das Rescue-Image starten und darin (hoffentlich) mit fdisk neu partitionieren.
Beim Booten manual=1 für Textmodus verwenden.

samsa
Newbie
Newbie
Beiträge: 3
Registriert: 8. Sep 2006, 01:53

Beitrag von samsa » 8. Sep 2006, 14:20

Danke für die Hilfe. Das mit dem Rescue-Image hab ich mir auch schon gedacht. Allerdings findet man das Ding nicht irgendwo im Internet, ich brauch erstmal ein openSUSE-10.0-Sytem und die passende DVD, um die Diskette erstmal zu erstellen, um ein openSUSE-10.0-System erstmal zu installieren. Ich komm mir vor wie beim Basteln eines CROSS-Compiler. Naja, wird schon klappen. Das mit manual muss ich ausprobieren, schade, dass die die Manual-Option aus dem Boot-Manager rausgenommen haben.

cu samsa

samsa
Newbie
Newbie
Beiträge: 3
Registriert: 8. Sep 2006, 01:53

Beitrag von samsa » 9. Sep 2006, 18:40

Also, nachdem ich yast nun sagen konnte, dass es die swap-partition in Ruhe lassen soll, habe ich wirklich ein opensuse-10.0-system installieren können, und das über Netztwerk. Ich habe mir ne 3. Partition eingerichtet, wo der Kernel und die ramdisk für ne Installation is, um notfalls das ganze booten zu können. Leider ist yast nun nach dem ersten Hochfahren des Systems hängengeblieben, jedesmal wenn es die Netzwerkkarte und alles erkennen will, egal, ob ich es überspringen möchte oder nicht. Was kann man dagegen tun? ich habe sicherheitshalber failsafe gebootet und das Powermanagement im BIOS ausgeschaltet, aber es klappt trotzdem nicht. Unter 10.0 gab es da keine Probleme.

Und: Danke für dei Hilfe.
cu samsa

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast