[solved] VLC Installation unter knoppix

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
odin2
Newbie
Newbie
Beiträge: 7
Registriert: 24. Jan 2005, 16:12

[solved] VLC Installation unter knoppix

Beitrag von odin2 » 2. Sep 2006, 18:29

Hallo zusammen,

Ich versuche Krampfhaft VLC unter Knoppix 4.0.2 (Kernel 2.6.12 HDD Installation) zu Installieren, aber als Linux Anfänger, bin ich mit mein Lateien am ende :(


bei der Installation erhalte ich immer wieder folgende fehlermeldung

< export DEBIAN_FRONTEND; apt-get install --yes 'vlc' ;echo RESULT=$?
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
instabile Distribution verwenden, einige erforderliche Pakete noch nicht
kreiert oder aus Incoming herausbewegt wurden.

Da Sie nur eine einzige Operation angefordert haben ist es sehr wahrscheinlich,
dass das Paket einfach nicht installierbar ist und eine Fehlermeldung über
dieses Paket erfolgen sollte.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
vlc: Hängt ab: libcaca0 soll aber nicht installiert werden
Hängt ab: libdvdnav4 (>= 0.1.10) aber 0.1.9-3 soll installiert werden
Hängt ab: libslang2 (>= 2.0.6-3) aber 2.0.6-2 soll installiert werden
Hängt ab: libwxgtk2.6-0 (>= 2.6.3.2.1.5) soll aber nicht installiert werden
Hängt ab: libxxf86vm1 soll aber nicht installiert werden
E: Kaputte Pakete
RESULT=100
habe jetzt schon libdvdnav4 und libslang2 selber aktualisiert, aber ich erhalte trotzdem immer wieder den selben fehlermeldung.
Habe auch schon die boardsuche benutzt, aber nicht wirklich was gefunden :(

Bin für jeden Tipp dankbar!

anbei noch meine Sourcen
# /etc/apt/sources.list for Knoppix
# If you want to do a "full upgrade", you should first
# upgrade the Packages from Debian/unstable (KDE & Co.)
# before doing a (dist-)upgrade for Debian/testing.
#
# See sources.list(5) for more information, especialy
# Remember that you can only use http, ftp or file URIs
# CDROMs are managed through the apt-cdrom tool.

# Security updates for "stable"
deb http://security.debian.org stable/updates main contrib non-free
deb http://security.debian.org testing/updates main contrib non-free

# Stable
deb http://ftp.de.debian.org/pub/debian stable main contrib non-free

# The non-US branch doesn't exist anymore since sarge. -KK
# deb http://ftp.de.debian.org/pub/debian-non-US stable/non-US main contrib non-free
# deb-src http://ftp.de.debian.org/pub/debian-non-US stable/non-US main contrib non-free
# deb-src http://ftp.de.debian.org/pub/debian-non-US testing/non-US main contrib non-free
# deb http://ftp.de.debian.org/debian-non-US unstable/non-US main contrib non-free
# deb-src http://ftp.de.debian.org/debian-non-US unstable/non-US main contrib non-free
# deb http://ftp.de.debian.org/pub/debian-non-US testing/non-US main contrib non-free

# Stable Sources
# deb-src http://ftp.de.debian.org/pub/debian stable main contrib non-free

# Testing
deb http://ftp.de.debian.org/pub/debian testing main contrib non-free

# Testing Sources
# deb-src http://ftp.de.debian.org/pub/debian testing main contrib non-free

# Unstable
deb http://ftp.de.debian.org/debian unstable main contrib non-free

# Unstable Sources
# deb-src http://ftp.de.debian.org/debian unstable main contrib non-free

# Experimental
deb http://ftp.de.debian.org/debian ../project/experimental main contrib non-free

# Experimental Sources
# deb-src http://ftp.de.debian.org/debian ../project/experimental main contrib non-free

# ndiswrapper source
deb http://ndiswrapper.sourceforge.net/debian ./

# KDE 3.4 (not in sarge)
# deb http://pkg-kde.alioth.debian.org/kde-3.4.1/ ./
# deb-src http://pkg-kde.alioth.debian.org/kde-3.4.1/ ./

# Unichrome graphics driver
# deb http://www.physik.fu-berlin.de/~glaweh/debian/ unichrome/
# deb-src http://www.physik.fu-berlin.de/~glaweh/debian/ unichrome/

# NX stuff
# deb http://www.kalyxo.org/debian/ experimental main
# deb http://www.kalyxo.org/debian/ unstable main

# ndiswrapper
# deb http://rigtorp.se/debian unstable/
# deb-src http://rigtorp.se/debian unstable/

# Blades Repository (pppoeconf & co)
# deb http://people.debian.org/~blade/testing ./
# deb-src http://people.debian.org/~blade/testing ./

# deb cdrom:[Debian GNU/Linux 2.2 r3 _Potato_ - Official i386 Binary-1 (20010427)]/ unstable contrib main non-US/contrib non-US/main

# Knoppix special packages resource at LinuxTag HQ
# deb http://developer.linuxtag.net/knoppix ./
# deb-src http://developer.linuxtag.net/knoppix ./

# deb http://snapshot.debian.net/archive pool gcc
# deb-src http://snapshot.debian.net/archive pool gcc

# From the Kanotix archives
deb http://kanotix.com/files/debian/ ./
# deb-src http://kanotix.com/files/debian/ ./

# Packages from ubuntu. CAUTION, they don't mix well with Debian
# deb http://de.archive.ubuntu.com/ubuntu hoary main universe multiverse
# deb-src http://de.archive.ubuntu.com/ubuntu hoary main universe multiverse

# VLC media player for Debian GNU/Linux stable (sarge)
deb http://download.videolan.org/pub/videolan/debian sarge main
deb-src http://download.videolan.org/pub/videolan/debian sarge main

# VLC media player for Debian GNU/Linux unstable (sid)
deb http://download.videolan.org/pub/videolan/debian sid main
deb-src http://download.videolan.org/pub/videolan/debian sid main

gruß
Odin

Werbung:
Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4207
Registriert: 14. Jun 2004, 09:12

Beitrag von Geier0815 » 4. Sep 2006, 12:58

Versuch mal "apt-get install vlc/testing" damit er versucht nicht aus unstable zu installieren. Du lernst gerade einen der Nachteile von Knoppix kennen: Knoppix verwendet einen Paketmix und setzt nicht sauber auf einem Zweig von Debian auf. Für eine Festplatteninstallation ist deshalb Kanotix besser geeignet, basiert allerdings auf unstable, deshalb sollte man regelmässig auf kanotix.com die Warnungen mitlesen.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

odin2
Newbie
Newbie
Beiträge: 7
Registriert: 24. Jan 2005, 16:12

Beitrag von odin2 » 4. Sep 2006, 17:04

hat sich erledigt.... beim versuch VLC zu installieren hat sich irgendwann das ganze System verabschiedet :(

Ich habe jetzt erstmal kubuntu raufgemacht und will damit erstmal probieren!

gruß
Odin

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast