APT Speicherzugriffsfehler

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
sykh
Newbie
Newbie
Beiträge: 2
Registriert: 29. Aug 2006, 22:15

APT Speicherzugriffsfehler

Beitrag von sykh » 29. Aug 2006, 22:20

Hallo,

mein APT läuft leider nichtmehr, vielleicht kann mir jemand von euch weiter helfen.
Folgendes Problem:

Apt Upgrade bringt folgende Meldung:

Code: Alles auswählen

apt upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Sie werden `apt-get --fix-broken install' ausführen wollen um diese zu beheben.
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  abiword: Hängt ab von: ghostscript-fonts-other
           Hängt ab von: gnome-icon-theme
           Hängt ab von: libORBit-2.so.0
           Hängt ab von: libatk-1.0.so.0
           Hängt ab von: libbonobo-2.so.0
           Hängt ab von: libbonobo-activation.so.4
           Hängt ab von: libbonoboui-2.so.0
           Hängt ab von: libcairo.so.2
           Hängt ab von: libgconf-2.so.4
           Hängt ab von: libgdk-x11-2.0.so.0
           Hängt ab von: libgdk_pixbuf-2.0.so.0
           Hängt ab von: libglib-2.0.so.0
           Hängt ab von: libglitz.so.1
           Hängt ab von: libgmodule-2.0.so.0
           Hängt ab von: libgnome-2.so.0
           Hängt ab von: libgnome-keyring.so.0
           Hängt ab von: libgnomecanvas-2.so.0
           Hängt ab von: libgnomeui-2.so.0
           Hängt ab von: libgnomevfs-2.so.0
           Hängt ab von: libgobject-2.0.so.0
           Hängt ab von: libgthread-2.0.so.0
           Hängt ab von: libgtk-x11-2.0.so.0
           Hängt ab von: libgucharmap.so.4
           Hängt ab von: libpango-1.0.so.0
           Hängt ab von: libpangocairo-1.0.so.0
           Hängt ab von: libpangoft2-1.0.so.0
           Hängt ab von: libpangoxft-1.0.so.0
           Hängt ab von: librsvg-2.so.2
  desktop-file-utils: Hängt ab von: libglib-2.0.so.0
  enchant: Hängt ab von: libglib-2.0.so.0
           Hängt ab von: libgmodule-2.0.so.0
  libglade2: Hängt ab von: libatk-1.0.so.0
             Hängt ab von: libcairo.so.2
             Hängt ab von: libgdk-x11-2.0.so.0
             Hängt ab von: libgdk_pixbuf-2.0.so.0
             Hängt ab von: libglib-2.0.so.0
             Hängt ab von: libglitz.so.1
             Hängt ab von: libgmodule-2.0.so.0
             Hängt ab von: libgobject-2.0.so.0
             Hängt ab von: libgtk-x11-2.0.so.0
             Hängt ab von: libpango-1.0.so.0
             Hängt ab von: libpangocairo-1.0.so.0
  libgnomecups: Hängt ab von: libglib-2.0.so.0
                Hängt ab von: libgobject-2.0.so.0
                Hängt ab von: libgthread-2.0.so.0
  libgnomeprint: Hängt ab von: libglib-2.0.so.0
                 Hängt ab von: libgmodule-2.0.so.0
                 Hängt ab von: libgobject-2.0.so.0
                 Hängt ab von: libpango-1.0.so.0
                 Hängt ab von: libpangoft2-1.0.so.0
  libgnomeprintui: Hängt ab von: libatk-1.0.so.0
                   Hängt ab von: libcairo.so.2
                   Hängt ab von: libgdk-x11-2.0.so.0
                   Hängt ab von: libgdk_pixbuf-2.0.so.0
                   Hängt ab von: libglib-2.0.so.0
                   Hängt ab von: libglitz.so.1
                   Hängt ab von: libgmodule-2.0.so.0
                   Hängt ab von: libgnomecanvas-2.so.0
                   Hängt ab von: libgobject-2.0.so.0
                   Hängt ab von: libgtk-x11-2.0.so.0
                   Hängt ab von: libpango-1.0.so.0
                   Hängt ab von: libpangocairo-1.0.so.0
                   Hängt ab von: libpangoft2-1.0.so.0
  libgnomesu: Hängt ab von: gnome-icon-theme
              Hängt ab von: libORBit-2.so.0
              Hängt ab von: libORBitCosNaming-2.so.0
              Hängt ab von: libatk-1.0.so.0
              Hängt ab von: libbonobo-2.so.0
              Hängt ab von: libbonobo-activation.so.4
              Hängt ab von: libbonoboui-2.so.0
              Hängt ab von: libcairo.so.2
              Hängt ab von: libdbus-1.so.2
              Hängt ab von: libdbus-glib-1.so.2
              Hängt ab von: libgconf-2.so.4
              Hängt ab von: libgdk-x11-2.0.so.0
              Hängt ab von: libgdk_pixbuf-2.0.so.0
              Hängt ab von: libglib-2.0.so.0
              Hängt ab von: libglitz.so.1
              Hängt ab von: libgmodule-2.0.so.0
              Hängt ab von: libgnome-2.so.0
              Hängt ab von: libgnome-keyring.so.0
              Hängt ab von: libgnomecanvas-2.so.0
              Hängt ab von: libgnomeui-2.so.0
              Hängt ab von: libgnomevfs-2.so.0
              Hängt ab von: libgobject-2.0.so.0
              Hängt ab von: libgthread-2.0.so.0
              Hängt ab von: libgtk-x11-2.0.so.0
              Hängt ab von: libhal-storage.so.1
              Hängt ab von: libhal.so.1
              Hängt ab von: libpango-1.0.so.0
              Hängt ab von: libpangocairo-1.0.so.0
              Hängt ab von: libpangoft2-1.0.so.0
  libgsf: Hängt ab von: libglib-2.0.so.0
          Hängt ab von: libgobject-2.0.so.0
  libidl: Hängt ab von: libglib-2.0.so.0
  libwmf: Hängt ab von: libgdk_pixbuf-2.0.so.0
          Hängt ab von: libglib-2.0.so.0
          Hängt ab von: libgmodule-2.0.so.0
          Hängt ab von: libgobject-2.0.so.0
  libwpd: Hängt ab von: libglib-2.0.so.0
          Hängt ab von: libgobject-2.0.so.0
  mozilla-xulrunner: PreDepends: pango
                     PreDepends: gtk2
                     PreDepends: atk
                     PreDepends: glib2
                     Hängt ab von: libORBit-2.so.0
                     Hängt ab von: libatk-1.0.so.0
                     Hängt ab von: libbonobo-2.so.0
                     Hängt ab von: libbonobo-activation.so.4
                     Hängt ab von: libbonoboui-2.so.0
                     Hängt ab von: libcairo.so.2
                     Hängt ab von: libgconf-2.so.4
                     Hängt ab von: libgdk-x11-2.0.so.0
                     Hängt ab von: libgdk_pixbuf-2.0.so.0
                     Hängt ab von: libglib-2.0.so.0
                     Hängt ab von: libglitz.so.1
                     Hängt ab von: libgmodule-2.0.so.0
                     Hängt ab von: libgnome-2.so.0
                     Hängt ab von: libgnome-keyring.so.0
                     Hängt ab von: libgnomecanvas-2.so.0
                     Hängt ab von: libgnomeui-2.so.0
                     Hängt ab von: libgnomevfs-2.so.0
                     Hängt ab von: libgobject-2.0.so.0
                     Hängt ab von: libgthread-2.0.so.0
                     Hängt ab von: libgtk-x11-2.0.so.0
                     Hängt ab von: libpango-1.0.so.0
                     Hängt ab von: libpangocairo-1.0.so.0
                     Hängt ab von: libpangoft2-1.0.so.0
  poppler: Hängt ab von: libcairo.so.2
           Hängt ab von: libglitz.so.1
  poppler-glib: Hängt ab von: libcairo.so.2
                Hängt ab von: libgdk-x11-2.0.so.0
                Hängt ab von: libgdk_pixbuf-2.0.so.0
                Hängt ab von: libglib-2.0.so.0
                Hängt ab von: libglitz.so.1
                Hängt ab von: libgmodule-2.0.so.0
                Hängt ab von: libgobject-2.0.so.0
                Hängt ab von: libpango-1.0.so.0
                Hängt ab von: libpangocairo-1.0.so.0
  shared-mime-info: PreDepends: glib2
                    Hängt ab von: libglib-2.0.so.0
E: Unerfüllte Abhängigkeiten. Versuchen Sie --fix-broken zu benutzen.
Nach einem apt -get upgrade --fix-broken stürtzt mein Apt mit einem Speicherzuggriffsfehler ab:

Code: Alles auswählen

apt-get upgrade --fix-broken
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Korrigiere Abhängigkeiten ... Fertig
Die folgenden Pakete werden upgegradet werden:
  abiword alsa enchant esound gnome-filesystem gnome-mime-data libart_lgpl libgnomecups libgnomeprint libgnomeprintui libgnomesu libgsf
  libidl libwpd mozilla-nspr mozilla-nss mozilla-xulrunner poppler poppler-glib psiconv
Die folgenden NEUEN Pakete werden installiert werden:
  atk cairo dbus-1 dbus-1-glib gconf2 ghostscript-fonts-other glib2 glitz gnome-icon-theme gnome-keyring gnome-vfs2 gtk2 gucharmap hal
  libbonobo libbonoboui libcroco libgnome libgnomecanvas libgnomeui librsvg orbit2 pango
20 upgegradet, 23 neu installiert, 0 entfernt und 0 nicht upgegradet.
Muss 0B/34,2MB an Archiven holen.
Nach dem Auspacken werden 55,6MB zusätzlicher Plattenplatz benutzt.
Wollen Sie fortsetzen? [J/n] j
Speicherzugriffsfehler
Auch der Yast Softwareinstaller ist nichtmehr ans laufen zu bekommen, hier das gleiche Problem.

Hat jemand eine Idee?

Tschau...

Thorsten

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 29. Aug 2006, 22:45

Hm.

Die Speicherzugriffsfehler in apt und YaST können zusammenhängen oder auch nicht.

Probier mal als root:

Code: Alles auswählen

rpm --rebuilddb
Mit etwas Glück ist das Problem dann gelöst.

Wenn das Problem danach immer noch besteht, dann sind es wahrscheinlich zwei verschiedene Probleme: Eines mit apt und eines mit YaST.

Welche SUSE-Version benutzt Du?

Code: Alles auswählen

cat /etc/SuSE-release
openSUSE Factory - GNOME 2.32.1

sykh
Newbie
Newbie
Beiträge: 2
Registriert: 29. Aug 2006, 22:15

Beitrag von sykh » 29. Aug 2006, 23:18

Vielen Dank, das hat mir weiter geholfen. Mein Apt läuf wieder :)


Tschau...

Thorsten

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste