gelöst: "server sent an invalid reply header" bei

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
bike
Hacker
Hacker
Beiträge: 497
Registriert: 10. Jan 2005, 19:34

gelöst: "server sent an invalid reply header" bei

Beitrag von bike » 29. Aug 2006, 21:31

Hallo,

wenn ich mit apt update versuche mein System zu aktualisieren bekomme ich folgende Meldung:
Gescheitert zu holen http://software.opensuse.org/download/K ... repomd.xml The http server sent an invalid reply header
Gescheitert zu holen http://software.opensuse.org/download/K ... repomd.xml The http server sent an invalid reply header
Wenn die Paketlisten erzeugt wird kommt folgende Meldung:
Erzeuge Abhängigkeitsbaum... Fertig
W: Release-Dateien einiger Repositories konnten nicht geholt oder authentifiziert werden. Derartige Repositories werden ignoriert.
W: Release file did not contain checksum information for http://software.opensuse.org/download/K ... rimary.xml
W: Release file did not contain checksum information for http://software.opensuse.org/download/K ... elists.xml

in meiner source list steht:
repomd http://software.opensuse.org/download/KDE:/KDE3 SUSE_Linux_10.0
repomd http://software.opensuse.org/download/KDE:/Backports SUSE_Linux_10.0


bei:
linux:/home/bike # apt policy apt
apt:
Installiert: 0.5.15lorg3-17.1
Kandidat: 0.5.15lorg3-17.1
Versionstabelle:
*** 0.5.15lorg3-17.1 0
100 RPM Database
linux:/home/bike # rpm -V apt
S.5....T c /etc/apt/apt.conf.d/apt.conf
S.5....T c /etc/apt/apt.conf.d/gpg-checker.conf
S.5....T c /etc/apt/sources.list

Ich habe SuSE 10.0 mit kde 3.5.4 und kernel
uname -a
Linux linux 2.6.13-15.8-default #1 Tue Feb 7 11:07:24 UTC 2006 i686 athlon i386 GNU/Linux

Kann mir bitte jemand schreiben, wo da der Fehler ist?

danke

bike
Zuletzt geändert von bike am 30. Aug 2006, 21:27, insgesamt 1-mal geändert.

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Re: Problem mit apt update/upgrade

Beitrag von traffic » 29. Aug 2006, 21:55

bike hat geschrieben:Kann mir bitte jemand schreiben, wo da der Fehler ist?
Ja gerne. Und jetzt halt Dich mal fest: Das ist sogar schon hypnotisch-prophylaktisch im Voraus passiert. Es ist nämlich bereits bekannt, dass es Probleme mit apt und den Redirector-URLs (download.opensuse.org, software.opensuse.org) gibt.

Verwende, bis das geklärt ist, direkt einen Mirror anstelle der Umleitung. Zum Beispiel folgende sources.list-Einträge anstelle der genannten:

Code: Alles auswählen

repomd http://download.uni-hd.de/ftp/pub/linux/opensuse/repositories/KDE:/KDE3 SUSE_Linux_10.0
repomd http://download.uni-hd.de/ftp/pub/linux/opensuse/repositories/KDE:/Backports SUSE_Linux_10.0
Außerdem wäre es nicht schlecht, wenn ein apt-Benutzer das mal auf der Mailingliste ansprechen könnte, damit dem nachgegangen werden kann.
openSUSE Factory - GNOME 2.32.1

bike
Hacker
Hacker
Beiträge: 497
Registriert: 10. Jan 2005, 19:34

gelöst: Re: Problem mit apt update/upgrade

Beitrag von bike » 30. Aug 2006, 21:12

traffic hat geschrieben:hypnotisch-prophylaktisch .
Uff, das ist eine Wortschöpfung ;-)
Danke für den Hinweis, so funktioniert es.

Kannst du mir vielleicht schreiben wo solche Infos( bezüglich Problemen oder ähnliches) zu finden sind?

danke


bike

B.Hannes
Member
Member
Beiträge: 102
Registriert: 24. Jan 2006, 22:20

Problem mit apt update/upgrade

Beitrag von B.Hannes » 31. Aug 2006, 22:41

Hallo traffic, Hallo bike,

mit YAST habe ich das gleiche Problem.

Ist es ein BUG oder woran kann es liegen? Bei APT habe ich den Server ftp.gwdg.de fest eingetragen.


Mit freundlichen Grüßen

B.Hannes

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast