apt: nvidia Treiber nicht fuer aktuellen kernel?

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
wh
Member
Member
Beiträge: 67
Registriert: 14. Nov 2005, 15:32

apt: nvidia Treiber nicht fuer aktuellen kernel?

Beitrag von wh » 29. Aug 2006, 14:33

Weches Forum? "Grafikkarten und Monitore", "APT - smartpm - YUM" oder gar "Kernel-Hacking"? Ich versuch es mal hier.

Habe versucht, entsprechend den Threads von
oc2pus http://www.linux-club.de/ftopic65601.html
Blackscreen und traffic http://www.linux-club.de/ftopic65597.html und
Z-City http://www.linux-club.de/ftopic65779.html
per apt den nvidia Treiber als Modul fuer den aktuellen Kernel zu installieren, und bin dabei gescheitert:

Mein Kernel ist:

Code: Alles auswählen

# uname -r
2.6.16.21-0.13-default
# apt policy kernel-default
kernel-default:
  Installiert: 2.6.16.21-0.13
  Kandidat: 2.6.16.21-0.13
  Versionstabelle:
 *** 2.6.16.21-0.13 0
        500 ftp://ftp4.gwdg.de SuSE/10.1-i386/update pkglist
        500 ftp://ftp4.gwdg.de SuSE/10.1-i386/security pkglist
        100 RPM Database
     2.6.16.13-4 0
        500 ftp://ftp4.gwdg.de SuSE/10.1-i386/base pkglist
und der Treiber:

Code: Alles auswählen

# apt policy nvidia-gfx-kmp-default
nvidia-gfx-kmp-default:
  Installiert: (nichts)
  Kandidat: 1.0.8762_2.6.16.21_0.8-1
  Versionstabelle:
     1.0.8762_2.6.16.21_0.8-1 0
        500 ftp://download.nvidia.com novell/ repomd
Folgende Installation lief (ohne --test) probemlos durch:

Code: Alles auswählen

# apt --test install nvidia-gfx-kmp-default
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Die folgenden zusätzlichen Pakete werden installiert werden:
  x11-video-nvidia
Die folgenden NEUEN Pakete werden installiert werden:
  nvidia-gfx-kmp-default x11-video-nvidia
0 upgegradet, 2 neu installiert, 0 entfernt und 0 nicht upgegradet.
Muss 0B/5641kB an Archiven holen.
Nach dem Auspacken werden 18,9MB zusätzlicher Plattenplatz benutzt.
Wollen Sie fortsetzen? [J/n]
Committing changes...
Preparing...                ########################################### [100%]
Fertig.
Es wurde (von apt) noch SaX2 durchlaufen (=> neues /etc/X11/xorg.conf).

Beim reboot wurde das Grafiksystem nicht gestartet. In /var/log/Xorg.0.log gab es eine Fehlermeldung (aus dem Gedaechtnis) wie: "kernel module nvidia.ko not found" oder so. Mit

Code: Alles auswählen

# rpm -e nvidia-gfx-kmp-default x11-video-nvidia
# sax2 -m 0=nvidia
# reboot
hab ich mein hand"geraffeltes" /lib/modules/2.6.16.21-0.13-default/kernel/drivers/video/nvidia.ko wieder aktivieren koennen.

Folgende Fragen hierzu:
Ist mit dem Hinweis von oc2pus
Wichtig:
Die Modul-Version im Repository MUSS zum aktuell installierten Kernel passen!
gemeint, dass kernel-default-2.6.16.21-0.13 und nvidia-gfx-kmp-default_1.0.8762_2.6.16.21_0.8-1 nicht zusammen passen?

Ist das bei smart anders? Auf die Frage von Blackscreen
Des Verständnis wegen: Kann man davon ausgehen daß Pakete mit dem Kernel kompatibel sind, solange die ersten 4 Ziffernteile identisch sind (z.B. 2.6.16.21-x.xx) und der hintere Teil (2.6.16.21-x.xx) ist nur eine Minor Version ?
schreibt traffic:
...Die Treiberpakete haben auch Symbole, und kompatibel sind sie, wenn alle Symbole zusammenpassen. Ob das der Fall ist, berechnet smart automatisch, d.h. ein inkompatibles Paket kann smart gar nicht installieren.
Oder bin ich hier voll daneben?
Zuletzt geändert von wh am 30. Aug 2006, 18:59, insgesamt 1-mal geändert.

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 29. Aug 2006, 20:11

Die Versionen müssen nicht genau zusammenpassen, wenn Du mit "genau" meinst, dass diese hier nicht OK wären:

kernel-default-2.6.16.21-0.13
nvidia-gfx-kmp-default-1.0.8762_2.6.16.21_0.8-1

Wie Du siehst, sind die fettgedruckten Releasenummern nicht ganz genau gleich, sie passen aber trotzdem zusammen. Es ist sogar der gewollte Effekt, dass diese Pakete über mehrere Kernel-Versionen hinweg funktionieren, solange die ABI sich nicht geändert hat.

Ob die Pakete zusammenpassen oder nicht, erkennt man nicht an den Releasenummern, sondern daran, dass sie sich installieren lassen. Würden sie nicht zusammenpassen, dann könntest Du sie gar nicht zusammen installieren.

Warum es bei Dir nicht ging, weiß ich nicht und kann ich mir nur ungefähr bekanntem Logfile-Eintrag auch nicht herausfinden. Es kämen mehrere andere Gründe in Frage:

- Zusätzlich zur bereits bekannten Tatsache, dass man vor der Installation dieses Pakets den Kernel aktualisieren muss, muss man auch sämtliche X.org-Patches installieren;

- Um interessante Wechselwirkungen zu vermeiden, wäre es mal einen Versuch wert, vor der Installation alle früher auf anderen Wegen installierten NVidia-Treiber zu entfernen;

- Das Verlinken des Kernelmoduls ins Modulverzeichnis des aktuellen Kernels wird durch ziemlich komplizierte Skripte erledigt, die evtl. fehlschlagen könnten, wenn die Umgebung nicht die vorgesehene ist, d.h. es wäre vielleicht mal einen Versuch wert, diese Installation mit YaST/YOU zu machen.

Zwischen apt und smart gibt es bei der Installation dieser Pakete hier keinen Unterschied.
openSUSE Factory - GNOME 2.32.1

wh
Member
Member
Beiträge: 67
Registriert: 14. Nov 2005, 15:32

Beitrag von wh » 29. Aug 2006, 22:38

Danke fuer die Tips, und gut zu wissen, dass die Versionsnummern nicht unbedingt uebereinstimmen muessen.

Was meinst Du mit
- Zusätzlich zur bereits bekannten Tatsache, dass man vor der Installation dieses Pakets den Kernel aktualisieren muss, muss man auch sämtliche X.org-Patches installieren;
???
Ist mein Kernel kernel-default-2.6.16.21-0.13 nicht der aktuelle und muss noch aktualisiert werden, und wenn ja, wo kann ich das nachlesen und finde diese und die X.org patches?

Ich werde morgen mit mehr Zeit und Ruhe die Installation noch einmal von "scratch" versuchen, und dabei die eventuell auftretenden Fehlermeldungen und die Links in /lib/modules besser dokumentieren und hier posten. Das Leben ohne Grafiksystem und vernueftigen Editor und Browser ist leider sehr gewoehnungsbeduerftig.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 29. Aug 2006, 22:49

Mit den X.org-Patches meine ich die Updates der xorg-x11-Pakete im regulären Update-Repository. Die haben nichts mit dem Kernel zu tun, der Kernel ist ja schon aktualisiert.

Falls Du mit "Installation von scratch" eine Neuinstallation des kompletten Betriebssystems meinst: Das wäre übertrieben und wahrscheinlich nicht notwendig.

Worin bestehen denn die Probleme mit dem Editor und mit dem Browser?
openSUSE Factory - GNOME 2.32.1

wh
Member
Member
Beiträge: 67
Registriert: 14. Nov 2005, 15:32

Beitrag von wh » 29. Aug 2006, 23:16

Mit den X.org-Patches meine ich die Updates der xorg-x11-Pakete im regulären Update-Repository. Die haben nichts mit dem Kernel zu tun, der Kernel ist ja schon aktualisiert.


Ich bringe mein System eigentlich jeden Tag per

Code: Alles auswählen

# apt update
# apt -s dist-upgrade
# apt --test install [neue Pakete]
# apt install [neue Pakete]
auf den neuesten Stand. Es sind folgende Pakete von xorg installiert:

Code: Alles auswählen

# rpm -qa | grep xorg
xorg-x11-fonts-scalable-6.9.0-48
xorg-x11-fonts-syriac-6.9.0-48
xorg-x11-man-6.9.0-48
xorg-x11-server-6.9.0-50.20
xorg-x11-fonts-100dpi-6.9.0-48
xorg-x11-fonts-75dpi-6.9.0-48
xorg-x11-6.9.0-50.17
xorg-x11-driver-options-6.9.0-48
xorg-x11-server-glx-6.9.0-50.17
xorg-x11-devel-6.9.0-48
xorg-x11-Xvnc-6.9.0-48
xorg-x11-libs-6.9.0-50.17
Ist hoffentlich auch aktuell.
Falls Du mit "Installation von scratch" eine Neuinstallation des kompletten Betriebssystems meinst: Das wäre übertrieben und wahrscheinlich nicht notwendig.
Sorry. Ich meinte, ich versuche noch einmal mit

Code: Alles auswählen

# apt install nvidia-gfx-kmp-default x11-video-nvidia 
anzufangen, eventuell wie vorgeschlagen den handgestrickten Kernel zu entfernen, reboot, usw.
Worin bestehen denn die Probleme mit dem Editor und mit dem Browser?
Wenn der nvidia Treiber wie beim letzten Mal nicht auf Anhieb laeuft, muss ich auf runlevel 3 ohne grafisches System mit vi, wget, bash usw. arbeiten, was ich nicht so gewohnt bin. Habe zur Zeit keinen weiteren Rechner zum parallel Arbeiten zur Verfuegung.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 29. Aug 2006, 23:28

Die xorg-x11-Pakete sind OK.

Wenn der nvidia-Treiber streikt, musst Du nicht im Runlevel 3 arbeiten, sondern Du kannst mit

Code: Alles auswählen

switch2nv
zum in X.org eingebauten, einfachen Treiber wechseln und mit

Code: Alles auswählen

switch2nvidia
wieder zurück.
openSUSE Factory - GNOME 2.32.1

wh
Member
Member
Beiträge: 67
Registriert: 14. Nov 2005, 15:32

Beitrag von wh » 30. Aug 2006, 18:24

Ich hoffe, es wird nicht zu lang, aber das Endergebnis war wieder negativ. Deshalb ein kleines Protokoll meines Vorgehens:

Zunaechst habe ich versucht, info zu switch2nv und switch2nvidia zu bekommen. Da weder man noch google etwas brauchbares geliefert hat:

Code: Alles auswählen

# switch2nv --help
------------------------------------------------------------------------
Switching the use of "nvidia" driver of NVIDIA to "nv" driver of X.Org
------------------------------------------------------------------------

warning: NVIDIA driver installed. Uninstalling NVIDIA driver first.
warning: Running "/usr/bin/nvidia-installer --uninstall -s" ... /usr/bin/switch2
nv: line 37: /usr/bin/tiny-nvidia-installer: Datei oder Verzeichnis nicht gefund
en
done

Patching /etc/X11/xorg.conf ... done
#

Na gut, gleich den alten Treiber deinstallieren. Also erst mal "apt install tiny-nvidia-installer" und nochmal:

Code: Alles auswählen

# switch2nv
------------------------------------------------------------------------
Switching the use of "nvidia" driver of NVIDIA to "nv" driver of X.Org
------------------------------------------------------------------------

warning: NVIDIA driver installed. Uninstalling NVIDIA driver first.
warning: Running "/usr/bin/nvidia-installer --uninstall -s" ...
WARNING: Your driver installation has been altered since it was initially
         installed; this may happen, for example, if you have since installed
         the NVIDIA driver through a mechanism other than the nvidia-installer
         (such as rpm or with the NVIDIA tarballs).  The nvidia-installer will
         attempt to uninstall as best it can.  Please see the file
         '/var/log/nvidia-installer.log' for details.

done

Patching /etc/X11/xorg.conf ... done
Ergebnis: kein nvidia.ko mehr in /lib/modules/2.6.16.21-0.13-default/kernel/drivers/video/ und im Logfile steht:

Code: Alles auswählen

# more /var/log/nvidia-installer.log
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Wed Aug 30 16:00:12 2006

option status:
  license pre-accepted    : true
  update                  : false
  force update            : false
  expert                  : false
  uninstall               : true
  driver info             : false
  no precompiled interface: false
  no ncurses color        : false
  query latest driver ver : false
  OpenGL header files     : true
  no questions            : true
  silent                  : true
  no backup               : false
  kernel module only      : false
  sanity                  : false
  add this kernel         : false
  no runlevel check       : false
  no network              : false
  no ABI note             : false
  no RPMs                 : false
  force tls               : (not specified)
  force compat32 tls      : (not specified)
  X install prefix        : /usr/X11R6
  OpenGL install prefix   : /usr
  compat32 install prefix : (not specified)
  installer install prefix: /usr
  utility install prefix  : /usr
  kernel name             : (not specified)
  kernel include path     : (not specified)
  kernel source path      : (not specified)
  kernel output path      : (not specified)
  kernel install path     : (not specified)
  proc mount point        : /proc
  ui                      : none
  tmpdir                  : /tmp
  ftp mirror              : ftp://download.nvidia.com
  RPM file list           : (not specified)

Using built-in stream user interface
-> Parsing log file:
-> done.
-> Validating previous installation:
-> Unable to access previously installed file
   '/usr/lib/libnvidia-tls.so.1.0.8762' (No such file or directory).
-> Unable to access previously installed file
   '/usr/lib/tls/libnvidia-tls.so.1.0.8762' (No such file or directory).
-> Unable to access previously installed file
   '/usr/lib/libnvidia-cfg.so.1.0.8762' (No such file or directory).
-> Unable to access previously installed file '/usr/X11R6/lib/libXvMCNVIDIA.a'
   (No such file or directory).
-> Unable to access previously installed file
   '/usr/X11R6/lib/libXvMCNVIDIA.so.1.0.8762' (No such file or directory).
-> Unable to access previously installed file
   '/usr/share/man/man1/nvidia-xconfig.1.gz' (No such file or directory).
-> Unable to access previously installed file
   '/usr/share/man/man1/nvidia-installer.1.gz' (No such file or directory).
-> Unable to access previously installed file
   '/usr/share/man/man1/nvidia-settings.1.gz' (No such file or directory).
-> Unable to access previously installed file '/usr/bin/nvidia-settings' (No
   such file or directory).
-> Unable to access previously installed file '/usr/bin/nvidia-xconfig' (No
   such file or directory).
-> Unable to access previously installed file '/usr/bin/nvidia-bug-report.sh'
   (No such file or directory).
-> Unable to access previously installed symlink '/usr/lib/libnvidia-tls.so.1'
   (No such file or directory).
-> Unable to access previously installed symlink
   '/usr/lib/tls/libnvidia-tls.so.1' (No such file or directory).
-> Unable to access previously installed symlink '/usr/lib/libnvidia-cfg.so.1'
   (No such file or directory).
-> Unable to access previously installed symlink '/usr/lib/libnvidia-cfg.so'
   (No such file or directory).
-> Unable to access previously installed symlink
   '/usr/X11R6/lib/libXvMCNVIDIA_dynamic.so.1' (No such file or directory).
-> done.
WARNING: Your driver installation has been altered since it was initially
         installed; this may happen, for example, if you have since installed
         the NVIDIA driver through a mechanism other than the nvidia-installer
         (such as rpm or with the NVIDIA tarballs).  The nvidia-installer will
         attempt to uninstall as best it can.  Please see the file
         '/var/log/nvidia-installer.log' for details.
-> Uninstalling NVIDIA Accelerated Graphics Driver for Linux-x86 (1.0-8762):
-> done.
-> Uninstallation of existing driver: NVIDIA Accelerated Graphics Driver for
   Linux-x86 (1.0-8762) is complete.
Na gut. Kann ich nicht beurteilen, ob irgendetwas Probleme macht. Aber:

Code: Alles auswählen

# switch2nvidia
------------------------------------------------------------------------
Switching the use of "nv" driver of X.Org to "nvidia" driver of NVIDIA
------------------------------------------------------------------------

# SaX generated X11 config file
Patching /etc/X11/xorg.conf ... done
aendert nur das xorg.conf, ohne das im Moment ueberhaupt ein nvdia Treiber da waere?

Also einen Installieren:

Code: Alles auswählen

# apt install nvidia-gfx-kmp-default x11-video-nvidia
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Die folgenden NEUEN Pakete werden installiert werden:
  nvidia-gfx-kmp-default x11-video-nvidia
0 upgegradet, 2 neu installiert, 0 entfernt und 0 nicht upgegradet.
Muss 0B/5641kB an Archiven holen.
Nach dem Auspacken werden 18,9MB zusätzlicher Plattenplatz benutzt.
Committing changes...
Preparing...                ########################################### [100%]
   1:x11-video-nvidia       ########################################### [ 50%]
/sbin/ldconfig: /usr/lib/libGLcore.so.1 is not a symbolic link

------------------------------------------------------------------------
Switching the use of "nv" driver of X.Org to "nvidia" driver of NVIDIA
------------------------------------------------------------------------

# SaX generated X11 config file
Patching /etc/X11/xorg.conf ... done
   2:nvidia-gfx-kmp-default ########################################### [100%]
Fertig.
Immerhin gibt es jetzt

Code: Alles auswählen

# ls -al /lib/modules/2.6.16.21-0.13-default/weak-updates/
insgesamt 8
drwxr-xr-x 2 root root 4096 2006-08-30 16:04 .
drwxr-xr-x 4 root root 4096 2006-08-30 16:04 ..
lrwxrwxrwx 1 root root   52 2006-08-30 16:04 nvidia.ko -> /lib/modules/2.6.16.21
-0.8-default/updates/nvidia.ko
# ls -al /lib/modules/2.6.16.21-0.8-default/updates/nvidia.ko
-rw-r--r-- 1 root root 5213635 2006-07-04 07:19 /lib/modules/2.6.16.21-0.8-defau
lt/updates/nvidia.ko
Die Fehlermeldung -- wenn es denn eine ist? -- ist korrekt:

Code: Alles auswählen

# ls -al /usr/lib/libGL*
lrwxrwxrwx 1 root root     10 2006-08-30 16:00 /usr/lib/libGL.so -> libGL.so.1
lrwxrwxrwx 1 root root     12 2006-08-30 16:00 /usr/lib/libGL.so.1 -> libGL.so.1
.2
-rwxr-xr-x 1 root root 375404 2006-05-02 10:17 /usr/lib/libGL.so.1.2
lrwxrwxrwx 1 root root     20 2006-07-22 11:36 /usr/lib/libGLU.so.1 -> libGLU.so
.1.3.060402
-rwxr-xr-x 1 root root 483152 2006-07-20 03:09 /usr/lib/libGLU.so.1.3.060402
-rwxr-xr-x 1 root root   2800 2006-05-02 10:17 /usr/lib/libGLcore.so.1
-rwxr-xr-x 1 root root   1184 2006-07-20 03:09 /usr/lib/libGLcore.so.1.0
lrwxrwxrwx 1 root root     15 2006-07-22 11:36 /usr/lib/libGLw.so.1 -> libGLw.so
.1.0.0
-rwxr-xr-x 1 root root  16912 2006-07-20 03:09 /usr/lib/libGLw.so.1.0.0
Keine Ahnung woher libGLcore.so.1 kommt, ob ich sie loeschen kann und einfach einen Link setzen soll, oder ignorieren?

Mal sehen was passiert, also reboot. Aber: keine Grafik, kein KDE...
Im /var/log/Xorg.0.log folgende Meldung:

Code: Alles auswählen

 # more /var/log/Xorg.0.log | grep EE
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.
Folgende Meldung fiel mir noch (erst zu diesem Zeitpunkt) im Xorg.0.log.old auf:

Code: Alles auswählen

 # more /var/log/Xorg.0.log.old < grep EE
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) Failed to load /usr/X11R6/lib/modules/extensions/libglx.so
(EE) Failed to load module "glx" (loader failed, 7)
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
(EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
(EE) NVIDIA(0):     you continue to encounter problems, Please try
(EE) NVIDIA(0):     reinstalling the NVIDIA driver.
switch2nv hilft auch nicht, wieder Grafik zu bekommen, auch nicht mit reboot. Also den nvidia Treiber wieder von Hand basteln:

Code: Alles auswählen

 # cd /usr/src/linux
 # make cloneconfig
 # make modules_prepare
 # cp /boot/symvers-2.6.16.21-0.13-default.gz /usr/src/linux
 # mv symvers-2.6.16.21-0.13-default.gz Module.symvers.gz
 # gunzip Module.symvers.gz
 # make modules_prepare
 # cd
 # sh NVIDIA-Linux-x86-1.0-8762-pkg1.run --kernel-source-path=/usr/src/linux -q
 # sax2 -m 0=nvidia
 # reboot
(init 5 klappt irgendwie nicht), um alles hier im Forum zu posten.

Wo liegt der Fehler?

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 30. Aug 2006, 18:30

Muss es unbedingt per apt sein?
Nimm dir mal einen dieser Wege vor:

http://www.linux-club.de/faq/Treiberinstallation_nVidia

Wobei ich fürchte, das dein System mittlerweile so zerbastelt ist, das die Anleitungen da auch nicht mehr helfen.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

wh
Member
Member
Beiträge: 67
Registriert: 14. Nov 2005, 15:32

Beitrag von wh » 30. Aug 2006, 18:58

Ich bin ja die Installation von Hand "gewoehnt", und die klappt ja auch soweit.

Yast/YOU muesste ich erst mal wieder aktivieren: mein System ist per "apt ugrade" von 10.0 -> 10.1 hochgefahren, da klappt YOU nicht auf Anhieb. Hab mich halt auf apt eingeschossen.

wh
Member
Member
Beiträge: 67
Registriert: 14. Nov 2005, 15:32

Beitrag von wh » 30. Aug 2006, 21:13

OK, muss mich korrigieren: YOU klappt doch relativ problemlos.

Installationsquellen ftp.gwdg.de/pub/suse/update/10.1 und download.nvidia.com/novell hinzugefuegt, Software installieren und loeschen, nvidia-gfx-kmp-default angeclickt und installiert.

reboot: keine Grafik, wie gehabt. Gleiche Fehlermeldung in /var/log/Xorg.0.log wie oben.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste