SLES 9 SP2: Yast friert bei einigen Modulen ein

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
lx0
Newbie
Newbie
Beiträge: 2
Registriert: 25. Aug 2006, 16:51

SLES 9 SP2: Yast friert bei einigen Modulen ein

Beitrag von lx0 » 25. Aug 2006, 17:19

Hallo zusammen,

ich bin zwar kein Linux-Neuling, allerdings arbeite ich selten mit SuSE. Ich habe nun ein Problem mit YaST im SLES 9 mit SP2.

YaST startet zunächst ganz normal, und die meisten Module funktionieren auch problemlos. Einige aber, darunter leider auch das Online-Update, frieren ein, sobald man sie aufruft. Das Problem tritt sowohl im grafischen als auch im ncurses-YaST auf. In der /var/log/Yast/y2log wiederholt sich immer wieder der folgende Textblock, solange das Program nicht mit "killall y2base" beendet wurde:

Code: Alles auswählen

2006-08-25 16:58:46 <1> ox(10681) [wfm] Y2CCScript.cc(createInLevel):157 Parsing finished
2006-08-25 16:58:46 <1> ox(10681) [Interpreter] online_update_dialogs.ycp:529 Calling YaST client online_update_start (arguments: [false, true])
2006-08-25 16:58:46 <3> ox(10681) [Interpreter] online_update_dialogs.ycp:9 Parser error
2006-08-25 16:58:46 <1> ox(10681) [Interpreter] online_update_dialogs.ycp:529 Called YaST client returned: nil
2006-08-25 16:58:46 <3> ox(10681) [Scanner] clients/online_update_start.ycp:27 Warning: Useless 'global' outside of module
2006-08-25 16:58:46 <3> ox(10681) [Scanner] clients/online_update_start.ycp:103 Warning: Useless 'global' outside of module
2006-08-25 16:58:46 <3> ox(10681) [Parser] clients/online_update_start.ycp:443 Undeclared identifier 'editUrl2'
2006-08-25 16:58:46 <1> ox(10681) [wfm] Y2CCScript.cc(createInLevel):157 Parsing finished
2006-08-25 16:58:46 <1> ox(10681) [Interpreter] online_update_dialogs.ycp:529 Calling YaST client online_update_start (arguments: [false, true])
2006-08-25 16:58:46 <3> ox(10681) [Interpreter] online_update_dialogs.ycp:9 Parser error
2006-08-25 16:58:46 <1> ox(10681) [Interpreter] online_update_dialogs.ycp:529 Called YaST client returned: nil
2006-08-25 16:58:46 <3> ox(10681) [Scanner] clients/online_update_start.ycp:27 Warning: Useless 'global' outside of module
2006-08-25 16:58:46 <3> ox(10681) [Scanner] clients/online_update_start.ycp:103 Warning: Useless 'global' outside of module
Andere Fehlermeldungen gibt es nicht; auch strace gibt nichts brauchbares aus.

Ich habe bereits versucht, alle Pakete neu zu installieren, die ansatzweise mit YaST zu tun haben könnten; darunter alle YaST-Module sowie Perl/YaST-Perl-Module und einige andere Sachen.

Zu dem Problem habe ich leider nicht viel im Netz gefunden; außer dass jemand anderes dieses Problem auch anscheinend nicht lösen konnte: http://lists.suse.com/archive/suse-sles ... /0116.html

Hat jemand eine Idee, was das Problem sein könnte und wie man es beheben könnte? Wenn weitere Infos nötig sind, werde ich die natürlich gerne posten.

Edit: Habe gerade die Reparatur-Routine von der Installations-CD laufen lassen. Es wurden tatsächlich Fehler mit YaST festgestellt; allerdings wurde das System (trotz anderslautender Meldung des Reparaturwerkzeugs) nicht repariert -- das Problem ist nach wie vor da.

Werbung:
lx0
Newbie
Newbie
Beiträge: 2
Registriert: 25. Aug 2006, 16:51

Re: SLES 9 SP2: Yast friert bei einigen Modulen ein

Beitrag von lx0 » 2. Sep 2006, 09:46

*bump*

Hat niemand eine Idee?

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste