Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Smart - Proxy Authentication

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
paranoia
Newbie
Newbie
Beiträge: 2
Registriert: 2. Jun 2006, 11:40
Kontaktdaten:

Smart - Proxy Authentication

Beitrag von paranoia » 22. Aug 2006, 21:41

Hallo,
ich habe folgendes Problem mit smart:
Wenn ich die Channel aktualisieren will, bekomme ich die Meldung
...Proxy Authentication Required.
Wie kann ich bei smart den Proxy-Benutzer einnstellen?
MfG

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 22. Aug 2006, 21:46

Über die Umgebungsvariable "http_proxy".

Außerdem muss python-curl installiert sein.

paranoia
Newbie
Newbie
Beiträge: 2
Registriert: 2. Jun 2006, 11:40
Kontaktdaten:

Beitrag von paranoia » 22. Aug 2006, 21:52

Kannst du mir genau erklären, wie man das mit der Umgebungsvariablen macht? Ich habe leider nicht so viel Ahnung, da ich ein Linux-Neuling bin.
MfG

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 22. Aug 2006, 21:59

OK, das ist jetzt etwas "tricky", weil die curl-Unterstützung im aktuellsten smart-Paket dank eines Patches zerstört wurde.

Also downgrade smart und smart-gui (falls vorhanden) erstmal auf die Version von den CDs, installiere anschließend curl und python-curl (aber nicht smart!) aus diesem Verzeichnis

http://software.opensuse.org/download/home:/cthiel1

und setze anschließend in $HOME/.profile die Umgebungsvariable:

Code: Alles auswählen

export http_proxy="http://username:password@servername:port/"
Nach einer Neuanmeldung ist die Umgebungsvariable dann gesetzt.

Das Problem mit diesem Patch wird wahrscheinlich bald behoben, danach kannst Du smart selbst auch wieder aktualisieren.

Antworten