Suse 10.1 Online Update klappt nicht

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

amswetter
Newbie
Newbie
Beiträge: 35
Registriert: 8. Dez 2005, 15:52

Suse 10.1 Online Update klappt nicht

Beitrag von amswetter » 16. Aug 2006, 14:25

Hi,

Ich durchsuche jetzt schon seit 2 Nächten das internet nach einer Lösung für mein Problem!

Es lautet folgendermaßen:

Ich habe Suse Linux 10.1 normal installiert. Ich habe keine Fehlermeldungen bekommen. Beim ersten Hochfahren wollte ich dann mal ein online update machen. Internetverbindung habe ich davor richtig eingestellt, ich habe also zugriff zum Internet.
Ich starte also über Yast2 das Onine Update und nix passiert, er öffnet ein Fenster und macht dann irgendetwas nur kriegt kein ergebnis, nach so 10 minuten sagt er dann Keine Patches verfügbar!

Was muss ich einstellen oder wo ist der Fehler?

Bitte um schnelle hilfe

Danke schon mal im voraus!

mfg AMSWETTER

Werbung:
b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 16. Aug 2006, 15:42

Ist überhaupt eine Update-Quelle eingerichtet?
Oder hast du diesen Punkt bei der Installation übersprungen?

YAST -> Software -> Online Update Konfiguration

Die Ausgabe von

Code: Alles auswählen

rug sl
(in der Konsole eingeben) wäre dann auch interessant.
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

sputnixx23

Online update suse 10.1 / "Dependency Resolution Failed

Beitrag von sputnixx23 » 26. Aug 2006, 18:14

Hallo,
ich habe ebenfalls einen Fehler beim online update.
Fehlertext: Dependency Resolution Failed

Im Hinweisfenster erscheint:
Establishing script:libzypp-patch-zmdrestart.sh-2-1533-1.noarch[SUSE-Linux-10.1-Updates]
This would invalidate script:libzypp-patch-zmdrestart.sh-2-1533-1.noarch[SUSE-Linux-10.1-Updates].
Marking this resolution attempt as invalid.

In YAST erscheint beim Aufruf der Einrichtung des Online updates ein leerer Bildschirm.

Weil ich dieses Problem nicht lösen konnte und auch im Netzt keine passende Antwort gefunden habe, hatte ich SUSE neu installiert. Leider ist der Fehler wieder da.
Hat einer eine Idee, wie ich da raus komme? Gibt es eine alternative Methode ohne "online update"?
Viele Grüße
sputnixx23

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Re: Online update suse 10.1 / "Dependency Resolution Fa

Beitrag von traffic » 26. Aug 2006, 21:56

sputnixx23 hat geschrieben:Leider ist der Fehler wieder da.
Welcher der ganzen Fehler (von denen nur ein Teil wirkiche Fehler sind) ist "wieder da"?

Du hast jetzt mehrere Probleme auf einmal beschrieben, dann neu installiert und am Ende gesagt, "der" Fehler sei wieder da. D.h. es ist offenbar nur einer, nicht wahr?

Könntest Du bitte unbedingt sagen, welcher das ist? Das wäre sehr wichtig, damit wir nicht parallel mehrere Probleme besprechen, von denen alle bis auf eines gar nicht mehr zutreffen.

foto-dami
Newbie
Newbie
Beiträge: 21
Registriert: 23. Aug 2006, 14:54
Wohnort: thüringen
Kontaktdaten:

Beitrag von foto-dami » 26. Aug 2006, 23:06

hallo,

der tip mit der online-update-konfiguration war eine hilfe für mich.
allerdings bekomme ich keine verbindung zum entsprechenden server. nach einer gewissen zeit kommt die fehlermeldung, daß die zeit überschritten wurde (wenn ich den englischen text richtig gedeutet habe - fehlermeldung: "Execute curl command failed with '28': curl: (28) connect() timed out!" - oder manchmal auch: "Execute curl command failed with '7': curl: (7) couldn't connect to host").
gibt es dafür eine erklärung?

gruß
micha
Zuletzt geändert von foto-dami am 27. Aug 2006, 00:25, insgesamt 1-mal geändert.
ich bin seit august 2006 neueinsteiger in die linux-welt - also blutiger anfänger.
verzeiht mir also bitte anfangs die eher einfältigen fragen - ich versuche vor dem posten mindestens hier im forum zu recherchieren.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 27. Aug 2006, 00:16

@foto-dami:

YaST -> Software -> Installationsquelle wechseln -> Hinzufügen -> URL angeben

http://suse.inode.at/pub/update/10.1

@sputnixx23:

Bitte unbedingt die Angabe nachliefern, welches der drei Probleme noch besteht - da alle schon oft besprochen und gelöst wurden, werde ich definitiv nicht alle drei nochmal auf Verdacht erklären.

foto-dami
Newbie
Newbie
Beiträge: 21
Registriert: 23. Aug 2006, 14:54
Wohnort: thüringen
Kontaktdaten:

Beitrag von foto-dami » 27. Aug 2006, 00:42

hab ich versucht.
nach ca. 10 minuten kam folgende meldung:
"instalationsquelle kann nicht von der url http://suse.inode.at/pub/update/10.1 erstellt werden."
was nun?
ich bin seit august 2006 neueinsteiger in die linux-welt - also blutiger anfänger.
verzeiht mir also bitte anfangs die eher einfältigen fragen - ich versuche vor dem posten mindestens hier im forum zu recherchieren.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 27. Aug 2006, 02:05

Dann bitte nacheinander alle Mirrors durchprobieren:

http://en.opensuse.org/YUM_servers

sputnixx23

Re: Online update suse 10.1 / "Dependency Resolution Fa

Beitrag von sputnixx23 » 27. Aug 2006, 13:10

traffic hat geschrieben:
sputnixx23 hat geschrieben:Leider ist der Fehler wieder da.
Welcher der ganzen Fehler (von denen nur ein Teil wirkiche Fehler sind) ist "wieder da"?

Du hast jetzt mehrere Probleme auf einmal beschrieben, dann neu installiert und am Ende gesagt, "der" Fehler sei wieder da. D.h. es ist offenbar nur einer, nicht wahr?

Könntest Du bitte unbedingt sagen, welcher das ist? Das wäre sehr wichtig, damit wir nicht parallel mehrere Probleme besprechen, von denen alle bis auf eines gar nicht mehr zutreffen.
Hallo traffic,
fangen wir mal mit dem eigentlichen Problem an:
ich will das online-update anstoßen und bekomme den die Fehlermeldung: "Dependency Resolution Failed" darunter der nachfolgende Text:
"Establishing script:libzypp-patch-zmdrestart.sh-2-1533-1.noarch[SUSE-Linux-10.1-Updates]
This would invalidate script:libzypp-patch-zmdrestart.sh-2-1533-1.noarch[SUSE-Linux-10.1-Updates].
Marking this resolution attempt as invalid."
Eine wiederholte Neuinstallation brachte nichts.
Was kann ich tun?
Viele Grüße
sputnixx23

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 27. Aug 2006, 13:32

Kommt das beim Onlineupdate via Yast-Software-Onlineupdate oder beim Klicken auf den ZEN-Updater (das orange Ausrufezeichen) ? Falls letzteres dann mach die ersten Online-Updates mit Yast-Software-Onlineupdate (wie schon -zigmal hier im Forum beschrieben)
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 27. Aug 2006, 18:40

1. Hör mal mit den ständigen Neuinstallationen auf. Eine Neuinstallation verbessert die Situation nicht, sondern verschlimmert sie und ist bei Linux fast immer der falsche Ansatz.

2. Verwende für das Update nicht das orangefarbene Icon rechts unten, sondern geh über "YaST -> Software -> Online-Update". Die Nichtbeachtung dieses Hinweises wird dazu führen, dass Du überhaupt nichts aktualisieren kannst.

3. Wenn derselbe Fehler auch beim Versuch über "YaST -> Software -> Online-Update" auftritt, dann melde Dich zurück.
openSUSE Factory - GNOME 2.32.1

foto-dami
Newbie
Newbie
Beiträge: 21
Registriert: 23. Aug 2006, 14:54
Wohnort: thüringen
Kontaktdaten:

Beitrag von foto-dami » 28. Aug 2006, 20:25

@traffic
ich bin gerade dabei alle mirrors (siehe oben) durchzuprobieren. allerdings erscheint oben genannte fehlermeldung bisher bei jedem versuch (die hälfte hab ich schon durchprobiert).
ich befürchte, das update-problem ist in einer anderen ursache zu suchen. ich habe übrigens auch keinen ZEN-Updater.
bei der installation des suse linux' (von dvd) war mein dsl-modem noch nicht angeschlossen. das hab ich hinterher erledigt.
am ende der installation von suse war ein teil (mit senden von systemdaten an novell und update - genau weiß ich das aber leider nicht mehr), den ich ich wegen fehlender internetverbindung übersprungen habe. vielleicht hat es damit etwas zu tun!?!
ist es denn eigentlich unbedingt notwendig, die updates machen zu können?

gruß micha

ps: das symbol unten rechts in der kontrolleiste von KDE (zum software-update) zeigt, wenn ich mit der maus darüber fahre an "There are no software updates available". mit der konfiguration komme ich auch nicht wirklich klar.
ich bin seit august 2006 neueinsteiger in die linux-welt - also blutiger anfänger.
verzeiht mir also bitte anfangs die eher einfältigen fragen - ich versuche vor dem posten mindestens hier im forum zu recherchieren.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 28. Aug 2006, 21:23

Dann mach mal folgendes:

- Das Software-Update-Symbol rechts unten komplett ignorieren, im Moment ausschließlich YaST verwenden

- Eine Online-Update-Installationsquelle hinzufügen:

YaST -> Software -> Installationsquelle wechseln -> Hinzufügen -> URL angeben

http://ftp.leo.org/pub/comp/os/unix/lin ... pdate/10.1

- Diese Befehle mit root-Rechten ausführen:

Code: Alles auswählen

mkdir -p /var/lib/zypp/db/patches.bak
mv /var/lib/zypp/db/patches/* /var/lib/zypp/db/patches.bak
- Jetzt das Online-Update anstoßen:

YaST -> Software -> Online-Update

- Nach Abschluss des Online-Updates den letzten Schritt wieder rückgängig machen:

Code: Alles auswählen

mv /var/lib/zypp/db/patches.bak/* /var/lib/zypp/db/patches
rmdir /var/lib/zypp/db/patches.bak
openSUSE Factory - GNOME 2.32.1

foto-dami
Newbie
Newbie
Beiträge: 21
Registriert: 23. Aug 2006, 14:54
Wohnort: thüringen
Kontaktdaten:

Beitrag von foto-dami » 28. Aug 2006, 21:31

jetzt kommt es ganz dumm (sorry):

wie und wo führe ich diese befehle aus?

es hapert ja bereits beim hinzufügen der url! das funktioniert ja bei keiner installationsquelle (siehe oben).
ich bin seit august 2006 neueinsteiger in die linux-welt - also blutiger anfänger.
verzeiht mir also bitte anfangs die eher einfältigen fragen - ich versuche vor dem posten mindestens hier im forum zu recherchieren.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 28. Aug 2006, 21:41

In einem Terminal:

Anwendungen-Menü -> System -> Terminals -> (irgendeines aussuchen)

Dann root-Rechte erlangen:

Code: Alles auswählen

su
Password: (hier das root-Passwort "blind" eintippen)
Und in dieser root-Shell dann die genannten Befehle ausführen.
openSUSE Factory - GNOME 2.32.1

foto-dami
Newbie
Newbie
Beiträge: 21
Registriert: 23. Aug 2006, 14:54
Wohnort: thüringen
Kontaktdaten:

Beitrag von foto-dami » 28. Aug 2006, 21:55

es entwickelt sich!

ich gehe davon aus, daß die 2 zeilen jeweils ein befehl sind, welche ich mit einem enter abschließe. desweiteren habe ich auch die leerzeichen mit eingegeben.
nach dem zweiten befehl kam dann folgende meldung:
mv: Aufruf von stat für „/var/lib/zypp/db/patches/*“ nicht möglich: Datei oder Verzeichnis nicht gefunden
ich bin seit august 2006 neueinsteiger in die linux-welt - also blutiger anfänger.
verzeiht mir also bitte anfangs die eher einfältigen fragen - ich versuche vor dem posten mindestens hier im forum zu recherchieren.

foto-dami
Newbie
Newbie
Beiträge: 21
Registriert: 23. Aug 2006, 14:54
Wohnort: thüringen
Kontaktdaten:

Beitrag von foto-dami » 28. Aug 2006, 22:00

kann es sein, daß es daran liegt, daß ich beim erstellen des verzeichnisses zwischen "-p" und "/var..." ein leerzeichen geschrieben habe?
ich bin seit august 2006 neueinsteiger in die linux-welt - also blutiger anfänger.
verzeiht mir also bitte anfangs die eher einfältigen fragen - ich versuche vor dem posten mindestens hier im forum zu recherchieren.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 28. Aug 2006, 22:06

Nein, daran liegt es nicht. Es liegt daran, dass das Verzeichnis von sich aus schon leer ist.

Überspring den Schritt einfach und mach mit dem Online-Update weiter.
openSUSE Factory - GNOME 2.32.1

foto-dami
Newbie
Newbie
Beiträge: 21
Registriert: 23. Aug 2006, 14:54
Wohnort: thüringen
Kontaktdaten:

Beitrag von foto-dami » 28. Aug 2006, 22:19

erstes problem:
nach dem hinzufügen der installationsquelle kam die schon weiteroben genannte fehlermeldung (installationsquelle kann nicht von der url ... erstellt werden. erneut versuchen ja-nein) dieses fenster ist noch offen. oder soll ich es lieber mit nein und beenden schließen?

zweites problem:
beim online-update kommt folgende fehlermeldung:
"another process is accessing the package database.
package management will not work"
ich bin seit august 2006 neueinsteiger in die linux-welt - also blutiger anfänger.
verzeiht mir also bitte anfangs die eher einfältigen fragen - ich versuche vor dem posten mindestens hier im forum zu recherchieren.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 28. Aug 2006, 22:32

Mach mal alle(!) YaST-Fenster zu, reboote vorsichtshalber auch noch den Rechner und versuch es danach nochmal.

Dass keine neue Installationsquelle hinzugefügt werden kann, wenn der Paketmanager gelockt ist, ist keine Überraschung.
openSUSE Factory - GNOME 2.32.1

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast