java verzeichnis finden gelöst !

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

java verzeichnis finden gelöst !

Beitrag von cc » 15. Aug 2006, 19:43

hallo

habe bei meinem suse 8.2 java 1.5.0 mit yast installiert:

Code: Alles auswählen

suse:/ # yast -i java-1_5_0-sun-1.5.0_03-0.1.i586.rpm

suse:/ # rpm -qa | grep java
java-1_5_0-sun-1.5.0_03-0.1
aber kann das neue java verzeichnis nicht finden.
unter /usr/lib sehe ich nur alte java versionen.
Zuletzt geändert von cc am 15. Aug 2006, 23:34, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
sparrow
Member
Member
Beiträge: 248
Registriert: 1. Mär 2005, 01:03
Wohnort: /home/sparrow

Beitrag von sparrow » 15. Aug 2006, 19:47

Verwendet das System bereits die neue Version?

Code: Alles auswählen

java -version
Wenn ja, mal schauen was er benutzt:

Code: Alles auswählen

which java
Sehr wahrscheinlich /usr/bin/java, wenn das auch deine Ausagabe ist schauen wir doch mal wohin der Link von dort geht

Code: Alles auswählen

ls -l /usr/bin/java
Zuhause in der Linux-Familie mit openSUSE 10.2 und Kubuntu 06.10

cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

Beitrag von cc » 15. Aug 2006, 20:37

Code: Alles auswählen

suse:/ # java -version
java version "1.4.2-01"
Java(TM) 2 Runtime Environment, Standard Edition (build Blackdown-1.4.2-01)
Java HotSpot(TM) Client VM (build Blackdown-1.4.2-01, mixed mode)
suse:/ # which java
/usr/lib/java/jre/bin/java
suse:/ # ls -l /usr/bin/java
ls: /usr/bin/java: No such file or directory

Benutzeravatar
sparrow
Member
Member
Beiträge: 248
Registriert: 1. Mär 2005, 01:03
Wohnort: /home/sparrow

Beitrag von sparrow » 15. Aug 2006, 20:55

Er benutzt nicht dir richtige Java virtuelle Maschine wie du siehst ;)

Ist das wirklich SuSE 8.2?
Das klingt ziemlich alt.


Versuch mal:

Code: Alles auswählen

update-alternatives --config java
Wenn das update-alternatives System verfügbar ist und dir RPMs aus den SUSE-Quellen installiert wurden müssten dann mehrere VMs auftauchen.
Dann gibst du einfach die Nummer der VM ein die du in zukunft nutzen willst, oder brichst mit STRG+C ab.
Auf jeden Fall siehst du so wo die JVMs liegen.

Gruß
Sparrow
Zuhause in der Linux-Familie mit openSUSE 10.2 und Kubuntu 06.10

cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

Beitrag von cc » 15. Aug 2006, 21:52

natürlich musste ich zuerst update-alternatives installieren,
bekomme aber keine auswahl.

Code: Alles auswählen

suse:/home # update-alternatives --config java
No alternatives for java.
suse:/home # rpm -qa | grep java
java-1_5_0-sun-src-1.5.0_03-0.1
java-1_5_0-sun-1.5.0_03-0.1
suse:/home # java -version
java version "1.4.2-01"
Java(TM) 2 Runtime Environment, Standard Edition (build Blackdown-1.4.2-01)
Java HotSpot(TM) Client VM (build Blackdown-1.4.2-01, mixed mode)

Benutzeravatar
sparrow
Member
Member
Beiträge: 248
Registriert: 1. Mär 2005, 01:03
Wohnort: /home/sparrow

Beitrag von sparrow » 15. Aug 2006, 21:58

Sehr seltsam.
Dann suchen wir jetzt halt die passende Java-Datei im Verzeichnisbaum:

Code: Alles auswählen

find / -type f -name "java"
Die Berechtigungsfehler kannst du ignorieren.
Zuhause in der Linux-Familie mit openSUSE 10.2 und Kubuntu 06.10

cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

Beitrag von cc » 15. Aug 2006, 22:12

Code: Alles auswählen

suse:/home # find / -type f -name "java"
/usr/lib/jvm/java-1.5.0-sun-1.5.0_03/jre/bin/java
/usr/lib/BlackdownJava2-1.4.2/jre/bin/java
/etc/sysconfig/java
/opt/etc-backup/sysconfig/java

Benutzeravatar
sparrow
Member
Member
Beiträge: 248
Registriert: 1. Mär 2005, 01:03
Wohnort: /home/sparrow

Beitrag von sparrow » 15. Aug 2006, 22:17

Da ist es, da ist es *freu*
/usr/lib/jvm/java-1.5.0-sun-1.5.0_03/jre/bin/java
jetzt weißt du wo es ist :)
Warum wolltest du das wissen?
Zuhause in der Linux-Familie mit openSUSE 10.2 und Kubuntu 06.10

cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

Beitrag von cc » 15. Aug 2006, 22:34

danke, aber mein problem ist immer noch nicht gelöst !

ich kann sslexplorer:

http://sourceforge.net/projects/sslexplorer/

nicht installieren, weil er minimum java 1.5.0 braucht.

Code: Alles auswählen

suse:/usr/local/sslexplorer # ./setup-sslexplorer
testing JVM in /usr/lib/java/jre ...
No suitable Java Virtual Machine could be found on your system.
The version of the JVM must be at least 1.5.0.
Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.
You can also try to delete the JVM cache file /root/.install4j

Benutzeravatar
sparrow
Member
Member
Beiträge: 248
Registriert: 1. Mär 2005, 01:03
Wohnort: /home/sparrow

Beitrag von sparrow » 15. Aug 2006, 22:43

Code: Alles auswählen

EXPORT INSTALL4J_JAVA=/usr/lib/jvm/java-1.5.0-sun-1.5.0_03/jre
./setup-sslexplorer
geht es so?

Alternativ den Link den du mit

Code: Alles auswählen

which java
herausfindest auf
/usr/lib/jvm/java-1.5.0-sun-1.5.0_03/jre/bin/java
ändern.
Zuhause in der Linux-Familie mit openSUSE 10.2 und Kubuntu 06.10

cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

Beitrag von cc » 15. Aug 2006, 23:12

verstehe nicht genau:

Code: Alles auswählen

suse:/home/sslexplorer # EXPORT INSTALL4J_JAVA=/usr/lib/jvm/java-1.5.0-sun-1.5.0_03/jre
-bash: EXPORT: command not found

suse:/home/sslexplorer # which java
/usr/lib/java/jre/bin/java
wie soll ich den link setzen ?

/usr/lib/java/jre/bin/java esistiert nicht.

Benutzeravatar
sparrow
Member
Member
Beiträge: 248
Registriert: 1. Mär 2005, 01:03
Wohnort: /home/sparrow

Beitrag von sparrow » 15. Aug 2006, 23:25

ah mist, klein.

Code: Alles auswählen

export INSTALL4J_JAVA=/usr/lib/jvm/java-1.5.0-sun-1.5.0_03/jre
./setup-sslexplorer
Zuhause in der Linux-Familie mit openSUSE 10.2 und Kubuntu 06.10

cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

Beitrag von cc » 15. Aug 2006, 23:27

problem gelöst !

1.) ich deinstallierte BlackdownJava2-1.4.2
2.) löschte die alten java einträge in /usr/lib
3.) SuSEconfig
4.) setzte den linlk:

Code: Alles auswählen

suse:/usr/local/sslexplorer # cd /usr/lib
suse:/usr/lib # ln -s /usr/lib/jvm/java-1.5.0-sun-1.5.0_03/jre/bin/java
5.)

Code: Alles auswählen

suse:/usr/lib # cd /usr/local/sslexplorer
suse:/usr/local/sslexplorer # ./setup-sslexplorer
testing JVM in /usr ...
Aug 15, 2006 11:16:18 PM java.util.prefs.FileSystemPreferences$3 run
INFO: Created system preferences directory in java.home.
Starting SSL Explorer in setup mode .....................................................
A browser has been opened and pointed to http://sue:28080.

Press CTRL+C or use the 'Shutdown' option from the web interface to leave setup mode.
p.s.
herzlichen dank !

Benutzeravatar
sparrow
Member
Member
Beiträge: 248
Registriert: 1. Mär 2005, 01:03
Wohnort: /home/sparrow

Beitrag von sparrow » 15. Aug 2006, 23:32

Schön, dass es funktioniert.

Magst du noch schnell deinen ersten Beitrag editieren und ein [gelöst] vor den Titel setzen?
Zuhause in der Linux-Familie mit openSUSE 10.2 und Kubuntu 06.10

cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

Beitrag von cc » 15. Aug 2006, 23:35

nur noch eine frage

was macht genau dieses command ?

Code: Alles auswählen

export INSTALL4J_JAVA=...

Benutzeravatar
sparrow
Member
Member
Beiträge: 248
Registriert: 1. Mär 2005, 01:03
Wohnort: /home/sparrow

Beitrag von sparrow » 15. Aug 2006, 23:39

Eine "Umgebungsvariable" setzen.
Programme können darauf zugreifen und den Wert auslesen.

Wenn du nur export in der Konsole eingibst siehst du, dass davon sehr viele definiert sind.

Dein Programm hat angeboten eine solche Variable zu setzen damit es die richtige JVM findet:
Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.

<edit>
und dann fällt mir auch noch auf, dass ich da das _HOME vergessen habe.
Verdammt... nicht mein Tag heute
Zuhause in der Linux-Familie mit openSUSE 10.2 und Kubuntu 06.10

cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

Beitrag von cc » 16. Aug 2006, 00:35

danke,

aber wo wird genau diese variable gesetzt und wie man sie wieder löschen kann ?
ich habe natürlich vieles ausprobiert und mag sein, dass ich unter anderen auch falsche variablen immer noch habe.

Benutzeravatar
sparrow
Member
Member
Beiträge: 248
Registriert: 1. Mär 2005, 01:03
Wohnort: /home/sparrow

Beitrag von sparrow » 16. Aug 2006, 00:45

Mach dir keine Gedanken.
Sie sind allerspätestens nach dem nächsten Reboot wieder weg, wahrscheinlich schon wenn du das Konsolenfenster schließt.

Die Variablen werden beim start aus Dateien ausgelesen uns gesetzt, dort haben wir sie aber nicht eingetragen.


Hier gibts viele Infos über die bash.
Zuhause in der Linux-Familie mit openSUSE 10.2 und Kubuntu 06.10

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast