Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] ]J2EE SDK 1.4_03 FCS auf Suse 10.0 installieren

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
antaeus
Newbie
Newbie
Beiträge: 41
Registriert: 15. Aug 2006, 13:27

[gelöst] ]J2EE SDK 1.4_03 FCS auf Suse 10.0 installieren

Beitrag von antaeus » 15. Aug 2006, 13:39

Hallo Gemeinde!

Kann mir bitte jemand erklären bzw. einen Link geben, wie ich unter Suse 10.0 J2EE SDK 1.4_03 FCS installieren kann. YAST bietet mir dieses Paket freiwillig nicht an, also habe ich es mir hier (https://sdlc1d.sun.com/ECom/EComActionS ... 2BD5BDC910) heruntergeladen. Leider stehe ich nun mit dem Download wie der sprichwörtliche Ochs vorm Berg da und weiß nicht was ich damit anfangen soll. Bei Sun selbst habe ich keine Installationshinweise gefunden und via Google habe ich das (http://www.torsten-horn.de/techdocs/jav ... UnterLinux) gefunden, nur funktioniert das nicht...

Für eure Hilfe besten Dank!
Zuletzt geändert von antaeus am 19. Aug 2006, 14:29, insgesamt 1-mal geändert.

Werbung:
b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 15. Aug 2006, 17:41

1. Java als Installationsquelle hinzufügen:
[HOWTO] Quellen für SuSE Linux 10.0

2. Anschließend: YAST -> Software -> Software installieren/löschen -> nach Java suchen ... :wink:
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

Benutzeravatar
antaeus
Newbie
Newbie
Beiträge: 41
Registriert: 15. Aug 2006, 13:27

Beitrag von antaeus » 15. Aug 2006, 21:06

Danke dir für die Antwort!

Ich habe nun diesen Server hinzugefügt:

Servername: ftp.gwdg.de
Verzeichnis: pub/opensuse/distribution/SL-10.0-OSS/inst-source-java

aber das SDK wird leider nicht unter den Quellen aufgelistet... (Oder ich bin blind!!). Auch wenn ich Pakete -> Entwicklung -> Sprachen -> Java mir anzeigen lasse, finde ich das gewünschte SDK nicht.

______________________

Mit meinem .bin-File bin ich etwas weiter gekommen. Ich wusste nicht, dass man das als ausführbar markieren muss, um es zu starten... :D *rotwerd* (aber ich bin auch seit gestern abend Linux-User, da darf man sowas noch nicht wissen).

Jedenfalls startet nun ein toller Installer, der auch ordentlich durchläuft. Ich habe mal alles auf den Einstellungen, die er mir vorschlägt gelassen, aber leider funktioniert der Java-Compiler, nach der Installation, nicht. (Oder liegt es etwas daran, dass ich den Java Application Server nicht gestartet habe!?

Ich schätze aber eher, dass das ein Pfad-Problem ist - oder so. Wie kann ich dem Linux beibringen, dass es die Pfade richtig setzt?

Benutzeravatar
sparrow
Member
Member
Beiträge: 248
Registriert: 1. Mär 2005, 01:03
Wohnort: /home/sparrow

Beitrag von sparrow » 15. Aug 2006, 21:41

Hallo antaeus,

erstmal willkommen im Club und in der Linux-Gemeinde.
Freut mich, dass du dich für SuSE und somit für Linux entschieden hast.

Könntest du mich mit Informationen füttern was du genau vorhast?
J2EE ist -> Enterprise Edition, also Web-Development.
Das ist dir klar?
Zuhause in der Linux-Familie mit openSUSE 10.2 und Kubuntu 06.10

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 15. Aug 2006, 21:43

Hm, für das SDK brauchst du imho
java-1_4_2-sun-devel bzw. java-1_5_0-sun-devel
Bei sind in dem Repositoriy vorhanden. :wink:

Für die manuelle Installation:
update-alternatives
=> Java mit YaST installieren

Pfade kannst du in der '/etc/profile.local' (Falls nicht vorhanden, anlegen) setzen.

Code: Alles auswählen

PATH=$PATH:/neuer/pfad
export PATH
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

Benutzeravatar
sparrow
Member
Member
Beiträge: 248
Registriert: 1. Mär 2005, 01:03
Wohnort: /home/sparrow

Beitrag von sparrow » 15. Aug 2006, 21:49

@b3ll3roph0n

Scheint so als will ern nicht das Standard SDK installieren, sonder das SDK für die Enterprise Edition.
Die sind nicht identisch.

Ich spiel das mal in einer VMWare Installation nach und schaue mal.
Zuhause in der Linux-Familie mit openSUSE 10.2 und Kubuntu 06.10

Benutzeravatar
antaeus
Newbie
Newbie
Beiträge: 41
Registriert: 15. Aug 2006, 13:27

Beitrag von antaeus » 15. Aug 2006, 22:27

Ja, richtig! Ich brauche die Enterprise Edition...

Wäre Super, wenn du, sparrow, das mal nachguggen könntest! Danke schon mal

Benutzeravatar
sparrow
Member
Member
Beiträge: 248
Registriert: 1. Mär 2005, 01:03
Wohnort: /home/sparrow

Beitrag von sparrow » 15. Aug 2006, 22:47

Sorry. hat einen Moment gedauert.
Die virtuelle Installation ist nicht so schnell.

Während der Installation fragt dich das Setup nach einem Installationspfad.
Bei mir /home/sparrow/SUNWappserver
der Compiler ist dann:
/home/sparrow/SUNWappserver/bin/jspc

Gruß
Sparrow
Zuhause in der Linux-Familie mit openSUSE 10.2 und Kubuntu 06.10

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 16. Aug 2006, 12:19

sparrow hat geschrieben:Scheint so als will ern nicht das Standard SDK installieren, sonder das SDK für die Enterprise Edition.
Die sind nicht identisch.
:oops:

Dann hat sich die Sache mit den Java*devel Paketen erledigt. :wink:
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

Benutzeravatar
antaeus
Newbie
Newbie
Beiträge: 41
Registriert: 15. Aug 2006, 13:27

Beitrag von antaeus » 16. Aug 2006, 22:16

Ja, jetzt funktioniert es "mehr oder weniger"...

Wobei mir noch eines nicht ganz klar ist: weswegen das Setup die nötigen Einstellungen für die Systemvariablen JAVAHOME etc nicht selbst setzt... Irgendwie komisch!

Naja, wie gesagt: es tut für den Augenblick! Ich danke euch.

Benutzeravatar
sparrow
Member
Member
Beiträge: 248
Registriert: 1. Mär 2005, 01:03
Wohnort: /home/sparrow

Beitrag von sparrow » 16. Aug 2006, 23:09

Ääähm...
ich glaube die Umgebungsvariablen brauchst du gar nicht. Ich glaube seit Version 1.4.2 von Java nicht mehr.

Und diese Installationsbeschreibung aus deinem ersten Post beziehts sich ausserdem auf das J2-SE-SDK (also das Java-Standad-Development-Kit), nicht auf das J2-EE-SDK (also die Enterprise Edition die du verwendest).
Standard: Applets und Programme in Java schreiben und compilen.
Enterprise. Web-Anwendungen (sog. Servlets) schreiben und compilen

Wenn du den compiler von überall her aufrufen können wilst, dann leg einfach einen Link darauf, und zwar aus dem Verzeichnis ~/bin auf den Compiler.

Bei mir wäre der Befehl:

Code: Alles auswählen

ln -s /home/sparrow/SUNWappserver/bin/jspc ~/bin/jspc
Zuhause in der Linux-Familie mit openSUSE 10.2 und Kubuntu 06.10

Benutzeravatar
antaeus
Newbie
Newbie
Beiträge: 41
Registriert: 15. Aug 2006, 13:27

Beitrag von antaeus » 17. Aug 2006, 22:53

Danke Sparrow! Das werde ich morgen testen!! Klingt so, als wäre es genau das, was ich wollte :)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste