[gelöst]: Keine Installation mit Yast,Kpackage,Smart möglich

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
haehnlein
Member
Member
Beiträge: 65
Registriert: 19. Feb 2004, 17:31

[gelöst]: Keine Installation mit Yast,Kpackage,Smart möglich

Beitrag von haehnlein » 12. Aug 2006, 01:45

Hallo,

ich habe ein Riesenproblem. Ich kann keine Software mehr installieren und löschen. Smart gibt mir folgende Abhängigkeitsprobleme:

Checking relations...
Unsatisfied dependency: antivir-avguard-2.1.5.24-11@i586 requires antivir = 2.1.5.24
Unsatisfied dependency: antivir-avguard-2.1.5.24-11@i586 requires hbedv-dazuko-kmp
Unsatisfied dependency: cups-1.1.23-39@x86_64 requires foomatic-filters
Unsatisfied dependency: cups-drivers-1.1.23-28@x86_64 requires foomatic-filters
Unsatisfied dependency: hplip-0.9.7-19@x86_64 requires foomatic-filters
Package kde3-i18n-de-3.5.4-69.2@noarch can't coexist with kde3-i18n-de-3.5.3-65.9@noarch
Unsatisfied dependency: kdebase3-devel-3.5.4-19.2@x86_64 requires kdebase3 = 3.5.4
Unsatisfied dependency: kdelibs3-devel-3.5.3-38.1@x86_64 requires kdelibs3 = 3.5.3
Package kdenetwork3-vnc-3.5.4-13.1@x86_64 can't coexist with kdenetwork3-vnc-3.5.3-8.1@x86_64
Package kdesdk3-translate-3.5.4-8.3@x86_64 can't coexist with kdesdk3-translate-3.5.3-6.4@x86_64
Package kdeutils3-laptop-3.5.4-9.2@x86_64 can't coexist with kdeutils3-laptop-3.5.3-3.10@x86_64
Unsatisfied dependency: libxine1-1.1.1-16.pm.0@x86_64 conflicts with xine-lib-1.1.1-24.6@x86_64
Package module-init-tools-3.2.2-32.13@x86_64 can't coexist with module-init-tools-3.2.2-32@x86_64
Unsatisfied dependency: novfs-kmp-default-1.2.0_2.6.16.21_0.13-9.2@x86_64 requires kernel(fs) = 278aa452c7f2316a
Unsatisfied dependency: novfs-kmp-default-1.2.0_2.6.16.21_0.13-9.2@x86_64 requires kernel(arch_x86_64_kernel) = 416b1834a3a1c96c
Unsatisfied dependency: novfs-kmp-default-1.2.0_2.6.16.21_0.13-9.2@x86_64 requires kernel(fs_proc) = 7b6a470a071ba4e4
Unsatisfied dependency: novfs-kmp-default-1.2.0_2.6.16.21_0.13-9.2@x86_64 requires kernel(mm) = 277a6b320d9419dc
Unsatisfied dependency: novfs-kmp-default-1.2.0_2.6.16.21_0.13-9.2@x86_64 requires kernel(kernel) = 8e533a71584e43b3
Unsatisfied dependency: novfs-kmp-default-1.2.0_2.6.16.21_0.13-9.2@x86_64 requires kernel(vmlinux) = 5ecc1117587c1f0f
Unsatisfied dependency: novfs-kmp-default-1.2.0_2.6.16.21_0.13-9.2@x86_64 requires kernel-default
Unsatisfied dependency: yast2-2.13.64.2-0.2@x86_64 requires yast2-pkg-bindings >= 2.13.43
Unsatisfied dependency: yast2-inetd-2.13.2-12@noarch requires yast2-packager
Unsatisfied dependency: yast2-installation-2.13.132.4-0.3@noarch requires yast2-packager >= 2.13.135
Unsatisfied dependency: yast2-installation-2.13.132.4-0.3@noarch requires yast2-pkg-bindings >= 2.13.86
Unsatisfied dependency: yast2-network-2.13.48-5@x86_64 requires yast2-packager
Unsatisfied dependency: yast2-nfs-server-2.13.3-12@noarch requires yast2-packager
Unsatisfied dependency: yast2-online-update-2.13.43-1.3@noarch requires yast2-pkg-bindings >= 2.13.88
Unsatisfied dependency: yast2-tv-2.13.8-8@noarch requires yast2-packager
Unsatisfied dependency: yast2-update-2.13.26-3@x86_64 requires yast2-packager

Deinstallationen mit Smart funktionieren überhaupt nicht mehr. Die Pakete sind beim nächsten Dependency-Check immer noch installiert.

Möchte ich nun ein Paket z.B. per Kpackage installieren kommt folgende Fehlermeldung:

</packages/yast2-perl-bindings-2.13.5-1.3.x86_64.rpm';echo RESULT=$?
rpmdb: PANIC: Invalid argument
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from dbcursor->c_put: DB_RUNRECOVERY: Fatal error, run database recovery
error: error(-30977) storing record README into Basenames
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery
error: error(-30977) getting "YaPI.html" records from Basenames index
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery
error: error(-30977) getting "YaST__YCP.html" records from Basenames index
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery
error: error(-30977) getting "typeinfo" records from Basenames index
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->sync: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->open: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Group index using db3 - (-30977)
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->open: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Requirename index using db3 - (-30977)
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->open: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Providename index using db3 - (-30977)
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->open: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Dirnames index using db3 - (-30977)
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->open: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Requireversion index using db3 - (-30977)
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->open: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Provideversion index using db3 - (-30977)
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->open: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Installtid index using db3 - (-30977)
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->open: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Sigmd5 index using db3 - (-30977)
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->open: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Sha1header index using db3 - (-30977)
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->open: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Filemd5s index using db3 - (-30977)
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->sync: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->sync: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->sync: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from dbenv->close: DB_RUNRECOVERY: Fatal error, run database recovery
RESULT=1

Versuche Pakete mit der Konsole zu installieren scheitern ebenfalls:

linux-7idj:/home/haehnlein/Desktop/packages # rpm -ivh *.rpm
error: File not found by glob: *.rpm
linux-7idj:/home/haehnlein/Desktop/packages #

Gibt es noch eine letzte Möglichkeit das System zum Laufen zu bringen ohne Neuinstallation?

Danke!
Zuletzt geändert von haehnlein am 15. Aug 2006, 09:58, insgesamt 2-mal geändert.
Grüße Christian

--------------------
Suse 11.0 64 bit, Acer Aspire 5104WLMi, AMD Turion X2 64 x2, 2 GB Ram, 160 GB Sata

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 12. Aug 2006, 07:01

Als root einmal

Code: Alles auswählen

rpm --rebuilddb
ausführen.

haehnlein
Member
Member
Beiträge: 65
Registriert: 19. Feb 2004, 17:31

Beitrag von haehnlein » 14. Aug 2006, 20:57

cool, es funzt wieder. danke! was macht eigentlich dieser befehl?
Grüße Christian

--------------------
Suse 11.0 64 bit, Acer Aspire 5104WLMi, AMD Turion X2 64 x2, 2 GB Ram, 160 GB Sata

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 14. Aug 2006, 21:05

Der baut deine rpm-Datenbank wieder auf. Da lag wohl was quer.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 15. Aug 2006, 05:29

Wenn das Problem damit gelöst ist, dann markier den Thread bitte noch als "gelöst".
(Deinen ersten Beitrag editieren und ein [gelöst] zum Titel hinzufügen)
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste