Fehlermeldung bei Online-Update

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Faraday
Newbie
Newbie
Beiträge: 48
Registriert: 3. Aug 2005, 20:54

Fehlermeldung bei Online-Update

Beitrag von Faraday » 8. Aug 2006, 17:47

Hallo Freunde.
Ich habe Suse Linux 10.1 per Netzwerkinstallation aus dem Internet installiert, was perfekt geklappt hat. Ich versuche nun ein (erstes) Online-Update zu machen mit der "Software-Aktualisierungsfunktion". Hierbei werden 174 Pakete zur Aktualisierung gefunden und angezeigt. Beim Klick auf "Aktualisieren" kommt allerdings die Fehlermeldung

Dependency Resolution Failed.
Establishing script:libzypp-patch-zmdrestart.sh-2-1533-1.noarch[SUSE-Linux-10.1-Updates]
This would invalidate script:libzypp-patch-zmdrestart.sh-2-1533-1.noarch[SUSE-Linux-10.1-Updates].
Marking this resolution attempt as invalid.


Weiß jemand, was ich da falsch mache? Hilfe! Bin Linux-Neuling. :roll:

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 8. Aug 2006, 17:51

Mach das erste Update nicht mit der "Software-Aktualisierungsfunktion", sondern mit YaST:

YaST -> Software -> Online-Update

Wenn es dort denselben oder einen ähnlichen Fehler gibt, melde dies bitte zurück.

Nach dem ersten Online-Update mit YaST kann man weitere Updates mit der "Software-Aktualisierungsfunktion" machen.

Faraday
Newbie
Newbie
Beiträge: 48
Registriert: 3. Aug 2005, 20:54

Beitrag von Faraday » 8. Aug 2006, 18:02

Auch mit YAST gibt es ein Problem: dort werden "keine Patches verfügbar" angezeigt. Internet geht, auf dem Rechner war vorher Suse 10.0 installiert, was perfekt lief.
Welche Server sollte ich unter "Installationsquelle wechseln" eingetragen haben? Dort steht bei mir jetzt der 134.76.11.100 mit dem Pfad

pub/opensuse/distribution/SL-10.1/inst-source

ist das korrekt?

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 8. Aug 2006, 18:06

Dieser Pfad ist die Basis-Installationsquelle, die Updates sind aber in einer separaten Installationsquelle.

YaST -> Software -> Installationsquelle wechseln -> Hinzufügen -> URL angeben

http://suse.inode.at/pub/update/10.1

Faraday
Newbie
Newbie
Beiträge: 48
Registriert: 3. Aug 2005, 20:54

Beitrag von Faraday » 8. Aug 2006, 18:22

Danke, das funktioniert jetzt perfekt! Sowas müßte halt der Anfänger irgendwo gesagt kriegen.. :) Das Forum hier ist echt klasse!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast