SUSE 10.1: YAST Installtionsquelle wechseln schließt nicht

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
brtz
Newbie
Newbie
Beiträge: 18
Registriert: 8. Aug 2006, 01:01

SUSE 10.1: YAST Installtionsquelle wechseln schließt nicht

Beitrag von brtz » 8. Aug 2006, 01:37

habe heute nach ein wenig Erfahrung mit SUSE 10.0 retail die 10.1 oss auf dem Laptop meiner Freundin installiert. (GERICOM, Pentium M 1800, 256 Mb RAM).
Treiber für Grafik, Sound, DSL usw. sind installiert, bzw. waren es schon und laufen prima.

Nachdem ich mehrere Installationsquellen hinzugefügt habe, will das Programm "Medien, die den Softwarekatalog enthalten" nicht mehr schließen. (schon seit 2 Stunden). Die Quellen stammen ausnahmslos von opensuse.org

versucht Yast deren Inhalt zu indizieren oder bin ich einem bug aufgesessen?

Davor hatte es noch geklappt, als ich nur einen Packman Mirror drin hatte.
no further comments.

Werbung:
obec
Advanced Hacker
Advanced Hacker
Beiträge: 1193
Registriert: 27. Dez 2005, 21:34
Wohnort: /home/obec

Beitrag von obec » 8. Aug 2006, 01:52

Hi,

gehört das in Office forum ?
256MB RAM ist für SuSE hart an der grenze!

Gruß

obec
openSuSE 11.0
Mandriva Linux 2008 Spring
Gigabyte P35-DS3
Intel Pentium D Prozessor 3,40GHZ
4096 MB Arbeitsspeicher
Nvidia Geforce 7600GS 512MB

brtz
Newbie
Newbie
Beiträge: 18
Registriert: 8. Aug 2006, 01:01

Beitrag von brtz » 8. Aug 2006, 01:56

1. Frage: nein. kann mal passiern bei tabbed browsing.
2. Ja, ist nicht viel langsamer als mein Desktop mit 1024 Mb RAM.
no further comments.

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Re: SUSE 10.1: YAST Installtionsquelle wechseln schließt nic

Beitrag von b3ll3roph0n » 8. Aug 2006, 02:02

brtz hat geschrieben:Nachdem ich mehrere Installationsquellen hinzugefügt habe, [...]
Wie viele Quellen denn und welche genau?
brtz hat geschrieben:Davor hatte es noch geklappt, als ich nur einen Packman Mirror drin hatte.
Mirror? Ich hoffe nicht dass du mehrmals die selbe Installationsquelle hinzugefügt hast?

PS:
[HOWTO] Pimp my SuSE !
[HOWTO] Quellen für SuSE Linux 10.1

Und 256 MB ist wirklich ein bisschen wenig (zumindest für KDE/Gnome).
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

brtz
Newbie
Newbie
Beiträge: 18
Registriert: 8. Aug 2006, 01:01

Beitrag von brtz » 8. Aug 2006, 02:26

Danke für die themenbezogene Antwort trotz falschem Forums, b3ll3roph0n!

Quellen stammen von dort:
http://de.opensuse.org/Zus%C3%A4tzliche ... 3%BCr_YaST

waren ungefähr fünf verschiedene, davon jedoch 2 vom ftp.gwdg.de, jedoch unterschiedliche Verzeichnisse. Dazu zwei Packman, einmal ilmenau, einmal erlangen glaub´ ich.
Die hab ich mittlerweile gelöscht, und nach zweieinhalb Stunden hat sich das angesprochene Problem endlich von selbst geschlossen.
Nur hab ich das "installationmedium wechseln" Ding jetzt wieder aufgemacht und es will wieder nicht schließen ("Sanduhr für immer").

Ansonsten reichen die 256 MB hervorragend, Blender z.B. rendert Animationen schneller als meine alte P III Coppermine 1000 Dualcore "Workstation" @1166, und das Multitasking ist ausreichend solange ich nicht mehr als vier große Programme (z.B. Firefox, Blender, Open Office, KTorrent) gleichzeitig nutze.
no further comments.

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 8. Aug 2006, 02:45

brtz hat geschrieben:[...] waren ungefähr fünf verschiedene, davon jedoch 2 vom ftp.gwdg.de, jedoch unterschiedliche Verzeichnisse. Dazu zwei Packman, einmal ilmenau, einmal erlangen glaub´ ich.
Die Frage war: welche genau :roll:
Du brauchst für YAST pro Installatiosquelle nur einen Mirror - alles andere verlangsamt YAST unnötig.
=> Alles doppelte rausschmeißen.

Wichtige / Sinnvolle Quellen findest du in den oben verlinkten Threads.
(Installationsquelle, AddOn Quelle und Packman - alles andere bei bedarf ...)
brtz hat geschrieben:[...] Ansonsten reichen die 256 MB hervorragend, [..]
Ansichtssache 8) - Ist aber nicht das eigentliche Problem
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

brtz
Newbie
Newbie
Beiträge: 18
Registriert: 8. Aug 2006, 01:01

Beitrag von brtz » 8. Aug 2006, 03:12

welche Quellen genau kann bzw. will ich nicht mehr rekonstruieren.
Habe alle rausgeschmissen bis auf die Installations-DVD.

Braucht immer noch ewig zum Schließen (glaub ich wenigstens, ist nämlich noch nicht zu), nachdem ich jetzt so weit gekommen bin, die Liste in die Steinzeit zu befördern.
Hab mittlerweile die gewünschten Pakete mittels
rpm -Uvh bla.bla installiert.

danke für die sinnvollen Links, vielleicht lag es ja an mehreren YUM Quellen.

Mal sehn was später nach ´nem Neustart passiert. Ich penn jetzt und träum von Commodore-Basic.
no further comments.

brtz
Newbie
Newbie
Beiträge: 18
Registriert: 8. Aug 2006, 01:01

Beitrag von brtz » 8. Aug 2006, 09:37

Problem gefunden:

ZENworks Management Daemon.

nach erzwungenem Runterfahren: "shutting down ZENworks Management Daeomon --- failure; aufgehängt.

Nach Neustart Hilfe befragt: zmd --non-daemon
Yast schließt wieder. Fehlermeldung in etwa: Fehler beim Synchronisieren mit zmd. Änderungen trotzdem speichern?

Also doch nix von wegen Quellendisaster.

Wie also zmd richtig konfigurieren?

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 8. Aug 2006, 09:41

Am besten gar nicht. Das Ding reagiert manchmal halt sehr träge. Aber es gibt ja Alternativen zu ZEN. smart oder apt sei an dieser Stelle genannt.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

brtz
Newbie
Newbie
Beiträge: 18
Registriert: 8. Aug 2006, 01:01

Beitrag von brtz » 8. Aug 2006, 10:20

danke fürs Verschieben in das richtige Forum.

Der Alternativen bin ich mir bewusst. Hatte aber bisher nicht das Verlangen, mich darin einzuarbeiten, weil ich die zentralistische Yast-Lösung recht elegent fand (vielleicht eine faschistische Tendenz in meinem Unterbewusstsein?)

soll ich den daemon generell killen zwecks Ressourcenauslastung, oder wäre das unklug?

wie verhält es sich mit y2pmsh? ebenfalls brauchbar?
no further comments.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 8. Aug 2006, 11:18

Du kannst:

- zmd deaktivieren/runterwerfen (YaST nutzt den zmd, wenn er installiert ist, braucht ihn aber nicht, d.h. läuft auch, wenn er nicht installiert ist)

- y2pmsh benutzen (y2pmsh nutzt den zmd überhaupt nicht, selbst wenn er aktiviert ist)

- etwas ganz anderes benutzen...

Einfach für eine Variante entscheiden.

brtz
Newbie
Newbie
Beiträge: 18
Registriert: 8. Aug 2006, 01:01

Beitrag von brtz » 8. Aug 2006, 11:48

Einfach für eine Variante entscheiden.
haha, "Einfach". Muss mich zwischen Hinkebein, Skylla und Charybdis entscheiden.

Naja, mittlerweile hat endlich ein Yast-update funktioniert, smart ist installiert, apt-get nicht auf der cd. Mal sehn ob mein aktualisiertes Yast so sauber läuft, wie ich es von SUSE 10.0 gewohnt bin.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 8. Aug 2006, 12:27

brtz hat geschrieben:haha, "Einfach". Muss mich zwischen Hinkebein, Skylla und Charybdis entscheiden.
Typischer Multiplikationseffekt... :roll:

y2pmsh kann bspw. gar nicht Hinkebein, Skylla oder Charybdis sein, weil es seit Ewigkeiten nicht mehr angerührt wurde (da steckt immer noch der alte zypp- und zmd-freie yast2-packagemanager drin!) und das YaST Online Update funktioniert "eigentlich" - vielleicht könntest Du das Problem genauer beschreiben?

Ansonsten: Es geht einfach darum, dass es relativ ineffizient ist, hier jetzt alle Paketmanager in einem Thread parallel zu behandeln, wenn Du am Ende doch nur einen benutzt. Am Ende wird es doch wieder nur ein "Alles so furchtbar"-Thread.

smart ist sicherlich keine schlechte Wahl, konfigurier jetzt erst mal den und dann sehen wir weiter.

brtz
Newbie
Newbie
Beiträge: 18
Registriert: 8. Aug 2006, 01:01

Beitrag von brtz » 8. Aug 2006, 13:07

das Problem bisher war, dass aufgrund der lamenden ZEN-Abfrage Yast nicht so konfiguriert werden konnte, dass Updates möglich waren. Mittlerweile ist ein einziger Updateserver ordnungsgemäss eingetragen, Yast hat sich aktualisiert - Neustart - Online-Update läuft - alles in Butter.
Die anderen Paketmanager interessieren hier tatsächlich nicht mehr da ja jetzt alles wieder geht.
Mit Hinkebein war Yast gemeint, apt-get mit Skylla und smart mit Charybdis, nachdem ich mich über deren Nachteile (aus meiner Sicht, gehört aber wie gesagt nicht hier hin) informiert habe.

Fazit: Zen ist nichts für die christlich geprägte Welt, dazu braucht man die Geduld der Buddhisten.

Danke für alles, Problem gelöst.
no further comments.

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 2 Gäste