Problem mit gnuplot

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
JonasD
Newbie
Newbie
Beiträge: 2
Registriert: 8. Aug 2006, 01:15

Problem mit gnuplot

Beitrag von JonasD » 8. Aug 2006, 01:31

Ich versuche gnuplot-3.7.3 zu installieren.

Zunächst habe ich zlib-1.2.3 und libpgn-1.2.3 installiert.
(configure + make install)

Anschliessend meldet

cd /usr/local/gnuplot/
./configure

checking for png_init_io in -lpng... no
PNG library not found.
See term/png.trm for download details
./configure: line 9040: syntax error near unexpected token `newline'
./configure: line 9040: ` yes:no:'

Verstehe nicht, warum gnuplot die zuvor installierten Libs nicht findet.

Hat jemand damit Erfahrung ?

Werbung:
b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 8. Aug 2006, 02:07

Vielleicht verrätst du uns erstmal deine Distribution! :roll:
Gnuplot sollte nämlich bei den meisten dabei sein.
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

Rain_Maker

Jupp ...

Beitrag von Rain_Maker » 8. Aug 2006, 02:23

Code: Alles auswählen

apt search gnuplot
emacs-calc - advanced calculator and mathematical tool for GNU emacs
gnuplot - Function Plotting Utility
gnuplot-debuginfo - Debug information for package gnuplot
pstoedit - PostScript and PDF Converter
pstoedit-devel - PostScript and PDF converter

apt policy gnuplot
gnuplot:
  Installiert: 4.0.0-7
  Kandidat: 4.0.0-7
  Versionstabelle:
 *** 4.0.0-7 0
        500 http://ftp-1.gwdg.de SuSE/10.0-i386/base pkglist
        100 RPM Database
SuSE 10.0 (man beachte das "base")

Code: Alles auswählen

apt policy gnuplot
gnuplot:
  Installiert: 4.0.0-20
  Kandidat: 4.0.0-20
  Versionstabelle:
 *** 4.0.0-20 0
        500 ftp://ftp4.gwdg.de SuSE/10.1-i386/base pkglist
        100 RPM Database
Same Story, hier SuSE 10.1.

9.3 müsste ich mir zuerst wieder installieren, ich hoffe das verlangt keiner von mir *g*

Aber auch bei (K)Ubuntu siehts ganz gut damit aus.

Code: Alles auswählen

apt-cache policy gnuplot
gnuplot:
  Installiert:(keine)
  Mögliche Pakete:4.0.0-2.1
  Versions-Tabelle:
     4.0.0-2.1 0
        500 http://archive.ubuntu.com dapper/universe Packages
        500 http://ftp.inf.tu-dresden.de dapper/universe Packages
Huch? Nicht installiert? Das holen wir mal schnell nach.

Code: Alles auswählen

apt-get install gnuplot
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  gnuplot-nox gnuplot-x11
Vorgeschlagene Pakete:
  gnuplot-doc
Die folgenden NEUEN Pakete werden installiert:
  gnuplot gnuplot-nox gnuplot-x11
0 aktualisiert, 3 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 880kB Archive geholt werden.
Nach dem Auspacken werden 1958kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]?
Hole:1 http://archive.ubuntu.com dapper/universe gnuplot-nox 4.0.0-2.1 [701kB]
Hole:2 http://archive.ubuntu.com dapper/universe gnuplot-x11 4.0.0-2.1 [178kB]
Hole:3 http://archive.ubuntu.com dapper/universe gnuplot 4.0.0-2.1 [1388B]
Es wurden 880kB in 2s geholt (368kB/s)
Wähle vormals abgewähltes Paket gnuplot-nox.
(Lese Datenbank ... 235766 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke gnuplot-nox (aus .../gnuplot-nox_4.0.0-2.1_i386.deb) ...
Wähle vormals abgewähltes Paket gnuplot-x11.
Entpacke gnuplot-x11 (aus .../gnuplot-x11_4.0.0-2.1_i386.deb) ...
Wähle vormals abgewähltes Paket gnuplot.
Entpacke gnuplot (aus .../gnuplot_4.0.0-2.1_all.deb) ...
Richte gnuplot-nox ein (4.0.0-2.1) ...

Richte gnuplot-x11 ein (4.0.0-2.1) ...
Richte gnuplot ein (4.0.0-2.1) ...
Danke @OP, wäre mir sonst gar nicht aufgefallen ;)

Ach so, der Kompilierfehler?
checking for png_init_io in -lpng... no
PNG library not found.


==> Wer lesen kann.....(kleiner Tipp.. für "Devel"opment braucht man "devel"-Pakete).

Aber wieso kompilieren, wenn es fertige Pakete gibt? Und wenn man denn doch 'unbedingt' kompilieren will, wieso dann ein Posting im Unterforum "Yast"? Und wieso Gnuplot 3.7.3? Projekt "Jurassic Gnu?"

Fragen über Fragen.......

Greetz,

RM

JonasD
Newbie
Newbie
Beiträge: 2
Registriert: 8. Aug 2006, 01:15

Beitrag von JonasD » 8. Aug 2006, 06:18

Also, das hatte ich vergessen, ich benutze Suse 9.3 64 bit.

Dann werde ich es wohl mal mit einer neueren Version von gnuplot versuchen.

Was ihr hier mit apt bzw. apt-get beschreibt, funktioniert das auch mit Suse 9.3 ?
Bei mir kommt dann "command not found". Ist das ein Zusatzpaket, welches das Installieren von Paketen erleichtert ? Wenn ja, wo bekommt man das ?

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 8. Aug 2006, 10:21

JonasD hat geschrieben:Ist das ein Zusatzpaket, welches das Installieren von Paketen erleichtert ? Wenn ja, wo bekommt man das ?
Genau. Für apt gibt es hier ein ganzes Unterforum:
=> [FAQ] [TIP] [INFO] immerwiederkehrende Fragen zu APT / SMART

Allerdings sollte gnuplot auf den CDs / DVD enthalten sein.
(Und falls doch nicht: => [HOWTO] Quellen für SuSE Linux 9.3)
YAST -> Software installieren / löschen -> "gnuplot" suchen -> installieren
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast