HOW TO r-base/r-project and SuSE10.1

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
xeroxed_yeti
Member
Member
Beiträge: 115
Registriert: 4. Aug 2005, 11:24

HOW TO r-base/r-project and SuSE10.1

Beitrag von xeroxed_yeti » 3. Aug 2006, 11:25

Hallo zusammen,

ich habe ein Problem mit dem Statisikprogramm R / R-Base / R-Project.
Ich habe es installiert mit rpm installiert und vorher natürlich die Abhängigkeiten geprüft, alles verlief gut.
Aber nachdem ich dann in der Console R mit dem Befehl 'R' starten wollte bekam ich die Fehlermeldung:

Code: Alles auswählen

/usr/lib/R/bin/exec/R: error while loading shared libraries: libgfortran.so.1: cannot open shared object file: No such file or directory
Die Libary libgfortran.so.1 existiert aber unter /opt/gnat/gcc/lib/libgfortran.so.1

Was muss ich denn machen, damit R weiß wo es noch der Datei zu suchen hat?

Danke!!
MAKE PEACE!!! NO WAR!!!

Bild

Windwos-Error-Message-Sahnestückchen:
http://www.spiegel.de/netzwelt/web/0,15 ... 01,00.html

Werbung:
Rain_Maker

Beitrag von Rain_Maker » 3. Aug 2006, 11:28

Wo hattest Du die Pakete her?

Oder noch besser, wie heissen diese Pakete? (genauer Dateiname)

Greetz,

RM

Benutzeravatar
xeroxed_yeti
Member
Member
Beiträge: 115
Registriert: 4. Aug 2005, 11:24

Beitrag von xeroxed_yeti » 3. Aug 2006, 11:39

als erstes habe ich das gnat-gcc rpm installiert:

gnat-gcc-4.1.1_20060517-r5.suse_9_2.i586

leider weiß ich nicht mehr genau wo ich dieses packet her habe, aber es war das einzigste package welches die 'libgfortran.so.1' supportet hat.


Im Anschluss habe ich dann das r-base rpm von:

http://cran.us.r-project.org/bin/linux/ ... 1.i586.rpm

gedownloaded.


weißt du vielleicht wo ich eine aktuellere Version von dieser libgfortran.so.1 her bekomme? vielleicht liegt es daran.
MAKE PEACE!!! NO WAR!!!

Bild

Windwos-Error-Message-Sahnestückchen:
http://www.spiegel.de/netzwelt/web/0,15 ... 01,00.html

Rain_Maker

Ein Colt äääh rpm für alle Fälle..

Beitrag von Rain_Maker » 3. Aug 2006, 11:50

newbie_needs_help hat geschrieben:als erstes habe ich das gnat-gcc rpm installiert:

gnat-gcc-4.1.1_20060517-r5.suse_9_2.i586

leider weiß ich nicht mehr genau wo ich dieses packet her habe, aber es war das einzigste package welches die 'libgfortran.so.1' supportet hat.
Genau das dachte ich mir.
Also war es wohl kaum von SuSE selbst.

BTW: Dieses "SuSE_9_2" sollte einen zumindest mal stutzig machen, oder?
Das Paket ist auch mit gcc.4.11 genbaut worden, nun gut.

Suche ein Paket gcc_fortran bzw. gcc-fortran für SuSE 10.1 und schmeisse das gnat-gcc unter.

Nachtrag:

Das hier habe ich gefunden:

Code: Alles auswählen

 rpm -qpl .opera/cache4/temporary_download/gcc-fortran-4.1.0-25.i586.rpm 
/usr/bin/gfortran
/usr/lib/gcc/i586-suse-linux/4.1.0/f951
/usr/lib/libgfortran.a
/usr/lib/libgfortran.la
/usr/lib/libgfortran.so
/usr/lib/libgfortran.so.1
/usr/lib/libgfortran.so.1.0.0
/usr/lib/libgfortranbegin.a
/usr/lib/libgfortranbegin.la
/usr/share/info/gfortran.info.gz
/usr/share/man/man1/gfortran.1.gz
ftp://ftp.gwdg.de/pub/opensuse/distribu ... st-source/

Also müsste es auf der CD/DVD dabei sein, wenn nicht, siehe P.S.


Greetz,

RM

P.S. Und bevor Du weiterhin solche "Frickelstunts" hinlegst und Pakete von Hand ins System prügelst, schaust Du Dir am besten an, wie man Online-Repositories ins System einbindet. (SuFU wird helfen).

Man muß ja nicht alles so kompliziert wie bei Windows machen.
Zuletzt geändert von Rain_Maker am 3. Aug 2006, 12:26, insgesamt 1-mal geändert.

Benutzeravatar
xeroxed_yeti
Member
Member
Beiträge: 115
Registriert: 4. Aug 2005, 11:24

Beitrag von xeroxed_yeti » 3. Aug 2006, 12:25

danke für den tip mit den zusätzlichen installations sourcen, aber ich habe schon ein paar hinzu gefügt.

Leider bin ich total erfolglos was das gcc_package und SuSE 10.1 angeht :(
weiß jemand wo ich ein Package für SuSE 10.1 finde welches die libgfortran.so.1 unterstützt?
MAKE PEACE!!! NO WAR!!!

Bild

Windwos-Error-Message-Sahnestückchen:
http://www.spiegel.de/netzwelt/web/0,15 ... 01,00.html

Rain_Maker

Beitrag von Rain_Maker » 3. Aug 2006, 12:30

Siehe oben...

(Zeitliche Überschneidung)

Ich will mal lieber nicht wissen, welche anderen Installationsquellen das sind.

Bei den offiziellen (sic!) ist es jedenfalls dabei.

Greetz,

RM

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 3. Aug 2006, 12:32

In der von Rain_Maker genannten Installationsquelle, Paket "gcc-fortran".

Du kannst es jetzt auch so installieren:

Code: Alles auswählen

rpm -Uvh http://ftp.gwdg.de/pub/opensuse/distribution/SL-10.1/inst-source/suse/i586/gcc-fortran-4.1.0-25.i586.rpm
wenn das mit der Installationsquelle nicht klappt (warum nicht? sollte es eigentlich).

Benutzeravatar
xeroxed_yeti
Member
Member
Beiträge: 115
Registriert: 4. Aug 2005, 11:24

Beitrag von xeroxed_yeti » 3. Aug 2006, 13:02

Danke für die Tipps :) R läuft nun.

...vielleicht hätte ich die installations sourcen einfach nur wieder aktivieren sollen :(
MAKE PEACE!!! NO WAR!!!

Bild

Windwos-Error-Message-Sahnestückchen:
http://www.spiegel.de/netzwelt/web/0,15 ... 01,00.html

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste