apt-update auf SuSE 10.0

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Ulyssus
Newbie
Newbie
Beiträge: 46
Registriert: 30. Jul 2006, 14:53

Beitrag von Ulyssus » 9. Aug 2006, 23:23

Hallo, ich wollt heut das apt upgrade machen und folgendes kam:

Code: Alles auswählen

        file /opt/kde3/share/mimelnk/application/x-bittorrent.desktop from install of kdelibs3-3.5.4-24.2 conflicts with file from package ktorrent-2.0_1.0-1.guru.suse100
        file /opt/kde3/share/mimelnk/application/x-mplayer2.desktop conflicts between attempted installs of kaffeine-0.8.1-18.1 and kdelibs3-3.5.4-24.2
        file /opt/kde3/share/mimelnk/application/x-sqlite2.desktop conflicts between attempted installs of koffice-database-1.5.2-6.1 and kdelibs3-3.5.4-24.2
        file /opt/kde3/share/mimelnk/application/x-sqlite3.desktop conflicts between attempted installs of koffice-database-1.5.2-6.1 and kdelibs3-3.5.4-24.2
E: Error while running transaction
E: Handler silently failed
Also hab ich es probiert mit:

Code: Alles auswählen

apt install --force kdelibs3-3.5.3-24.2
Allerdings findet er das Paket zu kdelibs nicht.

Daraufhin wollt ich diesen Link in die sources einfüge, also:

Code: Alles auswählen

rpm http://software.opensuse.org/download/repositories/KDE:/KDE3/SUSE_Linux_10.0/i586/
Nur wird das jetzt als misbildete Zeile gehandhabt

Was nun? EInfach das rpm-Paket von der Seite installieren?

Denn mit:

Code: Alles auswählen

apt-cache policy kdelibs3
erhalte ich:

Code: Alles auswählen

kdelibs3:
  Installiert: 3.5.3-38.1
  Kandidat: 3.5.4-24.2
  Versionstabelle:
     3.5.4-24.2 0
        500 ftp://ftp.gwdg.de SUSE_Linux_10.0/ repomd
 *** 3.5.3-38.1 0
        100 RPM Database
     3.4.2-24.3 0
        500 ftp://ftp.gwdg.de SuSE/10.0-i386/security pkglist
        500 ftp://ftp.gwdg.de SuSE/10.0-i386/update pkglist
     3.4.2-24.2 0
        500 ftp://ftp.gwdg.de SuSE/10.0-i386/security pkglist
        500 ftp://ftp.gwdg.de SuSE/10.0-i386/update pkglist
     3.4.2-24 0
        500 ftp://ftp.gwdg.de SuSE/10.0-i386/base pkglist
Also muss die Version doch irgendwie vorhanden sein :shock:

Werbung:
Rain_Maker

Falsche Syntax mal 4

Beitrag von Rain_Maker » 10. Aug 2006, 00:43

Hallo,

So kann das auch nichts werden.

Fehler Nr.1
apt install --force kdelibs3-3.5.3-24.2
Richtig:

Code: Alles auswählen

apt install --force kdelibs3=3.5.3-24.2
Fehler Nr.2, 3 & 4

Richtig:

Code: Alles auswählen

repomd http://software.opensuse.org/download/repositories/KDE:/KDE3/ SUSE_Linux_10.0

Allerdings brauchst Du die Zeile nicht, Du hast ja schon ein passendes Repo, also lösche den Unsinn aus Deiner sources.list raus.

Greetz,

RM

Ulyssus
Newbie
Newbie
Beiträge: 46
Registriert: 30. Jul 2006, 14:53

Re: Falsche Syntax mal 4

Beitrag von Ulyssus » 10. Aug 2006, 15:47

Richtig:

Code: Alles auswählen

apt install --force kdelibs3=3.5.3-24.2

Jetzt sagt er mir, dass die Version 3.5.3-24.2 für kdelibs3 nicht gefunden wurde.

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 2 Gäste