2 Fragen zu smart - vgl synaptics

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
meteosat
Newbie
Newbie
Beiträge: 47
Registriert: 20. Dez 2004, 17:29

Beitrag von meteosat » 27. Jul 2006, 14:48

Ich hätte noch zwei Fragen zu smart, die mir in synaptics besser gelöst schienen:

a. Kann ich anzeigen lassen, von welcher Version auf welche Version smart bei "Aktualisiere alle Pakete" updaten will? Bei mir steht bisher nur die neue. Und händisch die alte Version ermitteln ist wenig komfortabel.

b. Wenn ich "Aktualisiere alle Pakete" wähle, scheint er nur dies machen zu können. In synaptics konnte ich einzelne Pakete wieder abwählen. So kann man Software auf den akutellsten Stand halten und trotzdem die Sachen zurückhalten, bei denen man zuerst überlegen will, ob der update eine gute Idee wäre.

Werbung:
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 27. Jul 2006, 15:08

Zum Thema passend wäre z. B:

Code: Alles auswählen

smart query paketname --show-channels
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

meteosat
Newbie
Newbie
Beiträge: 47
Registriert: 20. Dez 2004, 17:29

Beitrag von meteosat » 27. Jul 2006, 15:46

Sorry,
das war es nicht, was ich wollte.
Ich möchte in der gui "Aktualisiere alle Pakete" wählen, dann sehen, was mir smart aktualisieren KÖNNTE und von welcher Version auf welche neue. Und dann auswählen, was ich wirklich updaten will.
Wahlweise könnte ich auch noch damit leben, nur eine Liste von Paketen zu bekommen, die man updaten kann und dann selber von Hand auszuwählen, was ich haben möchte.
Bei knapp 1000 installierten Paketen ist es doch sehr mühsam, alle einzeln durchzuschauen.

Benutzeravatar
BelaLugosi
Member
Member
Beiträge: 140
Registriert: 17. Jan 2006, 21:12
Wohnort: Dresden

Beitrag von BelaLugosi » 27. Jul 2006, 15:49

smart --gui:

Ansicht -> Verberge nicht aktualisierbare Pakete (oder so)

Damit bekommst Du nur die Pakete angezeigt, für die ein Update vorliegt.

Cheers,
SC
i don't have hard drives. i just keep 30 chinese teenagers in my basement and force them to memorize numbers (bash.org)

meteosat
Newbie
Newbie
Beiträge: 47
Registriert: 20. Dez 2004, 17:29

Beitrag von meteosat » 27. Jul 2006, 16:15

Danke,
das war es - fast.
Ich wohl jetzt meine updates wählen. Leider weiß ich aber nicht, von welcher Version ich update. Wie gesagt, das fand ich bei synaptic ganz komfortabel gelöst.

Antworten

Wer ist online?

Mitglieder in diesem Forum: Yahoo [Bot] und 1 Gast