nach Update Fehlschlag nun Kernel panic

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
drboe
Member
Member
Beiträge: 96
Registriert: 25. Aug 2004, 09:03

nach Update Fehlschlag nun Kernel panic

Beitrag von drboe » 26. Jul 2006, 17:00

Hi,

ich habe heute versucht mittels YAST ein SuSE 9.3 zu aktualisieren. Angeboten wurden zwei Sicherheits-Updates a) des Kernels und b) für gpg2. Bei der Installation des Kernels kam eine Fehlermeldung, die Installation wurde dann übersprungen. Der Patch für gpg2 wurde aber installiert. Im Anschluß startete leider das System nicht mehr; es hing in oder vor der HW-Erkennung. Ein Versuch es mit der 9.3er CD1 zu reparieren hat gar nichts gebracht. Nun kommen beim Start am Ende folgende Meldungen:

VFS: Cannot open root device "hda1" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount rout fs on
unknown-block(0,0)

Dann hängt der PC. Der Bootloader ist GRUB. Und zwar passiert sowohl beim Versuch den Default-Eintrag der menu.lst zu starten, als auch bei "Failsafe". hda1 ist eine Reiser-Partition. reiserfsck - gestartet von der Installations-CD - findet die ist in Ordnung. Der Eintrag für Failsafe in der menu.lst sieht wie folgt aus:

kernel (hd0,0)/boot/vmlinux root=/dev(hda1 showopts ide=nodma apm=off acpi=off vga=normal noresume selinux=0 barrier=off nosmp noapic maxcpus=0 3

Beim Vergleich mit einem anderen SuSE 9.3 (ss ist jeweils der Standard-Kernel von SuSE) fällt auf, dass dort bei den Einträgen für "Linux" und "Failsafe" noch eine Zeile folgt, nämlich

initrd (hd0,0)/initrd

Außerdem gibt es in /boot einen Link @initrd, jedoch fehlt offenbar das Ziel dieses Links. Zum Vergleich: In einem funktionierenden System verweist @initrd auf eine Datein initrd-2-6.11.4-21.12-default. Die gibt es nun auf meiner WS aber nicht mehr, vermutlich Folge des Fehlers. Selbst mit einer Update-Installation (eigentlich ist das ein Downgrade) wird das Problem leider nicht gelöst.

Derzeit sichere ich die Daten unter Knoppix soweit möglich auf einer andere Festplatte. Ich würde sehr gern eine Neuinstallation vermeiden.

Frage daher: wie kann ich das Ganze korrigieren bzw. das System manuell so einrichten, dass es wieder startet? Ich kann Knoppix starten. Alternativ auch das SuSE Rescue-System von der CD (aber leider nicht von der HD).

M. Boettcher

Werbung:
Rain_Maker

Changeroot?

Beitrag von Rain_Maker » 26. Jul 2006, 17:05

Hallo,

Versuche doch mal mittels Changeroot auf Deine SuSE zuzugreifen, wie z.b. hier beschrieben.

Anschliessend die Partition mounten und folgenden Befehl ausführen:

Code: Alles auswählen

su

(Passwort)

mkinitrd -k /boot/vmlinuz-*Kernelversion* -i /boot/initrd-*Kernelversion*
Dann passt der Link wieder und es wird ne neue initrd erstellt. Notfalls noch Grub neu konfigurieren/installieren.

Siehe auch:

http://www.thomashertweck.de/kernel26.html#installieren

Greetz,

RM

Edit: Nur zur Sicherheit (man weiß ja nie)

Code: Alles auswählen

kernel (hd0,0)/boot/vmlinux root=/dev(hda1 
Das hast Du abgetippt und es ist deshalb ein Fehlerchen drin, oder? In Wirklichkeit heisst das schon /dev/hda1?

Benutzeravatar
drboe
Member
Member
Beiträge: 96
Registriert: 25. Aug 2004, 09:03

Re: Changeroot?

Beitrag von drboe » 26. Jul 2006, 18:47

Hi,

Code: Alles auswählen

su

(Passwort)

mkinitrd -k /boot/vmlinuz-*Kernelversion* -i /boot/initrd-*Kernelversion*
Dann passt der Link wieder und es wird ne neue initrd erstellt. Notfalls noch Grub neu konfigurieren/installieren.
mkinitrd gibt u. a. folgende Meldungen aus:

Code: Alles auswählen

sed: can't read /sys/class/graphics/fb0/virtual_size: No such file or directory
Root device: /dev/hda1 (mounted on / as reiserfs)
Module list: sis5513 reiserfs ()

Kernel image: /boot/vmlinuz-2.6.11.4-20a-default
Initrd image: /boot/initrd-2.6.11.4-20a-default
cp: cannot stat 'sbin/udevtrigger': no such file or directory
cp: cannot stat 'sbin/udevsettle': no such file or directory
cp: cannot stat 'sbin/ata_id': no such file or directory
cp: cannot stat 'sbin/usb_id': no such file or directory
cp: cannot stat 'sbin/vol_id': no such file or directory
cp: cannot stat 'sbin/dasd_id': no such file or directory
cp: cannot stat 'sbin/edd_id': no such file or directory
cp: cannot stat 'sbin/path_id': no such file or directory
cp: cannot stat 'etc/scsi_id.config': no such file or directory
Shared libs: ldd: 'sbin/udevtrigger': no such file or directory
ldd: 'sbin/udevsettle': no such file or directory
ldd: 'sbin/ata_id': no such file or directory
ldd: 'sbin/vol_id': no such file or directory
ldd: 'sbin/dasd_id': no such file or directory
ldd: 'sbin/edd_id': no such file or directory
ldd: 'sbin/path_id': no such file or directory

Dann werden diverse libs aufgeführt. Zum Schluß kommt:

Driver modules: ide-core ide-disk sis5513
Filesystem modules: reiserfs
Including: initramfs fsck.reiserfs
Bootsplash: Suse (1024x768)
9599 blocks
warning: can't open /etc/mtab: No such file or directory

Code: Alles auswählen

kernel (hd0,0)/boot/vmlinux root=/dev(hda1 
Das hast Du abgetippt und es ist deshalb ein Fehlerchen drin, oder? In Wirklichkeit heisst das schon /dev/hda1?
Ja! Ich kann an der Maschine - mein Desktop - ja so gut wie nichts machen und habe das auf dem Notebook getippt.

Ich habe dann für GRUB noch in menu.lst die Zeile initrd (hd0,0)/initrd bzw. initrd (hd0,0)/boot/initrd wieder eingefügt. Leider liegt da wohl ein Fehler. Vermutlich sind die Verweise (Links) nicht richtig. Jedenfalls kommt beim Start jetzt die Meldung:

Code: Alles auswählen

kernel (hd0,0)/boot/vmlinuz rrot=/dev/hda1 vga=317 selinux=0 splash=silent resume=/dev/hdd2
 [Linux-bzImage, setup=01600, size=0x15a505]
initrd (hd0,0)/initrd

Error 15: File not found
Nachdem ich die Links @vmlinuz und @initrd jeweils durch die Lang-Version der Dateinamen ersetzt habe bin ich ... am Anfang, d. h. da, wo ich heute morgen nach dem Fehlschlag des Kernel-Updates war.

Und das äußert sich wie folgt: in der Initialiiserung der HW steht das System bei:

Code: Alles auswählen

input: AT Translated Set 2 keyboard on isa0060/serio0
Trying manual resume from /dev/hdd2
Starting udevd
input: ImPS/2 Logitec Wheel Mouse on isa0060/serio0 
:(

M. Boettcher

Rain_Maker

OK, der Reihe nach...

Beitrag von Rain_Maker » 26. Jul 2006, 19:55

drboe hat geschrieben:Hi,

Code: Alles auswählen

sed: can't read /sys/class/graphics/fb0/virtual_size: No such file or directory
Root device: /dev/hda1 (mounted on / as reiserfs)
Module list: sis5513 reiserfs ()

Kernel image: /boot/vmlinuz-2.6.11.4-20a-default
Initrd image: /boot/initrd-2.6.11.4-20a-default
cp: cannot stat 'sbin/udevtrigger': no such file or directory
cp: cannot stat 'sbin/udevsettle': no such file or directory
cp: cannot stat 'sbin/ata_id': no such file or directory
cp: cannot stat 'sbin/usb_id': no such file or directory
cp: cannot stat 'sbin/vol_id': no such file or directory
cp: cannot stat 'sbin/dasd_id': no such file or directory
cp: cannot stat 'sbin/edd_id': no such file or directory
cp: cannot stat 'sbin/path_id': no such file or directory
cp: cannot stat 'etc/scsi_id.config': no such file or directory
Shared libs: ldd: 'sbin/udevtrigger': no such file or directory
ldd: 'sbin/udevsettle': no such file or directory
ldd: 'sbin/ata_id': no such file or directory
ldd: 'sbin/vol_id': no such file or directory
ldd: 'sbin/dasd_id': no such file or directory
ldd: 'sbin/edd_id': no such file or directory
ldd: 'sbin/path_id': no such file or directory

Dann werden diverse libs aufgeführt. Zum Schluß kommt:

Driver modules: ide-core ide-disk sis5513
Filesystem modules: reiserfs
Including: initramfs fsck.reiserfs
Bootsplash: Suse (1024x768)
9599 blocks
warning: can't open /etc/mtab: No such file or directory
Da scheint noch einiges mehr im Eimer zu sein, oder hast Du (kann ja mal passieren) nicht alle Systempartitionen (falls z.B. /usr/ extra liegt) gemountet? OK, würde aber nicht erklären, warum er Daten in /sbin nicht findet, denn das muß *correct me if I'm wrong gurus out there* auf der Rootpartition liegen.

Eines der Hauptproblem ist mal wieder das, was wir schon mal hatten:

Code: Alles auswählen

kernel (hd0,0)/boot/vmlinuz rrot=/dev/hda1 vga=317 selinux=0 splash=silent resume=/dev/hdd2
 [Linux-bzImage, setup=01600, size=0x15a505]
initrd (hd0,0)/initrd

Error 15: File not found
Was sind da Tippfehler und was nicht?

rrot würde ich sagen Tippfehler beim Abschreiben, aber hdd2?

Der taucht gleich nochmal auf:

Code: Alles auswählen

input: AT Translated Set 2 keyboard on isa0060/serio0
Trying manual resume from /dev/hdd2
Starting udevd
input: ImPS/2 Logitec Wheel Mouse on isa0060/serio0 
DA in der Fehlermeldung.

2 mal der selbe Vertipper oder doch ein Fehler in der config?

Das Problem ist, so wird das verdammt schwer, irgendeine Aussage zu treffen, nur eines scheint sicher zu sein:

Da ist einiges mehr kaputt, wenn auf /sbin vieles nicht gefunden wird, was fürs System nötigst ist.

Versuche doch bitte, egal wie schwer es ist, fehlerfreie Meldungen hinzubekommen. So kann man sich nie sicher sein auch im Changeroot kannnst Du z.B. nen Stick mounten (von Hand latürnich) oder ne Floppy.

Greetz,

RM

Benutzeravatar
drboe
Member
Member
Beiträge: 96
Registriert: 25. Aug 2004, 09:03

Re: OK, der Reihe nach...

Beitrag von drboe » 26. Jul 2006, 20:54

Rain_Maker hat geschrieben:Da scheint noch einiges mehr im Eimer zu sein, oder hast Du (kann ja mal passieren) nicht alle Systempartitionen (falls z.B. /usr/ extra liegt) gemountet? OK, würde aber nicht erklären, warum er Daten in /sbin nicht findet, denn das muß *correct me if I'm wrong gurus out there* auf der Rootpartition liegen.
Es liegt definitiv Alles auf hda1.
Rain_Maker hat geschrieben:Eines der Hauptproblem ist mal wieder das, was wir schon mal hatten:

Code: Alles auswählen

kernel (hd0,0)/boot/vmlinuz rrot=/dev/hda1 vga=317 selinux=0 splash=silent resume=/dev/hdd2
 [Linux-bzImage, setup=01600, size=0x15a505]
initrd (hd0,0)/initrd

Error 15: File not found
Was sind da Tippfehler und was nicht?

rrot würde ich sagen Tippfehler beim Abschreiben, aber hdd2?
'rrot' ist in der Tat ein Vertipper und hdd2 stimmt. Die Swap-Partition liegt auf hdd (hdd2). Das System hatte 'mal 2 HDs (hda und hdd), ein CD-LW (hdb) und ein DVD-LW (hdc). hdd war eine Zeit mit SuSE 8.2 bootbar, daher gibt es historisch eine (sehr kleine) Partition hdd1 und dahinter den swap Bereich. Vor ca. 15 Monaten sind CD- und DVD-Laufwerk durch einen einzigen DVD-Brenner (hdc) ersetzt worden. Das CD-LW war leider defekt, das DVD-LW ist zwischenzeitlich in einen anderen PC eingebaut worden.
Rain_Maker hat geschrieben:Versuche doch bitte, egal wie schwer es ist, fehlerfreie Meldungen hinzubekommen. So kann man sich nie sicher sein auch im Changeroot kannnst Du z.B. nen Stick mounten (von Hand latürnich) oder ne Floppy.
Ich werde mich bemühen. Vielen Dank für's erste. Zur Not bleibt ja noch das System neu aufzusetzen. Das würde ich zwar gern vermeiden, aber wenn es nicht anders geht ...

M. Boettcher

Rain_Maker

Test...

Beitrag von Rain_Maker » 26. Jul 2006, 22:14

Hallo,

Ich habe eben getestet, ob vielleicht ein Denkfehler in meiner Methode mit dem Changeroot liegen könnte.

Tut mir leid, Dir sagen zu müssen, daß es leider (für Dich) nicht an der Methode liegt, sie funktioniert. (Unter Kubuntu im laufenden Betrieb Changeroot auf meine SuSE 10.0 und dann "neue" initrd "gebastelt".

Code: Alles auswählen

root@Adamantan:/ # chroot /SuSE10
Adamantan:/# cd boot/
Adamantan:/boot# ls -ls initrd*
   0 lrwxrwxrwx  1 root root      27 2006-07-26 22:09 initrd -> initrd-2.6.13-15.11-default
2599 -rw-r--r--  1 root root 2654656 2006-07-22 23:15 initrd-2.6.13-15.11-default
Adamantan:/boot# mkinitrd -k vmlinuz-2.6.13-15.11-default -i initrd-2.6.13-15.11-default.test
Root device:    /dev/hda5 (mounted on / as reiserfs)
Module list:    sis5513 processor thermal fan reiserfs

Kernel image:   /boot/vmlinuz-2.6.13-15.11-default
Initrd image:   /boot/initrd-2.6.13-15.11-default.test
Shared libs:    lib/ld-2.3.5.so lib/libblkid.so.1.0 lib/libc-2.3.5.so lib/libselinux.so.1 lib/libuuid.so.1.2

Driver modules: ide-disk sis5513 processor thermal fan
Filesystem modules:     reiserfs
Including:      klibc initramfs udev fsck.reiserfs
Bootsplash:     UNIXBROTHERSBOOT (1024x768)
9559 blocks
Adamantan:/boot# ls -ls initrd*
   0 lrwxrwxrwx  1 root root      32 2006-07-26 22:11 initrd -> initrd-2.6.13-15.11-default.test
2599 -rw-r--r--  1 root root 2654656 2006-07-22 23:15 initrd-2.6.13-15.11-default
2599 -rw-r--r--  1 root root 2654642 2006-07-26 22:11 initrd-2.6.13-15.11-default.test
Kannst Du vielleicht eine Systemreparatur von CD/DVD versuchen? Vielleicht findet die die offensichtlich vorhandenen Fehler bei Paketen in /sbin.

Greetz,

RM

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste