[gelöst] APT Problem mit glibc

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
BobbbMarley
Newbie
Newbie
Beiträge: 44
Registriert: 3. Dez 2004, 09:32

[gelöst] APT Problem mit glibc

Beitrag von BobbbMarley » 26. Jul 2006, 15:50

*** glibc detected *** double free or corruption (!prev): 0x0824d610 ***
/usr/bin/apt: line 123: 12127 Abgebrochen apt-get $ARG
linux:/ #

Diese Meldung erhalte ich, wenn ich
apt update
eingebe.

Ach so: SuSE 10 mit KDE 3.5.3

Bobbb
Zuletzt geändert von BobbbMarley am 28. Jul 2006, 21:18, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 26. Jul 2006, 15:53

und die apt Version ?

rpm -q apt apt-libs
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

BobbbMarley
Newbie
Newbie
Beiträge: 44
Registriert: 3. Dez 2004, 09:32

Beitrag von BobbbMarley » 26. Jul 2006, 17:22

linux:/ # rpm -q apt apt-libs
apt-0.5.15repomd060302-0.suse1000.rb1
apt-libs-0.5.15repomd060302-0.suse1000.rb1

Bobbb

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 26. Jul 2006, 17:32

Die Pakete sind so alt, dass sie schon gar nicht mehr riechen.

Hier geht's lang:

http://software.opensuse.org/download/h ... _i586/i586

Auch nützlich:

http://www.linux-club.de/ftopic64264.html
http://www.linux-club.de/ftopic61986.html

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 26. Jul 2006, 17:38

traffic hat geschrieben:Die Pakete sind so alt, dass sie schon gar nicht mehr riechen.
:mrgreen:
da warst du schneller .. wolle gerade so was ähnliches schreiben ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

BobbbMarley
Newbie
Newbie
Beiträge: 44
Registriert: 3. Dez 2004, 09:32

Beitrag von BobbbMarley » 26. Jul 2006, 18:43

linux:/home/xxxxx/downloads/torrents # rpm -Uvh apt*
warning: apt-0.5.15lorg3.2-12.1.i586.rpm: V3 DSA signature: NOKEY, key ID 6b9d6523
Preparing... ########################################### [100%]
package apt-libs-0.5.15repomd060302-0.suse1000.rb1 (which is newer than apt-libs-0.5.15lorg3.2-12.1) is already installed
package apt-0.5.15repomd060302-0.suse1000.rb1 (which is newer than apt-0.5.15lorg3.2-12.1) is already installed
package apt-devel-0.5.15repomd060302-0.suse1000.rb1 (which is newer than apt-devel-0.5.15lorg3.2-12.1) is already installed

watt nu?

Bobbb

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 26. Jul 2006, 18:50

Nimm die Option "--oldpackage" dazu:

Code: Alles auswählen

rpm -Uvh apt* --oldpackage
Das liegt daran, dass rpm aufgrund der Buchstaben in der Versionsnummer "denkt", die neue Version sei älter als die installierte, obwohl es natürlich nicht stimmt.

BobbbMarley
Newbie
Newbie
Beiträge: 44
Registriert: 3. Dez 2004, 09:32

Beitrag von BobbbMarley » 26. Jul 2006, 19:02

DER GEEEEEEEEHT!!! SONYYYYYYYYYYY ;-)

Hey, vielen Dank, ihr seid Klasse.

Bobbb

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 26. Jul 2006, 19:07

Vergiss nicht, das bisherige Repo von Richard Bos (1) zu deaktivieren, ansonsten schneit die Uralt-Version beim nächsten apt upgrade wieder rein. Dir entgeht dadurch nichts, die neueren Pakete gibt es im Build Service (2).

(1) http://ftp.gwdg.de/pub/linux/suse/apt/S ... suser-rbos = alt
(2) http://software.opensuse.org/download/h ... -10.0_i586 = neu

BobbbMarley
Newbie
Newbie
Beiträge: 44
Registriert: 3. Dez 2004, 09:32

Beitrag von BobbbMarley » 26. Jul 2006, 21:01

Meine Source-List sieht so aus:

# A very basic sources.list file.
# Bemove "base" in case you are behind a slow connection.
# Fastest repository comes first, with netselect it is possible to determine
# the fastest repository easily.
# Visit the Server to determine which apt components are provided.
# rpm ftp://mirrors.mathematik.uni-bielefeld. ... inux/suse/ SuSE/10.0-i386 base update security rpmkeys
# rpm ftp://ftp.gwdg.de/pub/linux/suse/ SuSE/10.0-i386 base update security rpmkeys

# The list with all available components can be found at:
# http://linux1.gwdg.de/apt4rpm
# Some components provide experimental software, select wisely!
# http://ftp.gwdg.de/pub/linux/suse/apt/S ... s.list.FTP

# Consult the link above if you want to include uri's for src rpms

rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 base
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 extra
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 funktronics
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 gnome
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 jacklab
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 java
repomd ftp://ftp.gwdg.de/pub/opensuse/repositories/KDE:/KDE3 SUSE_Linux_10.0
repomd ftp://ftp.gwdg.de/pub/opensuse/reposito ... /Backports SUSE_Linux_10.0
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 kde
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 kde3-stable
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 kde-unstable
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 kernel-of-the-day
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 kolab
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 kraxel
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 mozilla
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 openoffice
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 packman-i686
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 packman
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 rpmkeys
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 samba3
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 security
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suse-people
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suse-projects
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-agirardet
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-crauch
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-gbv
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-guru
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-hthen
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-jengelh
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-jogley
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-liviudm
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-oc2pus
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-ollakka
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-raoul
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-rbos
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-sbarnin
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-scorot
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-scrute
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-tcousin
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 update
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 usr-local-bin
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 wine
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 ximian
# rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 xorg
rpm http://ftp.heanet.ie/pub/jpackage/ 1.7/generic free
rpm http://mirrors.sunsite.dk/jpackage/ 1.6/generic free
rpm http://folk.uio.no/oeysteio/apt/suse/ 10.0-olsen Olsen
# rpm http://www.version6.net/apt/ SuSE/10.0-i386 version6
rpm http://eric.lavar.de/comp/linux/rpm/ noarch java
rpm http://macromedia.mplug.org/ rpm macromedia
rpm http://op4.xemini.de/linux/suse/apt SuSE/10.0-i386 xemini
#rpm http://download.opengroupware.org/night ... es/apt4rpm suse10-0/trunk OGo
#rpm http://download.opengroupware.org/night ... es/apt4rpm suse10-0/trunk ThirdParty
#rpm http://download.opengroupware.org/night ... es/apt4rpm suse10-0/trunk SOPE
#rpm http://download.opengroupware.org/night ... es/apt4rpm suse10-0/releases ThirdParty
#rpm http://download.opengroupware.org/night ... es/apt4rpm suse10-0/releases opengroupware-1.0beta.2-rock
#rpm http://download.opengroupware.org/night ... es/apt4rpm suse10-0/releases opengroupware-1.1.2-moveon
#rpm http://download.opengroupware.org/night ... es/apt4rpm suse10-0/releases opengroupware-1.1.3-moveon
#rpm http://download.opengroupware.org/night ... es/apt4rpm suse10-0/releases sope-4.4.0-cell
#rpm http://download.opengroupware.org/night ... es/apt4rpm suse10-0/releases sope-4.5.5-morecore
#rpm http://download.opengroupware.org/night ... es/apt4rpm suse10-0/releases sope-4.5.6-morecore

Wie und wo trage ich das von dir erwähnte Repo ein?

Bobbb

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 26. Jul 2006, 21:14

so zum Beispiel:

Code: Alles auswählen

repomd http://software.opensuse.org/download/home: rbos/SL-10.0_i586
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

BobbbMarley
Newbie
Newbie
Beiträge: 44
Registriert: 3. Dez 2004, 09:32

Beitrag von BobbbMarley » 28. Jul 2006, 21:17

funzt nu, vielen Dank

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast