[gelöst] Komischer Konflikt mit mono-core

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Seppl82
Newbie
Newbie
Beiträge: 17
Registriert: 8. Apr 2006, 14:03

[gelöst] Komischer Konflikt mit mono-core

Beitrag von Seppl82 » 19. Jul 2006, 23:03

Hallo zusammen,

heute habe ich Suse 10.1 installiert und habe seitdem einen saukomischen konflikt.
wenn ich

>>apt-get upgrade

mache kommt...

Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get --fix-broken install' to correct these.
The following packages have unmet dependencies:
mono-data: Depends: mono-core (= 1.1.13.7-6)
mono-data-sqlite: Depends: mono-core (= 1.1.13.7-6)
mono-web: Depends: mono-core (= 1.1.13.7-6)
E: Unmet dependencies. Try using --fix-broken.


wenn ich dann

>> apt-get install mono-core=1.1.13.7-6

eingebe kommt....


Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be DOWNGRADED
mono-core
0 upgraded, 0 newly installed, 1 downgraded, 0 removed and 150 not upgraded.
Need to get 0B/6365kB of archives.
After unpacking 2990B disk space will be freed.
Do you want to continue? [Y/n] Y
/bin/sh is needed by mono-core-1.1.13.7-6.i586
/bin/bash is needed by mono-core-1.1.13.7-6.i586
libc.so.6(GLIBC_2.0) is needed by mono-core-1.1.13.7-6.i586
libc.so.6(GLIBC_2.1) is needed by mono-core-1.1.13.7-6.i586
libc.so.6(GLIBC_2.1.2) is needed by mono-core-1.1.13.7-6.i586
libc.so.6(GLIBC_2.2) is needed by mono-core-1.1.13.7-6.i586
libc.so.6(GLIBC_2.3.2) is needed by mono-core-1.1.13.7-6.i586
libc.so.6(GLIBC_2.3.3) is needed by mono-core-1.1.13.7-6.i586
libc.so.6(GLIBC_2.4) is needed by mono-core-1.1.13.7-6.i586
libcrypt.so.1 is needed by mono-core-1.1.13.7-6.i586
libdl.so.2 is needed by mono-core-1.1.13.7-6.i586
libdl.so.2(GLIBC_2.1) is needed by mono-core-1.1.13.7-6.i586
libm.so.6 is needed by mono-core-1.1.13.7-6.i586
libm.so.6(GLIBC_2.0) is needed by mono-core-1.1.13.7-6.i586
libpthread.so.0 is needed by mono-core-1.1.13.7-6.i586
libpthread.so.0(GLIBC_2.1) is needed by mono-core-1.1.13.7-6.i586
libpthread.so.0(GLIBC_2.2) is needed by mono-core-1.1.13.7-6.i586
librt.so.1 is needed by mono-core-1.1.13.7-6.i586
E: Transaction set check failed
E: Handler silently failed

und wenn ich

>>apt-get --fixbroken install

mache kommt

Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
mono-core mono-data mono-data-sqlite mono-web
The following packages will be upgraded
mono-core mono-data mono-data-sqlite mono-web
4 upgraded, 0 newly installed, 0 removed and 147 not upgraded.
Need to get 0B/8459kB of archives.
After unpacking 2060B of additional disk space will be used.
Do you want to continue? [Y/n] Y
/bin/sh is needed by mono-data-1.1.13.8-6.i586
/bin/sh is needed by mono-web-1.1.13.8-6.i586
/bin/sh is needed by mono-core-1.1.13.8-6.i586
/bin/bash is needed by mono-core-1.1.13.8-6.i586
libc.so.6(GLIBC_2.0) is needed by mono-core-1.1.13.8-6.i586
libc.so.6(GLIBC_2.1) is needed by mono-core-1.1.13.8-6.i586
libc.so.6(GLIBC_2.1.2) is needed by mono-core-1.1.13.8-6.i586
libc.so.6(GLIBC_2.2) is needed by mono-core-1.1.13.8-6.i586
libc.so.6(GLIBC_2.3.2) is needed by mono-core-1.1.13.8-6.i586
libc.so.6(GLIBC_2.3.3) is needed by mono-core-1.1.13.8-6.i586
libc.so.6(GLIBC_2.4) is needed by mono-core-1.1.13.8-6.i586
libcrypt.so.1 is needed by mono-core-1.1.13.8-6.i586
libdl.so.2 is needed by mono-core-1.1.13.8-6.i586
libdl.so.2(GLIBC_2.1) is needed by mono-core-1.1.13.8-6.i586
libm.so.6 is needed by mono-core-1.1.13.8-6.i586
libm.so.6(GLIBC_2.0) is needed by mono-core-1.1.13.8-6.i586
libpthread.so.0 is needed by mono-core-1.1.13.8-6.i586
libpthread.so.0(GLIBC_2.1) is needed by mono-core-1.1.13.8-6.i586
libpthread.so.0(GLIBC_2.2) is needed by mono-core-1.1.13.8-6.i586
librt.so.1 is needed by mono-core-1.1.13.8-6.i586
E: Transaction set check failed
E: Handler silently failed

hat jemand eine Idee?

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 19. Jul 2006, 23:08

Das hört sich nicht gut an. RPM-Datenbank angeknackst?

Zur Diagnose bitte mal die Ausgabe der folgenden Befehle posten:

Code: Alles auswählen

rpm -qf /bin/sh
rpm -q --whatprovides /bin/sh
rpm -q --whatprovides 'libc.so.6(GLIBC_2.4)'
rpm -q bash
rpm -q glibc
arch
uname -a

Seppl82
Newbie
Newbie
Beiträge: 17
Registriert: 8. Apr 2006, 14:03

Beitrag von Seppl82 » 20. Jul 2006, 11:40

Okay, RPM DB hatte ein Problem

rpm -rebuilddb

hat geholfen!

DANKE!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste