Fehlermeldung beim updaten

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
krüger
Newbie
Newbie
Beiträge: 8
Registriert: 11. Sep 2005, 11:39

Fehlermeldung beim updaten

Beitrag von krüger » 15. Jul 2006, 21:54

Hallo
Ich bin nicht gerade ein meister was linux betrifft,aber seit neusten bekomme ich beim onlineupdate folgende fehlermeldung:


There was an error in installation source initialization.
Corrupt source, Expected SHA1 450a56c009c906446bb125095a96f5bede66e276, got
f8e4dde0f20c6077b5c36d539592203ce2030805
for /var/lib/zypp/cache/Source.N78bif/DATA/descr/packages.

Hat jemand eine Idee wie Ich diesen Fehler beheben kann?

Im Voraus vielen Dank

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 16. Jul 2006, 00:10

Welche Quellen sind unter "YaST -> Software -> Installationsquelle wechseln" angegeben?

krüger
Newbie
Newbie
Beiträge: 8
Registriert: 11. Sep 2005, 11:39

Beitrag von krüger » 16. Jul 2006, 11:07

http://packman.iu-bremen.de//suse//suse/10.1
iso://?iso=/home/krueger/psp/iso/SUSE-Linux-10.1-Gm-386-CD1.iso
iso///?iso=/home/krueger/software/rpm/suse-Linux-10.1Gm-addon-Biarch.iso
http://ftp.tu-chemnitz.de/pup/linux/sus ... date/10.1/

das sind die inst.quellen

Rain_Maker

Kein Wunder

Beitrag von Rain_Maker » 16. Jul 2006, 11:12

Hallo,

Schau Dir mal die Adressen an, das kann nix werden.

Trage die Quellen so ein, wie in den entsprechenden HowTos beschrieben, dann passiert sowas z.B.

http://packman.iu-bremen.de//suse//suse/10.1

nicht mehr.

Greetz,

RM

krüger
Newbie
Newbie
Beiträge: 8
Registriert: 11. Sep 2005, 11:39

Beitrag von krüger » 16. Jul 2006, 11:23

tut mit leid
beim abschreiben ist mir ein fehler passiet bei mir steht es so drin:http://packman.iu-bremen.de//suse/10.1
iso://?iso=/home/krueger/psp/iso/SUSE-Linux-10.1-Gm-386-CD1.iso
iso///?iso=/home/krueger/software/rpm/suse-Linux-10.1Gm-addon-Biarch.iso
http://ftp.tu-chemnitz.de/pup/linux/sus ... date/10.1/

krüger
Newbie
Newbie
Beiträge: 8
Registriert: 11. Sep 2005, 11:39

Beitrag von krüger » 16. Jul 2006, 11:35

ovell.Zenworks.Zmd.Public.ZenException: Failed to lookup resolvable with id '483539'

Server stack trace:
in <0x00178> Novell.Zenworks.Zmd.Packaging.RedCarpetBackend+SqlTransaction:GetResult ()
in <0x00081> Novell.Zenworks.Zmd.Packaging.RedCarpetBackend:ResolveDependencies (Novell.Zenworks.Zmd.Packaging.IResolvable[] installs, Novell.Zenworks.Zmd.Packaging.IResolvable[] upgrades, Novell.Zenworks.Zmd.Packaging.IResolvable[] removals)
in <0x00023> Novell.Zenworks.Zmd.Packaging.PackageManager:Resolve (Novell.Zenworks.Zmd.Packaging.IResolvable[] installs, Novell.Zenworks.Zmd.Packaging.IResolvable[] upgrades, Novell.Zenworks.Zmd.Packaging.IResolvable[] removals)
in <0x00038> Novell.Zenworks.Zmd.Packaging.RemotePackageManager:ResolveDependencies (Novell.Zenworks.Zmd.Packaging.Public.ResolvableInfo[] installs, Novell.Zenworks.Zmd.Packaging.Public.ResolvableInfo[] upgrades, Novell.Zenworks.Zmd.Packaging.Public.ResolvableInfo[] removals)
in <0x00000> <unknown method>
in (wrapper managed-to-native) System.Runtime.Remoting.RemotingServices:InternalExecute (System.Reflection.MethodBase,object,object[],object[]&)
in <0x00188> System.Runtime.Remoting.RemotingServices:InternalExecuteMessage (System.MarshalByRefObject target, IMethodCallMessage reqMsg)

Exception rethrown at [0]:

in <0x006dc> System.Runtime.Remoting.Proxies.RealProxy:PrivateInvoke (System.Runtime.Remoting.Proxies.RealProxy rp, IMessage msg, System.Exception exc, System.Object[] out_args)

Jetzt kann ich zwar sehen welche updates ich brauche aber beim aktualisieren kommt die vorherige fehlermeldung

Rain_Maker

Beitrag von Rain_Maker » 16. Jul 2006, 11:39

Da ich keine Lust habe, weiter zu raten, was Du richtig oder falsch abgeschrieben hast (wozu das überhaupt?, aber egal), gebe ich Dir einen allgemeinen Tipp.

Deaktiviere doch mal einzeln die Installationsquellen und schaue Dir an, welche Fehlermeldungen wann verschwinden. Dann weisst Du, WELCHE Quellen fehlerhaft sind.

Für die korrekte Syntax --> FAQ und SuFU.

Edit: Die Fehlermeldungen sehen auch eher (ich benutzen das ZEN-Geraffel nicht, deshalb *Ohne Gewähr*) nach einem Checksummenfehler in einem der Repos aus. Meist taucht das auf, wenn gerade am Server gebastelt wird und verschwindet nach kurzer Zeit wieder. Sollte dem nicht der Fall sein, dann Repo löschen und neu anlegen.

Greetz,

RM

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste