Katalog werden nicht aktualisiert

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
snwiem
Newbie
Newbie
Beiträge: 2
Registriert: 15. Jul 2006, 16:24

Katalog werden nicht aktualisiert

Beitrag von snwiem » 15. Jul 2006, 16:32

Hallo zusammen,
ich habe ein problem mit den Yast2 Installations-Quellen. Ich habe OpenSuse 10.1 korrekt von der aktuellen CHIP-DVD Installiert. Nachinstallation von diversen Packeten hat auch funktioniert. Nachdem ich dann Packman (wie im FAQ auf Packman-Home beschreiben) als Installations-Quelle hinzugefügt hatte und von dort ein weiteres Packet installiert habe (lame) funktioniert die Software-Installation nicht mehr korrekt. Es werden nur noch ein paar Packete von Pacman angezeigt. Der DVD-Katalog ist komplett verschwunden. Ein versuch die DVD wieder zu adden hat gar nicht geklappt. Danach versuchte ich die 10.1er dist von ftp.gwdg.de wie hier im Forum beschreiben hinzu zu fügen. Hinzufügen hat auch geklappt, allerdings werden in der Packet-Installation immer noch nur die Packete der vorherigen Pacman-Quelle angezeigt. Auch wiederholten enfernen aller Installations-Quellen und adden von nur ftp.gwdg.de hat nichts gebracht. Immer nur die Pacman-Packete.

Gibt es eine Möglichkeit auf Cmd-Line den/die Paket-Kataloge komplett zu reinitialisieren ?

Gruß
Sebastian

Werbung:
snwiem
Newbie
Newbie
Beiträge: 2
Registriert: 15. Jul 2006, 16:24

Re: Katalog werden nicht aktualisiert

Beitrag von snwiem » 15. Jul 2006, 16:54

SOLVED !!
snwiem hat geschrieben:Hallo zusammen,
ich habe ein problem mit den Yast2 Installations-Quellen. Ich habe OpenSuse 10.1 korrekt von der aktuellen CHIP-DVD Installiert. Nachinstallation von diversen Packeten hat auch funktioniert. Nachdem ich dann Packman (wie im FAQ auf Packman-Home beschreiben) als Installations-Quelle hinzugefügt hatte und von dort ein weiteres Packet installiert habe (lame) funktioniert die Software-Installation nicht mehr korrekt. Es werden nur noch ein paar Packete von Pacman angezeigt. Der DVD-Katalog ist komplett verschwunden. Ein versuch die DVD wieder zu adden hat gar nicht geklappt. Danach versuchte ich die 10.1er dist von ftp.gwdg.de wie hier im Forum beschreiben hinzu zu fügen. Hinzufügen hat auch geklappt, allerdings werden in der Packet-Installation immer noch nur die Packete der vorherigen Pacman-Quelle angezeigt. Auch wiederholten enfernen aller Installations-Quellen und adden von nur ftp.gwdg.de hat nichts gebracht. Immer nur die Pacman-Packete.

Gibt es eine Möglichkeit auf Cmd-Line den/die Paket-Kataloge komplett zu reinitialisieren ?

Gruß
Sebastian
Habe nen System-Neustart durchgeführt.Beim runterfahren hat sich gezeigt, daß ein Yast2-Prozess hängen geblieben ist. Nach abschießen und Neustart lassen sich wieder Installations-Quellen hinzufügen und die Kataloge werden korrekt upgedatet.

Sorry für den unnötigen Post.

Gruß
Sebastian

spoensche
Moderator
Moderator
Beiträge: 7241
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Beitrag von spoensche » 16. Jul 2006, 12:42

wenn du suse neui installiert hast,installiere dir am besten yum o.ä (paketmanager), dann aktualisierst du als erstes die updates für yast.

Wenn du das gemacht hast,kannst du die installationsquellen unter Yast->Installationsquelle wechseln.Leider hat yast einen bug nach der neuinstallation, nach dem update von yast ist das problem behoben.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast