Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Neue Installationquelle hinzufügen

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Jun 2006, 15:10

und ist da ein Proxy im Spiel ?
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Werbung:
Nefrah81
Newbie
Newbie
Beiträge: 20
Registriert: 22. Jun 2006, 12:44

Beitrag von Nefrah81 » 22. Jun 2006, 15:15

JA ein Proxy ist im Spiel. Lass mich raten. Es ist nicht zufällig unmöglich ein Update durchzuführen, wenn man sich in einem Intranet befindet oder ???
Allerdings komm ich auch problemlos auf Seiten wie gmx und google ode rhat das damit nichts zu tun ???
Zuletzt geändert von Nefrah81 am 22. Jun 2006, 15:16, insgesamt 1-mal geändert.

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 22. Jun 2006, 15:15

Doch aber dann muß man im Yast einstellen daß ein Proxy benutzt werden soll.

*nachguck*

yast2 - Netzwerkdienste - Proxyserver

Der yast schaut nicht nach welche Einstellungen Du im Browser gemacht hast wie das z.B. unter Windows geschieht wo der MSIE ja zwangsinstalliert wird. Unter Linux ist ja gar nicht sicher daß überhaupt IRGENDEIN Browser installiert ist. Und selbst wenn... konqueror, firefox, opera... wo soll er denn nachgucken ?
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Jun 2006, 15:26

schaust du hier:

[gelöst]Install-quelle in yast2 integrieren (behind Proxy)
http://www.linux-club.de/ftopic62450.html

das hatten wir die Tage erst hier im YaST Forum ... :mrgreen:
schau am Ende des Threads nach der Lösung

dieser Artikel dürfte dein Problem lösen:
http://support.novell.com/docs/Tids/Sol ... 95303.html

Code: Alles auswählen

The YaST2 Online Update (YOU) needs a direct connection to the Internet. If you connect via a proxy, this must be configured first:

    * Open /etc/wgetrc with an editor of your choice.
    * Enter this line:

http_proxy = http://your_proxy:port/

      your_proxy stands for the name of your proxy machine and port is the port number to which the proxy listens on the proxy machine.

In case you need to authenticate against your proxy, insert user name and password in /etc/wgetrc, too:

proxy_user=user
proxy_passwd=password

Do not forget to enter the HTTP proxy to use instead of an FTP proxy. Patches are always downloaded via HTTP, not via FTP.

Also, go into YaST -> Network Services -> Proxy, and put in the proxy information in there as well.  This is settings for a proxy client, not a proxy server
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Nefrah81
Newbie
Newbie
Beiträge: 20
Registriert: 22. Jun 2006, 12:44

Beitrag von Nefrah81 » 22. Jun 2006, 15:50

Habe die Eintragung in der Datei gemacht aber bringt nix

langsam geb ich auf. Also ich hab bis jetzt folgendes gemacht

den Proxy den ich verwende unter Yast --> Netzwerkdienste --> Proxy eingestellt
dann die Proxykonfigurationen auch in die Datei /etc/wgetrc geschrieben

aber wenn ich meine Proxyeinstellungen testen möchte, zeigt er mir immer die gleicher Fehlermeldung, und zwar, dass er die Verbindung zu dem von mir angegebenen Proxy nicht aufbauen kann, ich kann ihn allerdings mit Hilfe der Konsole anpingen.
Was soll ich denn noch machen ???

Braucht man eigentlich für jeden Proxy Zugriff eine Kennung und Passwort ???
Zuletzt geändert von Nefrah81 am 22. Jun 2006, 16:02, insgesamt 1-mal geändert.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Jun 2006, 15:59

Nefrah81 hat geschrieben:Habe die Eintragung in der Datei gemacht aber bringt nix
Was hast du für Eintragungen gemacht ?
Was bringt nix ?
Meine Glaskugel ist gerade zum polieren weggegeben ...

Hast du denn den anderen Thread überhaupt gelesen ?
Dort wurde doch ganz klar erklärt welche Informationen man zur Fehleranalayse braucht ...
und genau diese lieferst du bitte, sonst kommen wir nicht weiter mit deinem Problem :mrgreen:
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Nefrah81
Newbie
Newbie
Beiträge: 20
Registriert: 22. Jun 2006, 12:44

Beitrag von Nefrah81 » 22. Jun 2006, 16:11

Okay habe jetzt erstmal den Befehl rpm -qa|sort|grep yast ausgeführt:

autoyast2-2.13.51-3
autoyast2-installation-2.13.51-3
yast2-2.13.54-3
yast2-apparmor-2.0-25
yast2-backup-2.13.1-10
yast2-bluetooth-2.13.3-6
yast2-bootfloppy-2.13.51-3
yast2-bootloader-2.13.51-3
yast2-control-center-2.13.2-11
yast2-core-2.13.21-3
yast2-core-devel-2.13.21-3
yast2-country-2.13.23-3
yast2-dhcp-server-2.13.2-7
yast2-dns-server-2.13.11-5
yast2-firewall-2.13.7-7
yast2-hardware-detection-2.13.3-11
yast2-http-server-2.13.13-6
yast2-inetd-2.13.2-10
yast2-installation-2.13.91-2
yast2-irda-2.13.1-12
yast2-kerberos-client-2.13.4-5
yast2-ldap-2.13.4-6
yast2-ldap-client-2.13.13-4
yast2-mail-2.13.3-10
yast2-mail-aliases-2.13.3-10
yast2-mouse-2.13.7-14
yast2-ncurses-2.13.26-3
yast2-network-2.13.48-3
yast2-nfs-client-2.13.3-10
yast2-nfs-server-2.13.3-10
yast2-nis-client-2.13.3-6
yast2-nis-server-2.13.3-6
yast2-ntp-client-2.13.8-3
yast2-online-update-2.13.33-3
yast2-online-update-frontend-2.13.33-3
yast2-packager-2.13.102-2
yast2-pam-2.13.2-13
yast2-perl-bindings-2.13.4-15
yast2-phone-services-2.13.1-10
yast2-pkg-bindings-2.13.67-3
yast2-power-management-2.13.6-6
yast2-powertweak-2.13.5-12
yast2-printer-2.13.12-3
yast2-profile-manager-2.13.4-12
yast2-qt-2.13.52-3
yast2-repair-2.13.4-7
yast2-restore-2.13.1-10
yast2-runlevel-2.13.7-6
yast2-samba-client-2.13.17-5
yast2-samba-server-2.13.9-6
yast2-scanner-2.13.16-7
yast2-schema-2.13.2-11
yast2-security-2.13.2-12
yast2-slp-2.13.1-12
yast2-sound-2.13.9-10
yast2-storage-2.13.56-3
yast2-storage-lib-2.13.56-3
yast2-support-2.13.2-10
yast2-sysconfig-2.13.5-12
yast2-tftp-server-2.13.3-10
yast2-theme-SuSELinux-2.13.7-4
yast2-trans-de-2.13.16-3
yast2-transfer-2.13.3-10
yast2-trans-stats-2.11.0-19
yast2-tune-2.13.4-12
yast2-tv-2.13.8-6
yast2-update-2.13.25-3
yast2-users-2.13.16-8
yast2-vm-2.13.40-3
yast2-x11-2.13.6-36
yast2-xml-2.13.1-11
nefrah81@linux-demsfrg6:~> clear
nefrah81@linux-demsfrg6:~> rpm -qa|sort|grep yast
autoyast2-2.13.51-3
autoyast2-installation-2.13.51-3
yast2-2.13.54-3
yast2-apparmor-2.0-25
yast2-backup-2.13.1-10
yast2-bluetooth-2.13.3-6
yast2-bootfloppy-2.13.51-3
yast2-bootloader-2.13.51-3
yast2-control-center-2.13.2-11
yast2-core-2.13.21-3
yast2-core-devel-2.13.21-3
yast2-country-2.13.23-3
yast2-dhcp-server-2.13.2-7
yast2-dns-server-2.13.11-5
yast2-firewall-2.13.7-7
yast2-hardware-detection-2.13.3-11
yast2-http-server-2.13.13-6
yast2-inetd-2.13.2-10
yast2-installation-2.13.91-2
yast2-irda-2.13.1-12
yast2-kerberos-client-2.13.4-5
yast2-ldap-2.13.4-6
yast2-ldap-client-2.13.13-4
yast2-mail-2.13.3-10
yast2-mail-aliases-2.13.3-10
yast2-mouse-2.13.7-14
yast2-ncurses-2.13.26-3
yast2-network-2.13.48-3
yast2-nfs-client-2.13.3-10
yast2-nfs-server-2.13.3-10
yast2-nis-client-2.13.3-6
yast2-nis-server-2.13.3-6
yast2-ntp-client-2.13.8-3
yast2-online-update-2.13.33-3
yast2-online-update-frontend-2.13.33-3
yast2-packager-2.13.102-2
yast2-pam-2.13.2-13
yast2-perl-bindings-2.13.4-15
yast2-phone-services-2.13.1-10
yast2-pkg-bindings-2.13.67-3
yast2-power-management-2.13.6-6
yast2-powertweak-2.13.5-12
yast2-printer-2.13.12-3
yast2-profile-manager-2.13.4-12
yast2-qt-2.13.52-3
yast2-repair-2.13.4-7
yast2-restore-2.13.1-10
yast2-runlevel-2.13.7-6
yast2-samba-client-2.13.17-5
yast2-samba-server-2.13.9-6
yast2-scanner-2.13.16-7
yast2-schema-2.13.2-11
yast2-security-2.13.2-12
yast2-slp-2.13.1-12
yast2-sound-2.13.9-10
yast2-storage-2.13.56-3
yast2-storage-lib-2.13.56-3
yast2-support-2.13.2-10
yast2-sysconfig-2.13.5-12
yast2-tftp-server-2.13.3-10
yast2-theme-SuSELinux-2.13.7-4
yast2-trans-de-2.13.16-3
yast2-transfer-2.13.3-10
yast2-trans-stats-2.11.0-19
yast2-tune-2.13.4-12
yast2-tv-2.13.8-6
yast2-update-2.13.25-3
yast2-users-2.13.16-8
yast2-vm-2.13.40-3
yast2-x11-2.13.6-36
yast2-xml-2.13.1-11

Und in der Log Datei "y2log" steht folgendes:

2006-06-22 12:56:40 <1> linux-demsfrg6(4729) [solver] Resolver.cc(show_pool):911 2825: U__s_[package]myspell-norsk-bokmaal-20050308-20.noarch
2006-06-22 12:56:41 <1> linux-demsfrg6(4729) [solver] Resolver.cc(show_pool):911 2826: U__s_[package]myspell-polish-20051016-18.noarch
2006-06-22 12:56:41 <1> linux-demsfrg6(4729) [solver] Resolver.cc(show_pool):911 2827: U__s_[package]myspell-portuguese-20020629-241.noarch
2006-06-22 12:56:41 <1> linux-demsfrg6(4729) [solver] Resolver.cc(show_pool):911 2828: U__s_[package]myspell-romanian-20051021-18.noarch
2006-06-22 12:56:41 <1> linux-demsfrg6(4729) [solver] Resolver.cc(show_pool):911 2829: U__s_[package]myspell-russian-20040406-26.noarch
2006-06-22 12:56:41 <1> linux-demsfrg6(4729) [solver] Resolver.cc(show_pool):911 2830: U__s_[package]myspell-slovak-20050901-18.noarch
2006-06-22 12:56:41 <1> linux-demsfrg6(4729) [solver] Resolver.cc(show_pool):911 2831: U__s_[package]myspell-slovene-20030907-52.noarch
2006-06-22 12:56:41 <1> linux-demsfrg6(4729) [solver] Resolver.cc(show_pool):911 2832: U__s_[package]ndiswrapper-kmp-default-1.10_2.6.16.11_4-17.i586
2006-06-22 12:56:41 <1> linux-demsfrg6(4729) [solver] Resolver.cc(show_pool):911 2833: U__s_[package]myspell-swedish-20030904-52.noarch
2006-06-22 12:56:41 <1> linux-demsfrg6(4729) [solver] Resolver.cc(show_pool):911 2834: U__s_[package]myspell-spanish-20051029-18.noarch
2006-06-22 12:56:41 <1> linux-demsfrg6(4729) [solver] Resolver.cc(show_pool):911 2835: U__s_[package]myspell-welsh-20040425-26.noarch
@
"y2log" 58734L, 7917355C

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Jun 2006, 16:13

och nö ... das war der Part um die YaST Installation zu verifizieren ... hier leider uninteressant :mrgreen:

darauf wärst du aber selber gekommen, wenn du dir die Uhrzeit mal angeschaut hättest.

weiter lesen, dann kommt der Teil wo die Fehlermeldungen bzgl der Installationsquelle kommen ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Nefrah81
Newbie
Newbie
Beiträge: 20
Registriert: 22. Jun 2006, 12:44

Beitrag von Nefrah81 » 22. Jun 2006, 16:18

Meinst du Seite 2 auf dem Thread, wo es mit dem installation_source losgeht ???

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Jun 2006, 16:20

Nefrah81 hat geschrieben:Meinst du Seite 2 auf dem Thread, wo es mit dem installation_source losgeht ???
ich meine jetzt gar nix mehr ... verkaspern kann ich mich selber :mrgreen:
lies den anderen Thread nochmal von vorne bis hinten durch, dann wirst du sehen, das dort alles zur Lösung deines Problemes steht.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Nefrah81
Newbie
Newbie
Beiträge: 20
Registriert: 22. Jun 2006, 12:44

Beitrag von Nefrah81 » 22. Jun 2006, 17:09

Das wars. Ich hab jetzt beide Threads durchgearbeitet und es funktioniert immer noch nicht.
Hiermit gebe ich offiziell mit diesem Problem auf !
Nacht !

emoenke
Member
Member
Beiträge: 121
Registriert: 14. Jul 2005, 23:58

Beitrag von emoenke » 23. Jun 2006, 19:43

Nefrah81 hat geschrieben:OK es klappt NICHT. Folgende Fehlermeldung:

Installationsquelle kann nicht von
der URL 'http://ftp.gwdg.de/pub/linux/suse/ftp.s ... pdate/10.1' erstellt werden.

Was nun, oder ist wieder was an der URL verkehrt ???
Das ist nur der Update-Baum für hinterher. Kurzname übrigens /pub/suse/update/10.1.
Das geht als Installations-Quelle nur zusätzlich zu den beiden Haupt-Quellen:

/pub/opensuse/distribution/SL-10.1/inst-source
und
/pub/opensuse/distribution/SL-10.1/non-oss-inst-source

Die Haupt-Quelle ist /pub/opensuse/distribution/SL-10.1/inst-source, ohne die geht es nicht.

Benutzeravatar
kroete
Newbie
Newbie
Beiträge: 11
Registriert: 17. Dez 2006, 09:50
Kontaktdaten:

gleiches Problem mit SuSE 10.2

Beitrag von kroete » 17. Dez 2006, 19:16

Hallo..
habe das gleiche Problem mit SuSE 10.2 das ich keine Installationsquellen hinzufügen kann. Die Firewall in meinem System ist ausgeschaltet, aber wie ich die Firewall unseres Routers ausgeschaltet bekomme weiß ich leider nicht (Fritz!Box SL WLAN). Geht das über Protfreigabe? Bitte um Hilfe...
Danke

TIFFI
LINUX-NEWBEE

System: OPEN SUSE 10.02
Betriebssystem: Linux 2.6.18.2-34-default i686
KDE: 3.5.5 "release 45"

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 17. Dez 2006, 21:04

Welche Installationsquelle versuchst du einzubinden?
Mit rug oder YaST?

Fehlermeldung?

Meldungen in den Logs?
=> /var/log/YaST2/y2log
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

Benutzeravatar
kroete
Newbie
Newbie
Beiträge: 11
Registriert: 17. Dez 2006, 09:50
Kontaktdaten:

Beitrag von kroete » 17. Dez 2006, 21:45

Meldungen in den Logs?
=> /var/log/YaST2/y2log

=als root -> permission denied

Informationsquelle:
Server=sunsite.informatik.rwth-aachen.de
Verzeichnis: pub/Linux/opensuse/distribution/10.2/repo/src-non-oss/suse/nosrc/

Meldung: Installationsquelle .... URL ..... kann nicht erstellt werden
LINUX-NEWBEE

System: OPEN SUSE 10.02
Betriebssystem: Linux 2.6.18.2-34-default i686
KDE: 3.5.5 "release 45"

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5175
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Beitrag von tomm.fa » 17. Dez 2006, 22:09

Protokoll ist: FTP
Server paßt
Verzeichns auf dem Server: pub/Linux/opensuse/distribution/10.2/repo/non-oss/

Oder in YAST die komplette URL angeben:
ftp://sunsite.informatik.rwth-aachen.de ... o/non-oss/

Nein, ich verfolge dich nicht

Benutzeravatar
kroete
Newbie
Newbie
Beiträge: 11
Registriert: 17. Dez 2006, 09:50
Kontaktdaten:

Beitrag von kroete » 17. Dez 2006, 22:17

Hallo tomfa

Hat leider nicht geklappt.. Alles ausprobiert.
Protokoll:
ftp, http oder url alles funkt. nicht.

Habe in einem Threat gelesen, dass das an der Firewall des Routers liegt, weiß aber nicht wie man die deaktiviert (Fritz!Box SL WLAN). Muss man da ports freigeben oder was muss man da machen???

TIFFI
LINUX-NEWBEE

System: OPEN SUSE 10.02
Betriebssystem: Linux 2.6.18.2-34-default i686
KDE: 3.5.5 "release 45"

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 17. Dez 2006, 22:19

TIFFI hat geschrieben:=als root -> permission denied
:roll: Das ist eine Textdatei. Die musst du schon mit einem Programm öffnen (cat, less, ein Editor deiner Wahl, ...).
TIFFI hat geschrieben:Informationsquelle:
Server=sunsite.informatik.rwth-aachen.de
Verzeichnis: pub/Linux/opensuse/distribution/10.2/repo/src-non-oss/suse/nosrc/
Was genau willst du mit der Quelle?
Das sind Quellpakete für die non-oss Pakete
Btw: Der Pfad ist auch falsch.

Versuch folgendes (als root in der Konsole):

Code: Alles auswählen

rug sa --type=ZYPP http://ftp.tu-chemnitz.de/pub/linux/opensuse/distribution/10.2/repo/src-non-oss/suse src-non-oss
Für "richtige Quellen": Quellen für openSUSE 10.2
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

Benutzeravatar
kroete
Newbie
Newbie
Beiträge: 11
Registriert: 17. Dez 2006, 09:50
Kontaktdaten:

Beitrag von kroete » 17. Dez 2006, 22:46

EIN GROßES DANKESCHÖN AN DEN MODERATOR.......

HAT DEM NEWBIE SEHR GEHOLFEN!!!!!!!

DANKE

TIFFI
LINUX-NEWBEE

System: OPEN SUSE 10.02
Betriebssystem: Linux 2.6.18.2-34-default i686
KDE: 3.5.5 "release 45"

Antworten