Yast oder die unednliche Geschichte (Suse 10.1)

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

sewa4444
Newbie
Newbie
Beiträge: 15
Registriert: 13. Dez 2004, 20:46

Beitrag von sewa4444 » 20. Jun 2006, 13:49

So die INstallation über die Konsole hat hingehauen, obwohls vorher nicht ging - egal!
Nun aber noch was anderes, wo ihr schon von apt angefangen habt. Ich bekomm folgende Fehlermeldung:


apt upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Die folgenden Pakete werden upgegradet werden:
NetworkManager beagle beagle-firefox cairo cifs-mount curl db desktop-translations
esound gconf2 gimp glib glib2 glibc gnome-desktop gnome-filesystem gnome-icon-theme
gnome-keyring gnome-vfs2 gtk2 imlib2 imlib2-loaders jpackage-utils ktorrent lftp
libart_lgpl libbeagle libbonobo libcroco libgnome libgnomeprint libgnomesu libgphoto2
libgsf libidl libnl libsmbclient libsndfile libtheora libtunepimp mc mono-core
mono-data mono-data-sqlite mono-web mozilla-nspr mozilla-nss mozilla-xulrunner orbit2
pango poppler samba samba-client speex w32codec-all
Die folgenden Pakete sind zurückgehalten worden
amarok amarok-helix amarok-libvisual amarok-xine jack xmoto
55 upgraded, 0 newly installed, 0 entfernt und 6 nicht upgegradet.
Muss 0B/78,4MB an Archiven holen.
Nach dem Auspacken werden 7823kB zusätzlicher Plattenplatz benutzt werden.
Wollen Sie fortsetzen? [J/n] j
Checking GPG signatures...
Committing changes...
Preparing... ########################################### [100%]
file /opt/kde3/share/mimelnk/application/x-bittorrent.desktop from install of ktorrent-2.0_0.1-1.guru.suse101 conflicts with file from package kdelibs3-3.5.3-14.1
E: Error while running transaction
E: Handler silently failed

Das Paket erzeugt ein Konflikt, aber warum? - in der sources list müssten auch die server eingetragen von denen apt sich das richtige paket runterladen kann?! Oder woran liegts??

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 20. Jun 2006, 13:58

Code: Alles auswählen

file /opt/kde3/share/mimelnk/application/x-bittorrent.desktop from install of ktorrent-2.0_0.1-1.guru.suse101 conflicts with file from package kdelibs3-3.5.3-14.1 
da ist eine Datei in zwei Paketen enthalten ... da es sich um eine *.desktop Datei handelt kannst du diesen Fehler umgehen mit:

apt-get upgrade --force
Zuletzt geändert von oc2pus am 26. Jun 2006, 15:11, insgesamt 1-mal geändert.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

sewa4444
Newbie
Newbie
Beiträge: 15
Registriert: 13. Dez 2004, 20:46

Beitrag von sewa4444 » 26. Jun 2006, 15:09

Hat n bissl gedauert: Habs ausprobiert.... ohne Erfolg.
Apt mag den Befehl nicht und schlägt vor gleich apt-get zu verwenden, aber das klappt dann auch nicht.

wie kann ich denn apt sagen, daß es diese paket "aussparen" soll?

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 26. Jun 2006, 15:13

du wirst nun langsam OFF-Topic ...

was hat dein Thread Titel nun mit apt zu tun ?
stell deine Frage doch im richtigen Forum, bzw suche dort nach einer Lösung...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast