Seite 1 von 1

Update neben der Uhr stürzt ab, Wie updaten?

Verfasst: 5. Jun 2006, 17:31
von danielhruska
Also erstens: Das Update per Yast Online Update funktioniert nicht. Dort erhalte ich keine Patches angezeigt! Das Tool neben der Uhr zeigt mir 62 Patches an. Entweder aber es meldet lediglich: Resolver error (oder so ähnlich) oder es stürzt gleich mit dieser Meldung ab:

unhandled exception:

Novell.Zenworks.Zmd.Public.ZenException: Failed to lookup resolvable with id '178968'

Server stack trace:
in <0x00178> Novell.Zenworks.Zmd.Packaging.RedCarpetBackend+SqlTransaction:GetResult ()
in <0x00081> Novell.Zenworks.Zmd.Packaging.RedCarpetBackend:ResolveDependencies (Novell.Zenworks.Zmd.Packaging.IResolvable[] installs, Novell.Zenworks.Zmd.Packaging.IResolvable[] upgrades, Novell.Zenworks.Zmd.Packaging.IResolvable[] removals)
in <0x00023> Novell.Zenworks.Zmd.Packaging.PackageManager:Resolve (Novell.Zenworks.Zmd.Packaging.IResolvable[] installs, Novell.Zenworks.Zmd.Packaging.IResolvable[] upgrades, Novell.Zenworks.Zmd.Packaging.IResolvable[] removals)
in <0x00038> Novell.Zenworks.Zmd.Packaging.RemotePackageManager:ResolveDependencies (Novell.Zenworks.Zmd.Packaging.Public.ResolvableInfo[] installs, Novell.Zenworks.Zmd.Packaging.Public.ResolvableInfo[] upgrades, Novell.Zenworks.Zmd.Packaging.Public.ResolvableInfo[] removals)
in <0x00000> <unknown method>
in (wrapper managed-to-native) System.Runtime.Remoting.RemotingServices:InternalExecute (System.Reflection.MethodBase,object,object[],object[]&)
in <0x00188> System.Runtime.Remoting.RemotingServices:InternalExecuteMessage (System.MarshalByRefObject target, IMethodCallMessage reqMsg)

Exception rethrown at [0]:

in <0x006dc> System.Runtime.Remoting.Proxies.RealProxy:PrivateInvoke (System.Runtime.Remoting.Proxies.RealProxy rp, IMessage msg, System.Exception exc, System.Object[] out_args)




So, also wie kann ich updaten???

Verfasst: 5. Jun 2006, 17:35
von Martin Breidenbach
Ähnliche Probleme hatte ich auch.

Ich habe inzwischen apt unter SuSE 10.1 installiert und die Updates darüber gemacht.

Verfasst: 5. Jun 2006, 17:48
von danielhruska
welches apt, woher?

Verfasst: 5. Jun 2006, 17:55
von danielhruska
ok blöde frage, vergiss es :)

Verfasst: 5. Jun 2006, 18:19
von danielhruska
witzigerweise funktioniert das ganze via you jetzt über den direkten aufruf /sbin/yast2 online_update allerdings meldet mir you nun zu hauf abhängigkeitsprobleme bei kdebase, meldungen, die ich in dieser form eigentlich nie hatte. Fehlt da irgendwo ein Paket beim Onlineupdate?

Verfasst: 5. Jun 2006, 20:38
von spunti
Bei mir dasselbe: der Zen-Updater bringt eine Exception, wenn er gerade mal nicht kommentarlos abstürzt. You aus Yast heraus startet gar nicht erst.

"yast2 online_update" direkt starten klappt bei mir und ich hab nur den Abhängigkeitsfehler, dass Smart mir sagt: networkmanager braucht networkmanager-kde und networkmanager-kde braucht networkmanager.

Da hat mir Suse echt ein Ei ins Nest gelegt mir ihrer angeblich stabilen 10.1-Beta.

grüße
spunti