smart -> Frage zu meiner channel Liste u. ff

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
cbr
Member
Member
Beiträge: 189
Registriert: 13. Nov 2005, 20:17
Wohnort: Neubrandenburg

smart -> Frage zu meiner channel Liste u. ff

Beitrag von cbr » 31. Mai 2006, 21:33

Ich hab mich heute von apt verabschiedet und mir smart installiert. Folgende channels hab ich importiert (f. SuSE 10.0 OSS)

Code: Alles auswählen

smart channel --show
[suse-100-apt-security]
type = apt-rpm
name = SUSE Linux 10.0 APT Security Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = security

[suse-apt-security-gwdg]
type = apt-rpm
name = SUSE Linux packages apt-rpm repository on ftp.gwdg.de
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = security

[suse-100-apt-kde]
type = apt-rpm
name = SUSE Linux 10.0 APT kde Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = kde

[suse-100-apt-wine]
type = apt-rpm
name = SUSE Linux 10.0 APT wine Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = wine

[suse-100-apt-samba3]
type = apt-rpm
name = SUSE Linux 10.0 APT Samba3 Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = samba3

[rpm-sys]
type = rpm-sys
name = RPM System

[suse-100-yum-base]
type = rpm-md
name = SUSE Linux 10.0 YUM Base Repository
baseurl = ftp://ftp.gwdg.de/pub/opensuse/distribution/SL-10.0-OSS/inst-source/suse

[guru]
type = yast2
name = Guru 3rd party package repository
baseurl = http://ftp.gwdg.de/pub/linux/misc/suser-guru/rpm/10.0

[suse-100-apt-gnome]
type = apt-rpm
name = SUSE Linux 10.0 APT Gnome Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = gnome

[guru-100-apt]
type = apt-rpm
name = Guru 10.0 APT Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = suser-guru

[suse-100-apt-update]
type = apt-rpm
name = SUSE Linux 10.0 APT Update Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = update

[suse-apt-base-gwdg]
type = apt-rpm
name = SUSE Linux packages apt-rpm repository on ftp.gwdg.de
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = base

[suse-100-apt-mozilla]
type = apt-rpm
name = SUSE Linux 10.0 APT Mozilla Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = mozilla

[packman-100-yum]
type = rpm-md
name = Packman 10.0 YUM Repository
baseurl = http://packman.iu-bremen.de/suse/10.0/

[packman-100-apt]
type = apt-rpm
name = Packman 10.0 APT Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = packman

[suse-100-apt-java]
type = apt-rpm
name = SUSE Linux 10.0 APT Java Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = java

[suse-100-apt-openoffice]
type = apt-rpm
name = SUSE Linux 10.0 APT OpenOffice.org Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = openoffice

[suse-kde]
type = yast2
name = Latest wine packages
disabled = yes
baseurl = ftp://ftp.suse.com/pub/suse/i386/supplementary/KDE/update_for_10.0/yast-source

[suse-100-apt-extra]
type = apt-rpm
name = SUSE Linux 10.0 APT Extra Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = extra

[suse-100-apt-kde3-stable]
type = apt-rpm
name = SUSE Linux 10.0 APT KDE3-stable Repository
disabled = yes
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = kde3-stable

[suse-100-apt-base]
type = apt-rpm
name = SUSE Linux 10.0 APT Base Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = base

[guru-apt]
type = apt-rpm
name = suser-guru 3rd party package repository for SUSE Linux on ftp.gwdg.de
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = suser-guru

[packman-apt]
type = apt-rpm
name = Packman 3rd party package repository for SUSE Linux on ftp.gwdg.de
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = packman

[suse-apt-update-gwdg]
type = apt-rpm
name = SUSE Linux packages apt-rpm repository on ftp.gwdg.de
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = update

[suse-wine]
type = rpm-md
name = Latest wine packages
disabled = yes
baseurl = ftp://ftp.suse.com/pub/people/meissner/wine/10.0/

[suse-100-yum-extra]
type = rpm-md
name = SUSE Linux 10.0 YUM Extra Repository
baseurl = ftp://ftp.gwdg.de/pub/linux/suse/ftp.suse.com/suse/i386/10.0/SUSE-Linux10.0-GM-Extra/suse

[suse-mozilla]
type = rpm-md
name = Latest mozilla.org packages
baseurl = ftp://ftp.suse.com/pub/projects/mozilla/10.0

[suse-update]
type = rpm-md
name = SUSE Linux Online Updates
baseurl = ftp://ftp.suse.com/pub/suse/update/10.0/

[packman-i686-100-apt]
type = apt-rpm
name = Packman-i686 10.0 APT Repository
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = packman-i686

[suse-100-yum-java]
type = rpm-md
name = SUSE Linux 10.0 YUM Java Repository
baseurl = ftp://ftp.gwdg.de/pub/opensuse/distribution/SL-10.0-OSS/inst-source-java/suse
Naja, da ich da nu mal Neuling bin die Frage ob das so Sinn macht was ich da importiert habe um das System aktuell zu halten. Vielleicht kann mir mal jemand dazu seine Meinung sagen ?

smart upgrade (auf meine Channels liefert folgendes:

Code: Alles auswählen

smart upgrade
Lade Zwischenspeicher...
Update Zwischenspeicher...                                          ############################################################################################## [100%]

Berechne Vorgang ...

Erneuere Pakete (7):
  cron-4.1-26.2@i586                        kernel-default-nongpl-2.6.13-15.10@i586   libtunepimp-0.4.2-1.guru.suse100@i686     xmms-lib-1.2.10-100@i586
  kernel-default-2.6.13-15.10@i586          kernel-source-2.6.13-15.10@i586           libxml2-2.6.23-1.guru.suse100@i686

Entfernte Pakete (4):
  amarok-1.4.0_2.0-2.guru.suse100@i686                    amarok-xine-1.4.0_2.0-2.guru.suse100@i686
  amarok-libvisual-1.4.0_2.0-2.guru.suse100@i686          amarok-xmms-1.4.0_2.0-2.guru.suse100@i686

69.7MB an Paketdateien sind benötigt.255.7MB wird benutzt.
Wie es aussieht möchte smart amarok deinstallieren ... ?! Wenn ich richtig gelesen hab muss ich dafür eine Priorität eingeben, hat -X oder +X die höchste Priorität damit er es nicht entfernt ? Das Gleiche natürlich für den Kernel ;-)) !

Vielen Dank schon mal für Eure Antworten !
_____________________________________________
IBM ThinkPad T530 2429-6jg - Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz
Tumbleweed (x86_64)

Werbung:
Benutzeravatar
jsdfkkalfsjfjklafbjk
Member
Member
Beiträge: 213
Registriert: 13. Nov 2004, 14:04

Beitrag von jsdfkkalfsjfjklafbjk » 31. Mai 2006, 21:41

Du kannst Amarok mit der rechten Maustaste sperren, dann wird es nicht angetastet, oder du musst den Channel finden, der dafür verantwortlich ist, das Amarok deinstalliert wird und den Channel auf -1 setzen

Benutzeravatar
stulle
Hacker
Hacker
Beiträge: 284
Registriert: 23. Mai 2005, 22:49
Wohnort: Hildesheim

Beitrag von stulle » 31. Mai 2006, 21:44

Der Upgrade von libtunepimp ist schuld daran. Ich würde libtunepimp sperren.
Mit der smart --gui kannst du das ganz einfach machen und nur diese eine Version sperren lassen. Wenn es dann eine neue Version gibt, kannst du es erneut versuchen.

cbr
Member
Member
Beiträge: 189
Registriert: 13. Nov 2005, 20:17
Wohnort: Neubrandenburg

Beitrag von cbr » 1. Jun 2006, 09:08

Danke für die schnellen Antworten ! Ich habe mir die Channels für SuSE 10.0 KDE 3.5.3
erstellt. Um die Updates auf meine 3.5.2 anzuwenden. Ich hoffe das klappt ohne grössere Schwierigkeiten ... !?

Was ist in diesem Zusammenhang im kde backports_yum enthalten ?
_____________________________________________
IBM ThinkPad T530 2429-6jg - Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz
Tumbleweed (x86_64)

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 1. Jun 2006, 12:45

Wie bereits im anderen Thread gesagt:

- Das KDE3-Repository enthält jetzt nur noch die KDE-Basispakete: qt3, kdelibs3, kdebase3 usw. Keine KDE-Programme mehr.

- Das Backports-Repository enthält jetzt nur noch KDE-Programme: amarok, koffice, gwenview usw. Keine KDE-Basispakete mehr.

Zusammen ergeben beide Repositories wieder genau das alte KDE-Repository. Jetzt musst Du Dich entscheiden:

- Wenn alles so sein soll wie bisher, dann nimm beide Repositories.

- Wenn Du nur die neuesten KDE-Programme haben willst ohne das Risiko, den kompletten Desktop zu vermurksen, dann nimm nur das Backports-Repository.

Nur das KDE3-Repository zu nehmen, hat keinen Sinn.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste