[gelöst]Suse 9.1 - YOU funktioniert plötzlich nicht mehr ...

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
twobeers
Newbie
Newbie
Beiträge: 16
Registriert: 8. Mär 2005, 16:46

[gelöst]Suse 9.1 - YOU funktioniert plötzlich nicht mehr ...

Beitrag von twobeers » 29. Mai 2006, 17:34

Hallo,

ich verwende SuSE Linux 9.1 Professional und habe gestern im Online-Update ein paar Pakete ausgewählt und installiert. Heute wollte ich das Update fortsetzen und ich bekomme leider immer die Fehlermeldung:

"Befehl yast2 'online_update' nicht gefunden"

auch die "Update-Überprüfung" aus dem SuSE-Watcher funktioniert nicht mehr ... :(

Internet geht sicher und ich habe auch nichts umgestellt, root bin ich auch - scheint irgendwie am Yast2 zu liegen - das Modul "Software installieren und löschen" funktioniert auch nicht mehr!

Hat irgendjemand einen Idee was ich machen kann - ich habe leider im Internet auch keine wirklich brauchbare Hilfe über Google oder die Boardsuche gefunden.

Vielen Dank für eure Bemühungen!
Grüße, TwoBeers

\edit: ich habe das Logfile "youlog" aus file:/var/lib/YaST2/you studiert, da gibt es folgende Fehlermeldungen mit
2006-05-27 20:42:05 (11919): dia: "Pufferüberläufe im xfig import von dia" wird installiert
2006-05-27 20:42:06 (11919): Fehler
2006-05-27 20:42:10 (11919): cpio: "security update für cpio" wird installiert
2006-05-27 20:42:10 (11919): Fehler
falls das jemanden weiterhilft!
Zuletzt geändert von twobeers am 31. Mai 2006, 09:34, insgesamt 2-mal geändert.

Werbung:
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 29. Mai 2006, 17:37

9.1 ist Geschichte.
Wird nicht mehr unterstützt und die you-Verzeichnisse dafür wurden geräumt.
Steig auf was moderneres um.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

twobeers
Newbie
Newbie
Beiträge: 16
Registriert: 8. Mär 2005, 16:46

Beitrag von twobeers » 29. Mai 2006, 17:38

Grothesk hat geschrieben:9.1 ist Geschichte.
Wird nicht mehr unterstützt und die you-Verzeichnisse dafür wurden geräumt.
Steig auf was moderneres um.
hat aber gestern abend noch funktioniert ... wieso sollte es heute nicht mehr gehen? bin irgendwie sehr zufrieden damit und möchte den Rechner nicht schon wieder neu installieren!

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 29. Mai 2006, 17:43

Vermutlich hat just übernacht jemand die Verzeichnisse gelöscht. Ich habe jetzt kein genaues Datum dafür im Kopf, aber 9.1 lief die Tage aus. Du findest also nur noch was im 'discontinued'-Ordner.


[Edit:] Am 15.06.2006 ist es soweit.
Sieh hier:
http://lists.suse.com/archive/suse-linu ... /1222.html

Also dich nach etwas aktuellerem umzuschaun würde ich dir anraten.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

twobeers
Newbie
Newbie
Beiträge: 16
Registriert: 8. Mär 2005, 16:46

Beitrag von twobeers » 30. Mai 2006, 09:53

Grothesk hat geschrieben:Am 15.06.2006 ist es soweit.
habe ich auch so rausgelesen ... also scheint der Fehler doch irgendwo in meinem System zu stecken - irgendeine Ahnung?
Ich kann ja auch nichts mehr normal installieren aus dem Yast2-Modul "Software installieren und löschen".

thx für deine (eure) Bemühungen!
TwoBeers

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8746
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 30. Mai 2006, 09:58

Funktioniert eine Installation mit "rpm" aus der Shell?
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

twobeers
Newbie
Newbie
Beiträge: 16
Registriert: 8. Mär 2005, 16:46

Beitrag von twobeers » 30. Mai 2006, 10:06

admine hat geschrieben:Funktioniert eine Installation mit "rpm" aus der Shell?
ja - problemlos, es scheint mir nur irgendwie diese Yast2-Sachen zerschossen zu haben ... :(

kann das von den Fehlern aus dem youlog aus dem ersten Post kommen? wie kann ich das ganze wieder korrigieren?

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8746
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 30. Mai 2006, 10:10

Moment ... da gabs doch etwas in der SuSE-SDB:
http://de.opensuse.org/SDB:YaST_funktio ... nicht_mehr
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

twobeers
Newbie
Newbie
Beiträge: 16
Registriert: 8. Mär 2005, 16:46

Beitrag von twobeers » 30. Mai 2006, 16:38

@admine: danke für den Tipp - ich habe der Anleitung nach im Link das alles so gemacht und bekomme die Meldung:
"package popt-1.7-176.3 is already installed"

es gehen im YaST-Kontrollzentrum ja interessanterweise auch nur die beiden Punkte "Online-Update" und "Software installieren oder löschen" nicht - der Rest funktioniert problemlos!
Zudem meldet auch der Susewatcher, dass die Update-Üpterprüfung fehlgschlagen hat und bei Klick auf Starte online update kommt die oben bschriebene Fehlermeldung ... noch irgendwelche Ideen?

twobeers
Newbie
Newbie
Beiträge: 16
Registriert: 8. Mär 2005, 16:46

Beitrag von twobeers » 30. Mai 2006, 16:46

ich habe jetzt einfach mal in der Konsole als su den Befehle online_update eingegeben und bekomme folgende Meldung:

"online_update: error while loading shared libraries: /usr/lib/liby2pm.so.2: undefined symbol: _ZN6VendorC1ERKSs"

Hilft das jemanden weiter?

/EDIT: mir selber hat es weitergeholfen :lol:
ich habe im Internet dazu was gefunden: man muss "einfach" von der Original-DVD die Datei liby2util-2.9.22-0.i586.rpm einspielen (z.B.: in tmp) und dann in der Konsole ausführen:
rpm -i --force /tmp/liby2util-2.9.22-0.i586.rpm

das Online-Update geht wieder - bin ja gespannt ob es nachdem ich es ausgeführt habe auch noch funktioniert ...
danke für eure Bemühungen - ich werde Bescheid geben ob alles funktioniert hat - falls es jemanden interessiert!

twobeers
Newbie
Newbie
Beiträge: 16
Registriert: 8. Mär 2005, 16:46

Beitrag von twobeers » 31. Mai 2006, 08:59

habe jetzt mal die ganzen Updates gemacht und es funktioniert "noch" immer alles - Problem ist also gelöst (bitte dementsprechend markieren!).

Vielen Dank für eure Unterstützung :)

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8746
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 31. Mai 2006, 09:14

twobeers hat geschrieben:Problem ist also gelöst (bitte dementsprechend markieren!).
Das kannst du bitte selbst tun, indem du deinen ersten Beitrag editierst und ein [gelöst] im Titel ergänzt :)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

twobeers
Newbie
Newbie
Beiträge: 16
Registriert: 8. Mär 2005, 16:46

Beitrag von twobeers » 31. Mai 2006, 09:35

:oops: sorry - das wußte ich nicht ... ich dachte mir es gibt einen Button für die Admins der das dann dementsprechend markiert!

habe es jetzt natürlich selbst gemacht ...

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast