Error: Missing Dependency: libpq.so.3 is needed by package h

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
cni
Newbie
Newbie
Beiträge: 5
Registriert: 18. Mai 2006, 15:29

Error: Missing Dependency: libpq.so.3 is needed by package h

Beitrag von cni » 18. Mai 2006, 15:35

Hallo Zusammen

bin neu in diesem forum und es sieht echt gut aus.

ich habe ein problem. ich möchte httpd-2.2.2-1.i386.rpm
installieren.

yum install httpd-2.2.2-1.i386.rpm

und bekomme den folgenden fehler.
Error: Missing Dependency: libpq.so.3 is needed by package httpd

ich habe das postgresql-libs-8.1.3-1PGDG.i686.rpm installiert jedoch geht es immer noch nicht.

könnt ihr mir vielleicht helfen?

danke

gruss
cni

Werbung:
flo41
Hacker
Hacker
Beiträge: 290
Registriert: 9. Feb 2005, 11:47

Beitrag von flo41 » 18. Mai 2006, 19:15

kann es sein das das Paket das du installiert hast eine andere Version der Datei bereitstellt als httpd benötigt?
System:
Athlon XP 2600+
768MB RAM
MSI NX6600GT VTD 128
-------
SuSE 10.1 OSS
-------
Bild

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 18. Mai 2006, 21:33

Dann liefer doch bitte die Information:

Code: Alles auswählen

rpm -ql postgresql-libs | grep libpq
Und es wäre außerdem sehr nett, wenn Du auch noch Deine Distribution nennen könntest, die Angabe brauche ich nämlich.

Wahrscheinlich versuchst Du einen Mix von Paketen für unterschiedliche Distributionen zu machen, das geht aber nicht.

cni
Newbie
Newbie
Beiträge: 5
Registriert: 18. Mai 2006, 15:29

Beitrag von cni » 19. Mai 2006, 08:01

hallo und danke für eure antworten



[root@bee01 ~]# rpm -ql postgresql-libs | grep libpq
/usr/lib/libpq.so.4
/usr/lib/libpq.so.4.1
/usr/share/locale/af/LC_MESSAGES/libpq.mo
/usr/share/locale/cs/LC_MESSAGES/libpq.mo
/usr/share/locale/de/LC_MESSAGES/libpq.mo
/usr/share/locale/es/LC_MESSAGES/libpq.mo
/usr/share/locale/fr/LC_MESSAGES/libpq.mo
/usr/share/locale/hr/LC_MESSAGES/libpq.mo
/usr/share/locale/it/LC_MESSAGES/libpq.mo
/usr/share/locale/ko/LC_MESSAGES/libpq.mo
/usr/share/locale/nb/LC_MESSAGES/libpq.mo
/usr/share/locale/pl/LC_MESSAGES/libpq.mo
/usr/share/locale/pt_BR/LC_MESSAGES/libpq.mo
/usr/share/locale/ru/LC_MESSAGES/libpq.mo
/usr/share/locale/sk/LC_MESSAGES/libpq.mo
/usr/share/locale/sl/LC_MESSAGES/libpq.mo
/usr/share/locale/sv/LC_MESSAGES/libpq.mo
/usr/share/locale/tr/LC_MESSAGES/libpq.mo
/usr/share/locale/zh_CN/LC_MESSAGES/libpq.mo
/usr/share/locale/zh_TW/LC_MESSAGES/libpq.mo
[root@bee01 ~]#


[root@bee01 ~]# yum list installed | grep "post*"
postgresql.i386 8.1.3-1 installed
postgresql-docs.i686 8.1.3-1PGDG installed
postgresql-jdbc.i686 8.1.3-1PGDG installed
postgresql-libs.i386 8.1.3-1 installed
postgresql-server.i386 8.1.3-1 installed
[root@bee01 ~]#


und arbeite mit fedora 5.

reicht das?
gruss
cni

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 19. Mai 2006, 08:13

Ja, das reicht.

Lösch beide Pakete, deinstallier postgresql-libs wieder und installier dann beides mit yum aus dem Fedora-Repository.

Wenn yum richtig konfiguriert ist, reicht ein einfaches

Code: Alles auswählen

yum install httpd

cni
Newbie
Newbie
Beiträge: 5
Registriert: 18. Mai 2006, 15:29

Beitrag von cni » 19. Mai 2006, 08:28

hey traffik cool, danke für deine schnelle antwort
ja ich versuch es jetzt

cni
Newbie
Newbie
Beiträge: 5
Registriert: 18. Mai 2006, 15:29

Beitrag von cni » 19. Mai 2006, 08:50

hey geil hat geklappt
thx a lot!!

cni
Newbie
Newbie
Beiträge: 5
Registriert: 18. Mai 2006, 15:29

Beitrag von cni » 19. Mai 2006, 08:58

also ich aber postsql... deinstallierte, hat er mir auch das post...server deinstalliert.

ich möchte jetzt das packet nochmals installieren und brachte mit folgenden fehler


Transaction Summary
=============================================================================
Install 2 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
Total download size: 20 M
Is this ok [y/N]: y
Downloading Packages:
(1/1): postgresql-8.1.3-1.i386.rpm 2.8 MB 00:56


Package postgresql-server-8.1.3-1PGDG.i686.rpm is not signed

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast