Abhängigkeits-Problem

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
christopher_m
Newbie
Newbie
Beiträge: 11
Registriert: 21. Jan 2005, 14:28

Abhängigkeits-Problem

Beitrag von christopher_m » 10. Mai 2006, 17:18

Hi,

jedesmal, wenn ich ein upgrade mit apt machen möchte, erhalte ich folgende Fehlermeldung, dass die libpng.so.2 nicht installiert ist:

linux:/home/christopher # apt upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
You might want to run `apt-get --fix-broken install' to correct these.
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
bjfilter-pixusip4100: Hängt ab von: libpng.so.2 aber es ist nicht installierbar
E: Unmet dependencies. Try using --fix-broken.

Kann ich es bei apt einstellen, dass das Paket bjfilter-pixusip4100 dauerhaft ignoriert wird? Entfernen möchte ich dieses Paket nämlich nicht, denn sonst verweigert mein Drucker seine Arbeit ;-)

Christopher

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 10. Mai 2006, 18:10

ja, dazu musst du dieses Paket aus der RPM-Datenbank entfernen:
rpm -e --justdb bjfilter-pixusip4100

die Dateien etc werden dadurch nicht gelöscht :)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Pumphaus
Member
Member
Beiträge: 152
Registriert: 10. Jul 2005, 13:15
Kontaktdaten:

Beitrag von Pumphaus » 10. Mai 2006, 18:27

Du kannst dir aber auch mal die Datei /etc/apt/apt.conf.d/apt.conf anschauen. Da kann man ignores festlegen.
Athlon64 X2 6000+
nVidia GeForce 8800GTS 640MB
Gentoo
--
Jabber: pumphaus@jabber.ccc.de

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste