Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] problem mit tovid über apt

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
faxweiche
Newbie
Newbie
Beiträge: 36
Registriert: 7. Mai 2006, 09:52
Kontaktdaten:

[gelöst] problem mit tovid über apt

Beitrag von faxweiche » 7. Mai 2006, 10:24

ich habe apt wie hier beschrieben konfiguriert und versuche nun tovid bzw. tovid-gui zu mit apt zu installieren. dabei erhalte ich folgende fehlermeldung:
Committing changes...
Preparing... ########################################### [100%]
file /usr/lib/libmp4v2.so.0.0.0 from install of libmp4v2-1.4.1-2 conflicts with file from package faad2-2.0-0.pm.7
E: Error while running transaction
E: Handler silently failed
wie kann ich den konflikt beheben?
besten dank im voraus.

[edit] yo, ich hatte mich dann auch daran gemacht faad mal auf den neuesten stand zu bringen, danach ging es. besten dank!
Zuletzt geändert von faxweiche am 7. Mai 2006, 11:44, insgesamt 1-mal geändert.
my drinking team has a rowing problem

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 7. Mai 2006, 10:34

Indem Du faad2 auf Version 2.0-0.pm.8 aktualisierst.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 7. Mai 2006, 10:35

welche SuSE-Version?
bitte immer angeben :)

die Fehlermeldung besagt das in den Paketen libmp4v2-1.4.1-2 und faad2-2.0-0.pm.7 die Datei /usr/lib/libmp4v2.so.0.0.0 enthalten ist.

d.h. du brauchst nur eines von den beiden Paketen. Also deinstalliere eines von beiden.

und es ist kein Problem von tovid(-gui), dieses Paket braucht nur diese:

Code: Alles auswählen

Requires: 	mjpegtools
Requires: 	MPlayer
Requires: 	normalize
Requires: 	ffmpeg
Requires: 	ImageMagick >= 6.0
Requires: 	transcode
Requires: 	dvdauthor >= 0.6.0
#Requires: 	libdvdcss
Requires: 	lsdvd
Requires: 	sox
Requires: 	vcdimager
Requires: 	mkisofs
Requires:       dvd+rw-tools
==> du hast dir diesen Fehler irgendwo anders eingefangen.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 7. Mai 2006, 16:36

Das Problem kommt daher, dass faad2-Versionen bis 0.pm.7 eine eigene Kopie der libmp4v2 enthalten. Das ist ein Bug, und dieser Bug ist in den faad2-Versionen ab 0.pm.8 gefixt.

Das Problem wird deshalb beim Installieren von tovid sichtbar, weil die libmp4v2 zwar keine direkte, aber eine indirekte Abhängigkeit von tovid ist.

Antworten