Error loading language plugin /usr/lib/YaST2/plugin/libpy2la

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Ludi
Member
Member
Beiträge: 65
Registriert: 10. Apr 2006, 21:43

Error loading language plugin /usr/lib/YaST2/plugin/libpy2la

Beitrag von Ludi » 2. Mai 2006, 21:14

Hi Leute,

hier SuSE 9.2 und 'yast' will nicht starten im Textmode:

Code: Alles auswählen

x:/home/xxx # yast
Error loading language plugin /usr/lib/YaST2/plugin/libpy2lang_perl.so: libperl.so: cannot open shared object file: No such file or directory
No such client module menu

Run 'yast2 -h' for help on usage
x:/home/schreier #

Jetzt habe ich bisschen gegoogelt und mal das RPM Paket (s.u.) installiert, aber bei `yast` kommt trotzdem die selbe Fehlermeldung! Was nun?

Code: Alles auswählen

x:/home/xxx # rpm -i yast2-perl-bindings-2.10.3-2.1.i586.rpm
        package yast2-perl-bindings-2.10.3-2.1 is already installed
Danke fuer Hilfe,
Gruss

Werbung:
Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8744
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 3. Mai 2006, 07:26

Versuch mal mit "rpm -Uhv" bzw "rpm -Fhv" das RPM upzudaten bzw. zu freshen.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Ludi
Member
Member
Beiträge: 65
Registriert: 10. Apr 2006, 21:43

Beitrag von Ludi » 3. Mai 2006, 16:14

Habe ich gemacht, passieren tut das:

Code: Alles auswählen

x:~ # rpm -qa |grep yast2-perl
yast2-perl-bindings-2.10.3-2.1

x:~ # rpm -Uhv `rpm -qa|grep yast2-perl`
error: open of yast2-perl-bindings-2.10.3-2.1 failed: No such file or directory

x:~ # rpm -Fhv `rpm -qa|grep yast2-perl`
error: open of yast2-perl-bindings-2.10.3-2.1 failed: No such file or directory
Schon seltsam.
Gruss,
L

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8744
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 3. Mai 2006, 21:00

Ich würde es ja eher so versuchen:

Code: Alles auswählen

rpm -Uhv yast2-perl-bindings-2.10.3-2.1.i586.rpm
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Ludi
Member
Member
Beiträge: 65
Registriert: 10. Apr 2006, 21:43

Beitrag von Ludi » 4. Mai 2006, 11:56

Naaajaaa Admine :),
schau:

Code: Alles auswählen

x:~ # rpm -qa |grep yast2-perl
yast2-perl-bindings-2.10.3-2.1
x:~ # rpm -Uvh yast2-perl-bindings-2.10.3-2.1.i586.rpm
Preparing...                ########################################### [100%]
        package yast2-perl-bindings-2.10.3-2.1 is already installed
x:~ # rpm -Fvh yast2-perl-bindings-2.10.3-2.1.i586.rpm
x:~ #

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste