Yast installiert keine RPM-Pakete mehr , Suse 10.0

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
PeterLustig
Newbie
Newbie
Beiträge: 5
Registriert: 19. Apr 2006, 19:52

Yast installiert keine RPM-Pakete mehr , Suse 10.0

Beitrag von PeterLustig » 30. Apr 2006, 15:34

tag,

ich habe folgendes problem: seit gestern funktioniert mein yast nicht mehr wie es soll, d.h. sobald ich ein rpm-paket öffne und den button "Paket mit Yast installieren" betätige startet sich yast auch wie gewohnt, er überprüft die Installationsquellen und dann bleibt er in der suchmaske stehen. Die eigentliche Installation des Paketes startet nicht mehr!!! ebenso kann ich auch keine RPM-Pakete mehr als Installationsquellen hinzufügen!!! Was kann da passiert sein? es kommen keine fehlermeldungen so das man das problem einschränken könnte, kann mir da jemand helfen?

ich nutze Suse 10.0 mit KDE 3.5.2.

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 30. Apr 2006, 15:46

sollen wir dich nur bedauern oder möchtest du Hilfe haben ?

im ersten Fall:
och du armer, so ein böses YaST :mrgreen:

für den zweiten Fall:
welche exakten Fehlermeldungen ?
was hast du vorher gemacht/updates etc ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin » 30. Apr 2006, 15:57

Ohne Fehlermeldung artet das hier zu einer interessanten Suche nach der Stecknadel im Heuhaufen aus.

1. Versuch: gib mal in der Konsole als root folgendes ein:

Code: Alles auswählen

rpm --rebuilddb
2. Versuch: boote von deiner Suse DVD und lass eine Systemreparatur durchlaufen.

3. Versuch: Kannst du Pakete über die Konsole installieren?

Code: Alles auswählen

rpm -Uhv Paket.rpm
Fehlermeldungen?

4. Versuch: Liegen die Pakete in einem Verzeichnis, dessen Name Leerzeichen enthält? Damit kann YaST schon mal Probleme haben.
=> Ersetz die Leerzeichen durch Unterstriche (/Verzeichnis_mit_meinen_Downloads/) und teste erneut.
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"

PeterLustig
Newbie
Newbie
Beiträge: 5
Registriert: 19. Apr 2006, 19:52

Beitrag von PeterLustig » 30. Apr 2006, 16:09

oc2pus hat geschrieben: für den zweiten Fall:
welche exakten Fehlermeldungen ?
was hast du vorher gemacht/updates etc ...
steht da doch! :shock:
KEINE FEHLERMELDUNGEN!
aus der Konsole heraus kann ich installieren was ich will, geht ohne probleme...

also, ich habe alle versuche bis auf die systemreperatur durchgefürht, ohne erfolg...es kann aber doch nicht einfach so kaputt gehen, das ist doch schliesslich ein linux system! :D
nun ja, ich bin echt ratlos, wenn nix mehr hilft und mir keiner weiterhelfen kann, werde ich das system nochmal neu aufspielen. das kann es aber doch nich sein...

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 30. Apr 2006, 16:12

starte das YaST mal aus einer Konsole ... dann kommen die Fehlermeldungen ans Tageslicht :)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

PeterLustig
Newbie
Newbie
Beiträge: 5
Registriert: 19. Apr 2006, 19:52

Beitrag von PeterLustig » 30. Apr 2006, 16:18

also, ich starte yast aus der konsole heraus via "yast2" -> Yast startet, soweit so gut.
öffne dann im konquerer ein beliebiges RPM-Paket, welches vor wenigen tagen noch ohne probleme installiert werden konnte, und will es mit Yast installieren -> Installation startet nicht und ich bekomme keine Fehlermeldung oder irgendein Feedback über die Konsole,
:(

Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin » 30. Apr 2006, 16:23

Vor einer Neuinstallation teste jedenfalls die Systemreparatur!
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast