Problem mit INstallation über Synaptic

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
bigdadyx
Member
Member
Beiträge: 77
Registriert: 1. Feb 2006, 23:43

Problem mit INstallation über Synaptic

Beitrag von bigdadyx » 10. Apr 2006, 10:58

Hi Leute, wenn ich als Beispiel einfach mal 3 Pakete anklicke die er installieren soll und ich dann bei "Verify Package Signatures" den Haken wegmache, dann ist das doch im Prinzip

--no-checksig, oder?

er müsste also einfach installieren, dennoch wenn eins eine falsche oder keine sigatur hat, dann installiert er keins der Pakete...
Warum?

dann noch ein prob, wollte "jonas" instaleren per console, hier die ausgabe:

Code: Alles auswählen

linux:~ # apt install jonas
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  jonas: Depends: carol (= 0:1.8.9.4) but it is not going to be installed
         Depends: jts (= 0:1.0) but it is not installable
         Depends: monolog (= 0:1.8.6) but 0:2.0-2jpp is to be installed
E: Broken packages
warum wird carol nicht installiert und jts gar nicht möglich zu installieren?

heisst das bei monolog, dass er mit höheren installierten version nicht arbeiten kann?

THX
bigdadyx

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 10. Apr 2006, 11:32

The following packages have unmet dependencies:
jonas: Depends: carol (= 0:1.8.9.4) but it is not going to be installed
Depends: jts (= 0:1.0) but it is not installable
Depends: monolog (= 0:1.8.6) but 0:2.0-2jpp is to be installed
jonas WILL monolog=0:1.8.6 haben ...

ermittle mit apt policy jonas carol jts welche Versionen es gibt und probiere dann mit apt install jonas=<version>0:1.8.6 jts=<version2> carol=<version3> ob es eine Kombination gibt welche auflösbar ist

ansonsten einen Bugzilla Eintrag schreiben und melden das Paket jonas exakt eine monolog Version braucht, evtl muss die Abhängigkeit dann korrigiert werden.

Buguzilla jpackage hier:
https://www.jpackage.org/bugzilla/

Nachtrag:
jts ist KEIN freies Paket, d.h. es gibt nur ein nosrc.rpm dazu und du musst es selber erstellen ...
schaust du hier:
No binary packages, sorry. See rebuilding instructions.
http://www.jpackage.org/rebuilding.php
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

bigdadyx
Member
Member
Beiträge: 77
Registriert: 1. Feb 2006, 23:43

Beitrag von bigdadyx » 10. Apr 2006, 12:21

ok, danke werd mich mal einlesen...

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste