Problem beim Installieren mit Yast2

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Gesperrt
matrix2712
Member
Member
Beiträge: 56
Registriert: 27. Mär 2006, 15:53
Kontaktdaten:

Problem beim Installieren mit Yast2

Beitrag von matrix2712 » 27. Mär 2006, 15:58

Hi !!!!
Mein Pc läuft mit Suse10.
Bis jetzt hatte ich nie probleme beim installieren von Updates oder neuen Programmen mit Hilfe von Yast2. Doch seit einen Tag lässt sich kein Paket mehr installieren, ich bekomme folgende Meldung :

ERROR(InstTarget:E_RpmDB_subprocess_failed)
---
error: db4 error(-30978) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from dbenv->close: DB_RUNRECOVERY: Fatal error, run database recovery


Was soll ich tun ???? HILFE...

Werbung:
Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin » 27. Mär 2006, 16:01

In der Konsole als root:

Code: Alles auswählen

rpm --rebuilddb
Danach sollte wieder alles funktionieren.
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"

matrix2712
Member
Member
Beiträge: 56
Registriert: 27. Mär 2006, 15:53
Kontaktdaten:

Beitrag von matrix2712 » 27. Mär 2006, 16:12

wow....
das ist schnell gegangen. Und es funktioniert wieder.
DANKE

und schon die nächste Frage : für was war/ist dieser Befehl gut ? :)

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Re: Problem beim Installieren mit Yast2

Beitrag von Martin Breidenbach » 27. Mär 2006, 16:16

matrix2712 hat geschrieben:run database recovery
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste