ein kleines Problem ...

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
cramer
Newbie
Newbie
Beiträge: 12
Registriert: 22. Dez 2004, 19:56

Beitrag von cramer » 20. Mär 2006, 21:36

Hallo.

Nach einigen missglückten Versuchen und Lösungsvorschlägen ähnlicher Probleme aus anderen Threads treibt mein apt mich noch zum Wahnsinn :evil: .

Ich habe neulich KDE via YAST auf 3.5 geupdatet was auch ohne Probleme ablief.
Jedoch scheints jetzt mein apt nicht mehr zu tun => zumindest glaube ich das es daran liegt.
Das Problem: jedesmal wenn ich apt für ein Update oder eine Installation benutzen möchte kommt folgende Fehlermeldung bei z.B.:

Code: Alles auswählen

#apt upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
You might want to run `apt-get --fix-broken install' to correct these.
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  kdelibs3-doc: Hängt ab von: sgml-skel aber es ist nicht installiert
                PreDepends: /usr/bin/sgml-register-catalog
                PreDepends: /usr/bin/edit-xml-catalog
  kdenetwork3-IRC: Hängt ab von: perl-IO-Socket-SSL aber es ist nicht installiert
  kdeutils3: Hängt ab von: libgmp.so.3
E: Unmet dependencies. Try using --fix-broken.
Nach der Eingabe: kommt folgendes ...

Code: Alles auswählen

# apt-get --fix-broken install
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Korrigiere Abhängigkeiten ... Fertig
Die folgenden zusätzlichen Pakete werden installiert werden:
  gmp kdelibs3 kdelibs3-devel libacl-devel libattr-devel libtiff-devel openssl-devel perl-IO-Socket-SSL perl-Net_SSLeay
  sgml-skel unsermake update-desktop-files
Die folgenden Pakete werden upgegradet werden:
  kdelibs3 kdelibs3-devel
Die folgenden NEUEN Pakete werden installiert werden:
  gmp libacl-devel libattr-devel libtiff-devel openssl-devel perl-IO-Socket-SSL perl-Net_SSLeay sgml-skel unsermake
  update-desktop-files
2 upgraded, 10 newly installed, 0 entfernt und 226 nicht upgegradet.
Muss 0B/21,3MB an Archiven holen.
Nach dem Auspacken werden 15,3MB zusätzlicher Plattenplatz benutzt werden.
Wollen Sie fortsetzen? [J/n] y
Checking GPG signatures...
Unknown signature /var/cache/apt/archives/gmp_4.1.4-99.gbv.1_i586.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#b7afc211)
E: Error(s) while checking package signatures:
0 unsigned package(s)
1 package(s) with unknown signatures
0 package(s) with illegal/corrupted signatures
E: Handler silently failed
das Ding bewegt sich nicht mehr vor und nicht mehr zurück ......
:(
Hat jemand eine Ahnung wie ich apt wieder zum laufen bekomme ???
AMD Athlon(tm) XP 2600+
1024MB DDR3 Infineon
ASUS V99999GT / 6800TG 128MB
ASUS A7N8X Deluxe

Werbung:
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 20. Mär 2006, 21:42

Das ist der key von suser-gbv:

apt install rpmkey-suser-gbv --no-checksig

ausführen.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

cramer
Newbie
Newbie
Beiträge: 12
Registriert: 22. Dez 2004, 19:56

Beitrag von cramer » 20. Mär 2006, 21:45

Schade, wieder das alte Spiel ..... :cry:

Code: Alles auswählen

# apt install rpmkey-suser-gbv --no-checksig
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
You might want to run `apt-get --fix-broken install' to correct these:
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  kdelibs3-doc: Hängt ab von: sgml-skel aber es wird nicht installiert werden
                PreDepends: /usr/bin/sgml-register-catalog
                PreDepends: /usr/bin/edit-xml-catalog
  kdenetwork3-IRC: Hängt ab von: perl-IO-Socket-SSL aber es wird nicht installiert werden
  kdeutils3: Hängt ab von: libgmp.so.3
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).
AMD Athlon(tm) XP 2600+
1024MB DDR3 Infineon
ASUS V99999GT / 6800TG 128MB
ASUS A7N8X Deluxe

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 20. Mär 2006, 21:45

@cramer:

1. Verstoss
an irgendein posting einfach was drangeklatscht ... der Moderator wir es schon richten oder wie ?
lies hier:
Ankündigungen: [Tip] Wie ärgere ich den Moderator ?
http://www.linux-club.de/viewtopic.php?t=56395

2. Verstoss
ich habe bereits mehrfach gesagt, das Threads zu Signatur Problemen in die Tonne gehen

==> dieser Thread zerstört sich in der nächsten halben Stunde :mrgreen:
==> du stehst auf der watchlist :mrgreen:

[EDIT]nach dem cramer sein Vergehen eingesehen hat, Gnade vor Recht![/EDIT]
Zuletzt geändert von oc2pus am 20. Mär 2006, 22:18, insgesamt 1-mal geändert.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

cramer
Newbie
Newbie
Beiträge: 12
Registriert: 22. Dez 2004, 19:56

Beitrag von cramer » 20. Mär 2006, 22:00

:shock: Oh. Da hab ich wohl Grenzen überschritten über die ich mir garnicht bewusst war ......

Dazu fällt mit gerade ein Buch ein was meine Schulkollegin mal gelesen hat:
"Vergeben lernen in zwölf Schritten." :lol:

http://www.amazon.de/exec/obidos/ASIN/3 ... 57-7359764
Amazon.de Redaktion:
Rezensionen

"Kurzbeschreibung
Vergeben bringt Heilung des Menschen
Ein spiritueller und therapeutischer Ratgeber, der Vergebung weniger als moralisches Gebot, sondern als heilende Wirklichkeit näher bringt. Viele Menschen verzweifeln wegen ihrer Unfähigkeit zu vergeben: unfähig, sich selbst zu vergeben, anderen zu vergeben und vor allem sich von Gott vergeben zu lassen. Vergebung wurde und wird oft nur als moralisches Gebot hingestellt. Wenn solch ein Willensakt nicht der Gefühlslage der geschädigten Person entspricht, bleibt ihr Innenleben verletzt und chaotisch. Wer diese Gefühle verdrängt, gelangt nicht zur wahren Vergebung.
In 12 Schritten führt der Autor in die Kunst des Verzeihens ein. Eine wichtige Voraussetzung dafür ist, dass Unrecht als solches erkannt und benannt wird und die geschädigte Person auch ihr Recht wahrnimmt. Erst wenn Menschen so die Verantwortung übernehmen, kann Vergebung als ein Geschenk Gottes geschehen"

tut mir leid ....

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 20. Mär 2006, 22:14

Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
kdelibs3-doc: Hängt ab von: sgml-skel aber es wird nicht installiert werden
PreDepends: /usr/bin/sgml-register-catalog
PreDepends: /usr/bin/edit-xml-catalog
kdenetwork3-IRC: Hängt ab von: perl-IO-Socket-SSL aber es wird nicht installiert werden
kdeutils3: Hängt ab von: libgmp.so.3
lass diese drei Pakete erst mal weg, dann sollte ein teilweises Update gelingen.

dann apt policy kdeutils3, und probiere die jeweilige Version aus,
apt install kdeutils3=<version>
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

cramer
Newbie
Newbie
Beiträge: 12
Registriert: 22. Dez 2004, 19:56

Beitrag von cramer » 20. Mär 2006, 22:16

Dank Dir :)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste