[solved] Updates zu konservativ?

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Jochen-of-Borg
Member
Member
Beiträge: 135
Registriert: 25. Okt 2005, 12:00

[solved] Updates zu konservativ?

Beitrag von Jochen-of-Borg » 10. Mär 2006, 14:27

Hallo!

Wenn ich mit apt ein update mache, bekomme ich zwar massenweise neue Packete, die sich in der 5. Nachkommastelle von der alten Version unterscheiden. Aber ich habe irgendwie das Gefühl, daß ich alle größeren updates manuell machen muß..

Ich hab jetzt mal auf einer frischen Suse 10.0 installation ein "apt-get update && apt-get upgrade" laufen lassen.

Kde ist nach wie vor 3.4.2 statt 3.5.1
nmap ist 3.81, aktuell ist die 4
usw...

Ich meine, ich will ja gar keine beta-Versionen. Aber aktuelle Stable Versionen hätte ich schon ganz gerne automatisch. Bin ich da mit Suse ganz falsch, oder muß ich nur meine apt-configs etwas pimpen?

Gruß.. Jochen
Zuletzt geändert von Jochen-of-Borg am 10. Mär 2006, 15:17, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
mada
Hacker
Hacker
Beiträge: 570
Registriert: 22. Sep 2004, 20:38
Wohnort: Freiburg i.Brsg.
Kontaktdaten:

Beitrag von mada » 10. Mär 2006, 14:29

was APT installiert hängt von Deiner sources.list ab. Wenn keine neues KDE daherkommt, dann liegts dran, dass vermutlich kde-stable und kde nicht dabei sind. Vergleich doch einfach mal Deine Liste mit der von Grothesk...
*Evidently, one is not going to be able to build a castle of blocks unless the blocks are a good deal smaller than the castle - E. Hecht

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Re: Updates zu konservativ?

Beitrag von oc2pus » 10. Mär 2006, 14:29

Jochen-of-Borg hat geschrieben:Ich meine, ich will ja gar keine beta-Versionen. Aber aktuelle Stable Versionen hätte ich schon ganz gerne automatisch. Bin ich da mit Suse ganz falsch, oder muß ich nur meine apt-configs etwas pimpen?
ich würde mit lesen hier im Forum beginnen ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 10. Mär 2006, 14:30

Code: Alles auswählen

apt policy nmap
nmap:
  Installiert: (nichts)
  Kandidat: 4.01-1.guru.suse100
  Versionstabelle:
     4.01-1.guru.suse100 0
        500 ftp://ftp4.gwdg.de SuSE/10.0-i386/suser-guru pkglist
     3.81-9 0
        500 ftp://ftp4.gwdg.de SuSE/10.0-i386/base pkglist
suser-guru anlegen...

Tja, und *eigentlich* is das *fast* alles beta, was da über apt reinkommt.
Nur 'base', 'updates' und 'security' kommt direkt von Suse, der Rest kommt von 'woanders'.
Zuletzt geändert von Grothesk am 10. Mär 2006, 14:33, insgesamt 1-mal geändert.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 10. Mär 2006, 14:31

Naja... was ist stabil.. was ist beta... da sind bei Linux die Grenzen eher fließend :D

KDE läßt sich mit apt auf 3.5.1 updaten. Alles eine Frage der Repositorien. Es kann sein daß da ein wenig Handarbeit erforderlich ist weil sich da ein paar Abhängigkeiten geändert haben aber das geht (ich hab's ja unter SuSE 9.2 und 10.0 damit gemacht).
Zuletzt geändert von Martin Breidenbach am 10. Mär 2006, 15:36, insgesamt 1-mal geändert.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Benutzeravatar
mada
Hacker
Hacker
Beiträge: 570
Registriert: 22. Sep 2004, 20:38
Wohnort: Freiburg i.Brsg.
Kontaktdaten:

Beitrag von mada » 10. Mär 2006, 15:00

Außerdem schadet es vielleicht nicht, statt apt upgrade die erweiterte Version apt dist-upgrade zu verwenden: mit upgrade werden nur vorhandene Pakete erneuert, es werden keine Pakete durch andere ersetzt oder gar deinstalliert, u.U. kann das aber ja sinnvoll sein, gerade bei größeren Versionssprüngen kann ja leicht mal ein bisher gebrauchtes Paket plötzlich deprecated werden.
*Evidently, one is not going to be able to build a castle of blocks unless the blocks are a good deal smaller than the castle - E. Hecht

Jochen-of-Borg
Member
Member
Beiträge: 135
Registriert: 25. Okt 2005, 12:00

Beitrag von Jochen-of-Borg » 10. Mär 2006, 15:16

Ok, ich bin einfach naiver weise davon ausgegangen, daß Suse die standardmäßig mitgelieferten Packete auch standardmäßig updated... :-)

Ich hab meine sources.list jetzt noch etwas erweitert. Sieht jetzt besser aus!
(Bislang hatte ich nur packman zusätzlich drin, um die kastrierten Multimedia-Player von Suse zu umgehen).

Gruß.. Jochen

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 10. Mär 2006, 15:26

Ok, ich bin einfach naiver weise davon ausgegangen, daß Suse die standardmäßig mitgelieferten Packete auch standardmäßig updated...
Hat Suse noch nie getan. Nur Sicherheitsupdates zurückportiert.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

Benutzeravatar
TeXpert
Guru
Guru
Beiträge: 2166
Registriert: 17. Jan 2005, 11:22

Beitrag von TeXpert » 13. Mär 2006, 19:14

Grothesk hat geschrieben:
Ok, ich bin einfach naiver weise davon ausgegangen, daß Suse die standardmäßig mitgelieferten Packete auch standardmäßig updated...
Hat Suse noch nie getan. Nur Sicherheitsupdates zurückportiert.
aus gutem Grund.... neue Versionen haben IDR immer neue Konfig-Optionen, d.h. einmal update und man flucht weil nix mehr geht :( ....

mancheiner will mit einem Rechner auch noch arbeiten ;)

Code: Alles auswählen

# to resolve all your problems, try this:
HOWTO='pack c5,41*2,sqrt 7056,unpack(c,H)-2,oct 115' && perl -le "print $HOWTO"
Ich beantworte keine Supportfragen per PM!

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 2 Gäste