Abhängigkeiten lösen: Was wenn altes Paket neuer ist?

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
newbie
Newbie
Newbie
Beiträge: 17
Registriert: 29. Nov 2003, 13:38
Kontaktdaten:

Abhängigkeiten lösen: Was wenn altes Paket neuer ist?

Beitrag von newbie » 9. Mär 2006, 13:46

Hallo!

ich mache mal meinem nick alle Ehre und stellen eine echte Newbie-Frage:
Ich will kdevelop mit apt installieren.
Leider bekomme ich folgende Fehlermeldung:

Code: Alles auswählen

file /usr/share/man/man1/jackd.1.gz from install of jack-devel-0.98.1-5.1 conflicts with file from package jack-0.99.0-0.oc2pus.1
E: Error while running transaction
E: Handler silently failed
Jetzt steht ja unter http://www.linux-club.de/viewtopic.php?t=16315#95217
das --force mein Problem löst, aber jack-0.99.0-0.oc2pus.1 scheint ja neuer als jack-devel-0.98.1-5.1

Somit die Frage: to --force or not to --force ?
Danke für Ratschläge.

newbie
SuSE 9.2 auf einem PIII 866MHz mit mageren 256MB Speicher

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 10. Mär 2006, 14:39

in diesem Fall liegt es etwas anders:

SuSE hat die man-pages im Paket jack-devel drin, da gehören sie nicht hin (nach meiner Meinung) und deshlab gibt es diesen Konflikt.

Lösung: auch mein jack-devel installieren, oder das jack-devel-0.98 deinstallieren
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

newbie
Newbie
Newbie
Beiträge: 17
Registriert: 29. Nov 2003, 13:38
Kontaktdaten:

Beitrag von newbie » 10. Mär 2006, 14:53

Danke für die Antwort oc2pus!
oc2pus hat geschrieben: Lösung: auch mein jack-devel installieren, oder das jack-devel-0.98 deinstallieren
Leider ist das für mich nicht so einfach, denn wenn ich das jack-devel deinstallieren will, sagt mir synaptic, dass ich auch alle meine MuMedia-Anwendungen los bin (Amarok, mplayer,...).

Kannst du so nett sein und mir das korrekte Vorgehen konkret beschreiben? :oops:

Newbie
SuSE 9.2 auf einem PIII 866MHz mit mageren 256MB Speicher

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 10. Mär 2006, 14:54

ich gehe mal davon aus das du SuSE-9.3 am Rennen hast ?

dann sollte dich apt install jack jack-devel zum Ziel bringen.
Ansonsten bitte die Ausgabe des obigen Befehls hier posten ;)

Und woher beziehst du dieses Paket ?
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

newbie
Newbie
Newbie
Beiträge: 17
Registriert: 29. Nov 2003, 13:38
Kontaktdaten:

Beitrag von newbie » 10. Mär 2006, 15:03

Hilft leider nicht:

Code: Alles auswählen

bruchtal:/etc # apt install jack jack-devel
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
jack ist bereits die neueste Version.
Die folgenden zusätzlichen Pakete werden installiert werden:
  pkgconfig
Die folgenden NEUEN Pakete werden installiert werden:
  jack-devel pkgconfig
0 upgraded, 2 newly installed, 0 entfernt und 2 nicht upgegradet.
Muss 0B/129kB an Archiven holen.
Nach dem Auspacken werden 613kB zusätzlicher Plattenplatz benutzt werden.
Wollen Sie fortsetzen? [J/n] J
Committing changes...
Preparing...                ########################################### [100%]
        file /usr/share/man/man1/jackd.1.gz from install of jack-devel-0.98.1-5.1 conflicts with file from package jack-0.99.0-0.oc2pus.1
E: Error while running transaction
E: Handler silently failed
Hier die policy:

Code: Alles auswählen

bruchtal:/etc # apt policy jack jack-devel
jack:
  Installiert: 0.99.0-0.oc2pus.1
  Kandidat: 0.99.0-0.oc2pus.1
  Versionstabelle:
 *** 0.99.0-0.oc2pus.1 0
        100 RPM Database
     0.98.1-5.1 0
        500 ftp://ftp4.gwdg.de SuSE/9.2-i386/base pkglist
jack-devel:
  Installiert: (nichts)
  Kandidat: 0.98.1-5.1
  Versionstabelle:
     0.98.1-5.1 0
        500 ftp://ftp4.gwdg.de SuSE/9.2-i386/base pkglist
Eigentlich habe ich schon SuSE 9.2
Wie kommst du auf 9.3 ?
Danke für weitere Hilfe... :cry:

Newbie
SuSE 9.2 auf einem PIII 866MHz mit mageren 256MB Speicher

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 10. Mär 2006, 15:10

newbie hat geschrieben:Eigentlich habe ich schon SuSE 9.2
Wie kommst du auf 9.3 ?
weil du nichts gesagt hast und ich geraten habe, das jack-0.99 von mir gab es nur für SuSE-9.3 und SuSE-9.2

Du hast nun ein Problem, jack und jack-devel gibt es nicht mehr in meinem Repository. D.h. wenn du kein jack-devel-0.99 von mir auf Platte stehen hast, bleibt dir der Ausweg, das du jack downgradest auf die 0.98er Version von SuSE mit dem Befehl:

Code: Alles auswählen

apt install jack=0.98.1-5.1[code]

Zweite Lösung: besorge dir von der SuSE-10.0 das jack-0.99-*.src.rpm
und wandele es auf deinem Rechner mit [code]rpmbuild --rebuild jack-0.99-*.src.rpm
um.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste