GNOME update?

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
ThinkMark

GNOME update?

Beitrag von ThinkMark » 12. Feb 2006, 18:16

´n Abend :-)

wie man an meiner Sig erkennen kann, nutze ich Gnome.
Laut Info über Gnome ist es derzeit die 2.12.2
Alle Updates schön per APT dank der sources.list von Grothesk (Danke dafür!) eingespielt, also auch das Gnome Verzeichnis in der Liste mit drin.
Wenn ich apt update und apt upgrade eingebe, bekomme ich nun aktuell folgende Meldung:

linux:/home/marky # apt upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Die folgenden Pakete sind zurückgehalten worden
beagle blam cairo evolution-sharp gecko-sharp gmime gnome-applets
gnome-cups-manager gnome-screensaver gnome-session gnome-themes gnumeric
gsf-sharp inkscape kino powersave rhythmbox totem xine-ui yelp
0 upgraded, 0 newly installed, 0 entfernt und 20 nicht upgegradet.


Ich bin bei solchen Meldungen eher vorsichtig, ... hat jemand eben diese Brücke mal übergangen mit --no-checksig?
Wenn ja, gab es was auffälliges?
Sollte man diese Pakete überhaupt einspielen?

Für den einen oder anderen Tip bin ich dankbar ;-)
Schönen Abend noch

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 12. Feb 2006, 18:19

diese Pakete brauchen weitere Pakete oder ersetzen andere Pakete.

Also apt install <liste-der-zurückgehaltenen-Paketnamen> sollte dir Klarheit bringen ;)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

ThinkMark

Beitrag von ThinkMark » 12. Feb 2006, 18:39

Is schon klar...
aber..
Ich hatte vor kurzem mal genau die gleichen Voraussetzungen wie jetzt...und startete das Update per Synaptic...nahm "INTELLIGENTE AKTUALISIERUNG"...keinen Schimmer, ob das dann den folgenden Fehler auslöste...
Es kamen eine Latte an Paketen rein, wurden installiert.
So weit, so gut...
Beim reboot hatte ich dann das Phänomen, dass beide Panels 3-4 blinkten und dann auf Nimmerwiedersehen verschwanden.
Wieso auch immer...

Deswegen fragte ich, ob sich jemand mal aktuell rangemacht hat und mit welchem Ergebnis. Die blinkenden Panels, die dann verschwanden, halten mich derweil etwas vom Experiment ab :-)
Allerdings möchte ich schon ein "komplettes" System haben, wenn Du verstehst..

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 12. Feb 2006, 18:45

tja, dann installiere diese Pakete doch einfach mal. dann wirst du es wissen ...

du kannst ja dann wieder downgraden wenn etwas nicht funktioniert ;)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

ThinkMark

Beitrag von ThinkMark » 12. Feb 2006, 18:56

über apt mit --no-checksig?

oder über Synaptic mit NORMALE Aktualisierung?

Was empfiehlt denn der Ultimative Guru? :wink:

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 12. Feb 2006, 19:15

marky hat geschrieben:über apt mit --no-checksig?
was willst du mit no-checksig ?

apt installiert diese Pakete nicht bei upgrade, weil es zusätzlicher Pakete bedarf oder andere obsolet werden ...

zum dritten mal jetzt:
apt install <liste-der-zurückgehaltenen-Paketnamen>
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

ThinkMark

Beitrag von ThinkMark » 12. Feb 2006, 19:54

bin grade dabei, das System per apt zu Fuss upzugraden..spiele also jedes Paket per Hand ein...
bekam eben bei Gnome-session folgende Fehlermeldung, die vielleicht für das blinkende und verschwindende Panel veranwortlich sein kann, das mir beim upgrade per Synaptic passierte, weil es vielleicht schlichtweg übergangen wurde

libmicasa.so.1 hat keinen Installationskandidaten
deswegen ist gnome-session fehlerhaft

hast Du eine Idee?

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 12. Feb 2006, 19:57

marky hat geschrieben:bin grade dabei, das System per apt zu Fuss upzugraden..spiele also jedes Paket per Hand ein...
und zum 4. mal
apt install <liste-ALLER-zurückgehaltenen-Paketnamen>

NICHT EINZELN!
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

ThinkMark

Beitrag von ThinkMark » 13. Feb 2006, 08:22

Moin

also...es hat soweit geklappt, allerdings nur, weil ich 2 Pakete später per YAST wieder gelöscht habe.
Cairo oder Gecko...da bin ich mir jetzt nicht sicher, haben zusätzliche Pakete mitgebracht, die dann das blinkende Panel verursacht haben, was dann immer ganz verschwand.
Also im YAST unter GNOME geschaut...die 2 Pakete lokalisiert, gelöscht...Reboot...und siehe da, alles läuft.
Scheint irgendwas schräg zu sein im Gnome Repo könnte man meinen.

Inwieweit ist das eigentlich die aktuelle Quelle?
Meines Wissens nach gibts ja schon neuere Pakete als die 2.12.2

Auf jeden Fall DANKE für die Geduld :-)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast