unmet dependencies Problem

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Testing
Newbie
Newbie
Beiträge: 2
Registriert: 10. Feb 2006, 23:00

unmet dependencies Problem

Beitrag von Testing » 11. Feb 2006, 12:05

Hallo zusammen!

Wollte heute mein frisch installierter Linux WebServer mit Plesk updaten. So, nun bekam ich dieses Problem wenn ich versucht hatte upzudaten:

root:/ # apt-get --fix-broken install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
mod_php4-apache2: Obsoletes: apache2-mod_php4 but 4.3.10-14.1.swsoft is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies


Wie kann man das Problem lösen? Will Plesk und PHP beibehalten.

thx

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 11. Feb 2006, 12:09

mod_php4-apache2: Obsoletes: apache2-mod_php4 but 4.3.10-14.1.swsoft is installed
na dann entscheide dich mal für eines der beiden :)
mod_php4-apache2 MACHT apache2-mod_php4 ÜBERFLÜSSIG ...
und solange du diese Leiche im Keller hast, wird apt NICHTS tun...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Testing
Newbie
Newbie
Beiträge: 2
Registriert: 10. Feb 2006, 23:00

Beitrag von Testing » 11. Feb 2006, 13:11

vielen dank für die schnelle antwort!

welches von dennen benutzt denn Plesk und kann man bedekjenlos löschen ohne dass Plesk kaputt geht?

thx

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 11. Feb 2006, 13:17

da du weder deine SuSE-Version (nutzt du überhaupt SuSE?), noch sonstige brauchbaren Infos lieferst, kann ich dir das nicht sagen.

probiere

Code: Alles auswählen

apt install mod_php4-apache2 apache2-mod_php4-
d.h. das apache2-mod_php4 deinstallieren (deswegen das "-" am Ende)

ansonsten poste die Ausgabe von apt install plesk (oder wie immer das heisst)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast