Offensichtlich falsche Abhängigkeiten - wie unterdrücken

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
coogor
Hacker
Hacker
Beiträge: 639
Registriert: 21. Dez 2005, 12:10
Wohnort: Düsseldorf

Offensichtlich falsche Abhängigkeiten - wie unterdrücken

Beitrag von coogor » 6. Feb 2006, 20:08

Moin,

ich hab von Hand das Paket freemind installiert. Es möchte ein Java >= 1.4 haben, und installiert ist java-1_5_0-sun-1.5.0_06-1.1

Ein apt upgrade liefert die Fehlermeldung:
freemind: Hängt ab von: java_runtime (>= 1.4) aber es ist nicht installierbar

Offensichtlich wird das 1.5.0 nicht erkannt. Nun möchte ich kein 1.4 zusätzlich installieren. Wie kann ich diese Abhängigkeit auf 'ignore' setzen?

Danke
Ax

Werbung:
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 6. Feb 2006, 20:20

Was liefert 'apt policy java-1_5_0-sun'?

Und welche Distri hast du? Wie sieht die sources.list aus?
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

coogor
Hacker
Hacker
Beiträge: 639
Registriert: 21. Dez 2005, 12:10
Wohnort: Düsseldorf

Beitrag von coogor » 7. Feb 2006, 14:51

axel@tp-a30:~> apt policy java-1_5_0-sun
java-1_5_0-sun:
Installiert: 1.5.0_06-1.1
Kandidat: 1.5.0_06-1.1
Versionstabelle:
*** 1.5.0_06-1.1 0
500 ftp://ftp4.gwdg.de SuSE/10.0-i386/update pkglist
500 ftp://ftp4.gwdg.de SuSE/10.0-i386/security pkglist
100 RPM Database

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Re: Offensichtlich falsche Abhängigkeiten - wie unterdrücken

Beitrag von oc2pus » 7. Feb 2006, 15:04

coogor hat geschrieben:Ein apt upgrade liefert die Fehlermeldung:
freemind: Hängt ab von: java_runtime (>= 1.4) aber es ist nicht installierbar
du brauchst dazu ein virtuelles RPM welches das Paket java_runtime "provided".
eMail an packager von freemind, er hat eine falsche Dependencie in seinem Paket.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

coogor
Hacker
Hacker
Beiträge: 639
Registriert: 21. Dez 2005, 12:10
Wohnort: Düsseldorf

Beitrag von coogor » 8. Feb 2006, 13:20

Das hst sich insofern erledigt als es inzwischen eine neue Version (0.8) gibt, und das Problem nur bei der 0.7.1 auftauchte.
Aber wie geht man generell damit um (virtuelles RPM?)??

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 8. Feb 2006, 13:31

Mittlerweile ist gut...
0.8 gibt es seit September letzten Jahres...
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 2 Gäste