TOLL: ACPI bei Thinkpad R40e nach Update SuSE 9.3 -> 10.0

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
BrotBraeuner
Member
Member
Beiträge: 87
Registriert: 17. Aug 2004, 10:51
Wohnort: Sonthofen

TOLL: ACPI bei Thinkpad R40e nach Update SuSE 9.3 -> 10.0

Beitrag von BrotBraeuner » 4. Feb 2006, 19:14

Ich habe keine Ahnung wie das funktioniert oder ob diese Information irgendwer braucht.
Auch habe ich das erst einmal gemacht und nicht wieder reproduziert.

Also: Ich habe da ein Thinkpad R40e.
Dieses hat wie viele Notebooks dieses ACPI-Problem, was es nötig macht, dass man ACPI bei einer Neuinstallation grundsätzlich deaktivieren sollte.
Doch das hat ein paar lediglich unangenehme nebenwirkungen:
Der Computer verhält sich wie ein AT-Rechner und kann sich nicht mehr selber ausschalten, die Batterieanzeige funktioniert nicht und noch ein paar andere Dinge wie die Prozessorsteuerung usw.

Das eigentliche Problem lag bei SuSE 9.3 beim Powersave-Dämon, den man nach der Installation über den Runlevel-Editor deaktivieren sollte.
Dann kann man über den Editor der Sysconfig Dateien die einstellungen für den ACPI-Dämon auf Battery und AC beschränken. Wenn man nun mit ACPI hochfährt und sich anmeldet, dann kommt zwar die Fehlermeldung, dass der Powersave-Dämon nicht läuft. Aber wenigstens funktioniert die Batterieanzeige (nach vollständigem Online-Update) und der Computer kann sich selber ausschalten, wenn man ihn herunterfährt.

Das Problem bei SuSE 10.0 war, dass sich diese Optionen nicht mehr nutzen liessen, und der Computer nun eigentlich am ACPI-Dämon scheiterte und nicht wie zuvor am Powersave-Dämon.
Eine (einfache) Lösung fand ich bis heute nicht.
Das Üble war dazu auch noch, dass der Computer sofort einfror, wenn man das Netzteil im laufenden betrieb einsteckte oder abzog.
ALSO: RUNTER MIT 10.0 UND ZURÜCK ZU 9.3!!!

Aus irgendeinem mir nicht mehr nachvollziehbaren Grund habe ich also nicht nur 9.3 neu installiert und wie oben beschrieben einfach laufen lassen, sondern danach gleich upgedatet auf 10.0.

Jetzt haltet euch fest: ALLES FUNKTIONIERT!!!

ECHT! EHRLICH! Der ACPI- und der Powersave-Dämon läuft. Der Computer kann sich selber Ausschalten, die Prozessorgeschwindigkeit wird geregelt, die Batterieanzeige funktioniert es geht einfach alles.

Vielleicht kann irgendjemand mit dieser Info was anfangen oder mir den Gefallen tun, und diese Erfahrung bestätigen. Denn das Laptop gehört eigentlich meiner Frau und die ist jetzt so glücklich, dass das funktioniert, dass sie mich keine weiteren Tests mehr machen lässt. ;-)
Die einen haben Spaß an ihrem Computer, die anderen haben Windows.

Werbung:
HyperSonic
Newbie
Newbie
Beiträge: 3
Registriert: 4. Apr 2005, 02:07

Beitrag von HyperSonic » 12. Apr 2006, 17:15

Hallo,

habe exakt das selbe problem mit meinem IBM ThinkPad r40e mit bios version 1.38 (aktuelle).

Habe SUSE 10 mit der option "acpi=off" installiert.
hat dann auch geklappt aber habe die selben probleme mit dem acpi und dem umschalten zwischen akkubetrieb und strom da friert alles ein...

sogar wenn ich amarok einschalte und mit den hardware tasten lauter und leiser mache friert es auch ein... das system ist mega unstabil.

hatte vorher suse 9.3 wo acpi auch nicht lief aber dafür ist das system nie eingefrohren!

könntest du mir bitte sagen wie du genau alles hinbekommen hast Schritt für Schritt.

Hast du suse 9.3 neu aufgespielt mit "Installation ohne ACPI"
und danach sofort auf suse 10 geupdatet?
wie hast du das gemacht ohne suse 9.3 gar nicht zu starten sondern sofort upzudaten?

Danke im vorraus

HyperSonic

BrotBraeuner
Member
Member
Beiträge: 87
Registriert: 17. Aug 2004, 10:51
Wohnort: Sonthofen

Beitrag von BrotBraeuner » 14. Apr 2006, 14:59

Gut, ich versuche dir mal genauer zu beschreiben, wie das ging:

Als erstes SuSE 9.3 wie gewöhnlich installieren einschließlich acpi (also acpi=on oder einfach die Standardinstallation.)
Wenn er dann fertig ist, die Dateien auf die Festplatte zu schaufeln, und er das erste mal einen Neustart machen willst, dann gibt du im Bootloader die Option acpi=off an, da er sonst überhaupt nicht startet bzw. bei dem Punkt acpi zusammenbricht und nichts mehr macht.

Wenn du den Rechner dann fertig konfiguriert hast und auf die Benutzeroberfläche kommst, dann gehst du in den Yast und wählst dort bei System den Editor für Sysconfig Dateien.

In der Struktur Links wählst du nun die Punkte /System/Powermanagment/Powersave/General/ACPI_MODULES
und /System/Powermanagment/Powersave/General/ACPI_MODULES_NOT_TO_UNLOAD

hier nimmst du alle Eintragungen heraus bis auf AC und BATTERY
Wenn du das gemacht hast, kannst du zum ersten mal deinen Rechner mit acpi starten. Das Symbol rechts unten im Systemtray passt sich dann auch je nachdem wo der Strom herkommt auf Netzversorgung oder Batterie an.
(Kann sein, dass du erst noch deinen Kernel Updaten musst.

Wenn du nun SuSE 10.0 willst, wählst du im Yast unter Software das Update an und führst es ganz normal aus.

Ich hoffe, dass das bei dir funktioniert, da ich wie du siehst noch keinen bestätigten Fall für diese Vorgehensweise habe.
Die einen haben Spaß an ihrem Computer, die anderen haben Windows.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste