Graphire3 wechselt Einstellungen (Suse10.0, KDE)

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
askir
Newbie
Newbie
Beiträge: 7
Registriert: 12. Jan 2006, 14:08

Graphire3 wechselt Einstellungen (Suse10.0, KDE)

Beitrag von askir » 20. Jan 2006, 14:27

bin mir nciht ganz sicher, ob hier richtig bin (im Notfall verschieben, bitte?!), aber ich hab ein Problem mit meinem Tablet Graphire4 von Wacom unter Suse10 KDE:

Da nur Graphire3-Treiber mitgeliefert werden hab ich diese ausgewählt und das Tablet läuft auch mit diesen .. Stift / Maus werden optimal erkannt. Auch die Einstellungen, ob man die Maus absolut oder relativ zu der Tabletfläche haben will funzt ... zumindest gleich nach dem Start. Hab alle Werte auf absolut gestellt wie gewünscht (sowohl beim Tablet allgemein, als auch beim Stift und Radierer)! Nach einiger Zeit geht diese Einstellung allerdings einfach so verloren ... Der Stift ist ab dann relativ (ohne das sich die Einstellung im Menü verändert hat!). Wie geht das denn??

Würde mich freuen, wenn mir jemand helfen könnte? DANKE

Werbung:
Benutzeravatar
askir
Newbie
Newbie
Beiträge: 7
Registriert: 12. Jan 2006, 14:08

Beitrag von askir » 20. Jan 2006, 18:48

... Entschuldigung. Hab mich geirrt. Es ist ein Wacom Graphire3 Tablet, was das ganze noch komischer macht, weil es ja eigentlich die richtigen Treiber sein sollten!

Benutzeravatar
Neotron
Hacker
Hacker
Beiträge: 254
Registriert: 30. Jan 2005, 18:51
Wohnort: Aichach
Kontaktdaten:

Beitrag von Neotron » 20. Jan 2006, 22:58

Hallo,

also ich hab auch das Graphire3 und bei mir geht's einwandfrei.
Hab es so eingerichtet:

Die Datei runterladen: http://prdownloads.sourceforge.net/linu ... .2.tar.bz2
und entpacken.

Danach rein ins Verzeichnis und folgendes ausführen:

Code: Alles auswählen

./configure --enable-wacom --enable-hid
make 
su
make install
Nun noch die "alten" Kernelmodule rausschmeißen und die neuen rein:

Code: Alles auswählen

rmmod wacom
modprobe wacom
Danach noch /etc/X11/xorg.conf tunen:

Section "ServerLayout" ergänzen mit

Code: Alles auswählen

    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
Folgende Zeilen noch einfügen:

Code: Alles auswählen

Section "InputDevice"
    Driver         "wacom"
    Identifier     "stylus"
    Option         "Device" "/dev/input/event3"
    Option         "Type" "stylus"
    Option         "USB" "on"
EndSection

Section "InputDevice"
    Driver         "wacom"
    Identifier     "eraser"
    Option         "Device" "/dev/input/event3"
    Option         "Type" "eraser"
    Option         "USB" "on"
EndSection

Section "InputDevice"
    Driver         "wacom"
    Identifier     "cursor"
    Option         "Device" "/dev/input/event3"
    Option         "Type" "cursor"
    Option         "USB" "on"
EndSection
Danach den X-Server neu starten und sollte funktionieren.
Gruß
Neotron

Benutzeravatar
askir
Newbie
Newbie
Beiträge: 7
Registriert: 12. Jan 2006, 14:08

Beitrag von askir » 21. Jan 2006, 11:11

he vielen Dank für die ausführliche Antwort! Ich werde es testen!

Benutzeravatar
askir
Newbie
Newbie
Beiträge: 7
Registriert: 12. Jan 2006, 14:08

Beitrag von askir » 21. Jan 2006, 15:47

.. funktioniert einwandfrei! Problem gelöst .. VIELEN DANK!

Benutzeravatar
Neotron
Hacker
Hacker
Beiträge: 254
Registriert: 30. Jan 2005, 18:51
Wohnort: Aichach
Kontaktdaten:

Beitrag von Neotron » 21. Jan 2006, 15:55

Keine Ursache.
Seit der neuen Version von linux-wacom macht's richtig Spaß mit dem Ding zu arbeiten.
Gruß
Neotron

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste