[gelöst] Abhängigkeiten lösen

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

moviemark
Member
Member
Beiträge: 161
Registriert: 16. Jul 2005, 01:16

[gelöst] Abhängigkeiten lösen

Beitrag von moviemark » 14. Jan 2006, 01:45

Hallo,

mal wieder ein Problem bei apt-upgrade. Kann mir jemand helfen folgendes zu lösen

Mark:/home/mark # apt-get upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
You might want to run `apt-get --fix-broken install' to correct these.
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
MPlayer: Hängt ab von: libdirectfb-0.9.so.22()(64bit) aber es ist nicht installierbar
Video-DVDRip: Hängt ab von: rar (>= 2.7.1) aber es ist nicht installierbar
Hängt ab von: perl-libintl-perl (>= 1.10) aber es ist nicht installierbar
transcode: Hängt ab von: liblzo.so.1()(64bit)
E: Unmet dependencies. Try using --fix-broken.

Wenn ich --fix-broken anwende werden Mplayer, transcode und Video-DVDRip gelöscht, dass wars nicht was ich erreichen wollte.

Wenn ich versuche rar einzeln zu installieren erhalte ich folgendes:

Mark:/home/mark # apt-get install rar
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Package rar has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and
never uploaded, has been obsoleted or is not available with the contents
of sources.list
E: Paket rar hat keinen Installationskanditaten
Zuletzt geändert von moviemark am 14. Jan 2006, 15:38, insgesamt 3-mal geändert.

Werbung:
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 14. Jan 2006, 03:07

Wie sieht deine sources.list aus?
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

moviemark
Member
Member
Beiträge: 161
Registriert: 16. Jul 2005, 01:16

Beitrag von moviemark » 14. Jan 2006, 11:38

rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-x86_64 base gnome kde misc mozilla packman rpmkeys samba3 security suse-people suse-projects suser-jmorris suser-rbos suser-scorot update xorg

mhzsüchtig

Beitrag von mhzsüchtig » 14. Jan 2006, 11:45

und du hast auch ein 64 bit rechner?

moviemark
Member
Member
Beiträge: 161
Registriert: 16. Jul 2005, 01:16

Beitrag von moviemark » 14. Jan 2006, 11:58

jo und auch 9.2

mhzsüchtig

Beitrag von mhzsüchtig » 14. Jan 2006, 12:02

apt-get update und apt upgrade schon mal ausgeführt?

ich meine direkt nach der instalation?
sonst funzt apt?

moviemark
Member
Member
Beiträge: 161
Registriert: 16. Jul 2005, 01:16

Beitrag von moviemark » 14. Jan 2006, 12:05

apt funzt wunderbar und auch update und upgrade und auch die datenbank geleert und neu eingelesen. alles brachte bislang keine lösung.

mhzsüchtig

Beitrag von mhzsüchtig » 14. Jan 2006, 12:08

Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
MPlayer: Hängt ab von: libdirectfb-0.9.so.22()(64bit) aber es ist nicht installierbar
Video-DVDRip: Hängt ab von: rar (>= 2.7.1) aber es ist nicht installierbar
Hängt ab von: perl-libintl-perl (>= 1.10) aber es ist nicht installierbar
dies macht mich stutzig da er meint das die pakete nicht instalierbar sind. also sind die wohl da aber er kann die nicht instalieren

poste mal die gesamte sources.list und nicht nur den auschnitt

moviemark
Member
Member
Beiträge: 161
Registriert: 16. Jul 2005, 01:16

Beitrag von moviemark » 14. Jan 2006, 12:12

das ist die gesamte sourcelist

mhzsüchtig

Beitrag von mhzsüchtig » 14. Jan 2006, 12:13

moviemark hat geschrieben:rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-x86_64 base gnome kde misc mozilla packman rpmkeys samba3 security suse-people suse-projects suser-jmorris suser-rbos suser-scorot update xorg
das kann doch nicht alles sein? habe zwar kein 64 bit aber die listen sehen doch normalerweise anders aus.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 14. Jan 2006, 12:20

mhzsüchtig hat geschrieben:
moviemark hat geschrieben:rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-x86_64 base gnome kde misc mozilla packman rpmkeys samba3 security suse-people suse-projects suser-jmorris suser-rbos suser-scorot update xorg
das kann doch nicht alles sein? habe zwar kein 64 bit aber die listen sehen doch normalerweise anders aus.
doch das ist schon korrekt so ;)

man muss nicht pro Reposirory eine eigene Zeile haben!
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

moviemark
Member
Member
Beiträge: 161
Registriert: 16. Jul 2005, 01:16

Beitrag von moviemark » 14. Jan 2006, 12:20

es gibt bei gwdg.de natürlich noch mehr aber die anderen hab ich nicht für sinnvoll erachtet bzw es gab bei apt mit zb den prpm oder drpm packeten probleme.

mhzsüchtig

Beitrag von mhzsüchtig » 14. Jan 2006, 12:22

na schön zu wissen :wink: obwohl ich kein 64 bit hab.

aber wo liegt sein problem? oder die lösung? ich steig da nicht durch.
apt meint er KANN es nicht instalieren also sind die pakete wohl da aber aus irgend einen grund geht es nicht(oder würden die pakete weitere abhängigkeiten auslösen?)

P.S: @oc2pus: endlich bist du da. glaub du kannst ihm am bessten helfen :wink:

moviemark
Member
Member
Beiträge: 161
Registriert: 16. Jul 2005, 01:16

Beitrag von moviemark » 14. Jan 2006, 12:26

ich hab das durchsteigen da schon länger aufgegeben, auch der versuch mit --force hat die gleiche meldung gebracht. hab auch schon versucht direkt mit yast die gewünschten pakete direkt per download zu installieren, auch nix. irgendwas scheint bei mir im system zu fehlen ud ist scheif gewickelt.

hilfe!!!

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 14. Jan 2006, 12:35

prüfe mal mit apt policy MPlayer Video-DVDRip .. welche Versionen dein apt überhaupt sieht.

dann installiere mal eine andere Version mit apt install <paket>=<version>
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

moviemark
Member
Member
Beiträge: 161
Registriert: 16. Jul 2005, 01:16

Beitrag von moviemark » 14. Jan 2006, 12:37

Mark:/home/mark # apt policy MPlayer Video-DVDRip transcode
MPlayer:
Installiert: 1.0pre7-pm.3
Kandidat: 1.0pre7-pm.3
Versionstabelle:
*** 1.0pre7-pm.3 0
100 RPM Database
1.0pre7-pm.2 0
500 ftp://ftp4.gwdg.de SuSE/9.2-x86_64/packman pkglist
1.0pre5-2 0
500 ftp://ftp4.gwdg.de SuSE/9.2-x86_64/suser-jmorris pkglist
Video-DVDRip:
Installiert: 0.52.6-0.pm.2
Kandidat: 0.52.6-0.pm.2
Versionstabelle:
*** 0.52.6-0.pm.2 0
500 ftp://ftp4.gwdg.de SuSE/9.2-x86_64/packman pkglist
100 RPM Database
transcode:
Installiert: 0.6.14-0.pm.2
Kandidat: 0.6.14-0.pm.2
Versionstabelle:
*** 0.6.14-0.pm.2 0
500 ftp://ftp4.gwdg.de SuSE/9.2-x86_64/packman pkglist
100 RPM Database
0.6.14-0 0
500 ftp://ftp4.gwdg.de SuSE/9.2-x86_64/suser-jmorris pkglist

moviemark
Member
Member
Beiträge: 161
Registriert: 16. Jul 2005, 01:16

Beitrag von moviemark » 14. Jan 2006, 12:39

Mark:/home/mark # apt install transcode=0.6.14-0
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Einige Pakete konnten nicht installiert werden. Dies könnte bedeuten,
dass Sie eine unmögliche Situation angefordert haben oder, falls Sie die
instabile Distribution verwenden, dass einige benötigte Pakete noch nicht
erzeugt oder aus 'Incoming' verschoben worden sind.

Da Sie nur eine einzelne Operation angefordert haben, ist es extrem
wahrscheinlich, dass das Paket schlichtweg nicht installierbar ist und
ein Bugreport über dieses Paket eingereicht werden sollte.
Die folgende Information könnte helfen die Sitation zu beheben:

Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
transcode: Hängt ab von: liblzo.so.1()(64bit)
E: Fehlerhafte Pakete

Mark:/home/mark # apt install MPlayer=1.0pre5-2
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Einige Pakete konnten nicht installiert werden. Dies könnte bedeuten,
dass Sie eine unmögliche Situation angefordert haben oder, falls Sie die
instabile Distribution verwenden, dass einige benötigte Pakete noch nicht
erzeugt oder aus 'Incoming' verschoben worden sind.

Da Sie nur eine einzelne Operation angefordert haben, ist es extrem
wahrscheinlich, dass das Paket schlichtweg nicht installierbar ist und
ein Bugreport über dieses Paket eingereicht werden sollte.
Die folgende Information könnte helfen die Sitation zu beheben:

Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
MPlayer: Hängt ab von: liblzo.so.1()(64bit)
E: Fehlerhafte Pakete

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 14. Jan 2006, 12:57

liblzo.so.1()(64bit)
checke dieses Paket mal, das scheint der Übeltäter zu sein. Evtl brauchst du da eine bestimme Version ...

apt policy lzo
apt install lzo=<...>
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

moviemark
Member
Member
Beiträge: 161
Registriert: 16. Jul 2005, 01:16

Beitrag von moviemark » 14. Jan 2006, 12:57

juh juh, gelöst,

hab mal google angeschmissen und nach liblzo.so.1()(64bit) gesucht.

heraus kam ein rpm "lzo", runtergeladen und mit yast installiert. nu läuft alles.

Danke allen für die hilfe, manchmal ist gilt dann doch wieder selbst ist der mann. bis zum nächsten mal

moviemark
Member
Member
Beiträge: 161
Registriert: 16. Jul 2005, 01:16

Beitrag von moviemark » 14. Jan 2006, 13:03

mußte jetzt aber feststellen, daß beim apt upgrade dann lzo zurückgahlten wurde, ein versuch zur gesonderten installation brachte dann daß ergebnis, daß apt mplayer, video-dvdrip und transcode löschen wollte, hab davon dann doch die finger gelassen.

nur merkwürdig, was meint ihr? so lassen oder doch noch ne lösung parat?

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste