Probleme bei install von ffmpeg

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
michael_33
Member
Member
Beiträge: 70
Registriert: 20. Jul 2004, 09:58

Probleme bei install von ffmpeg

Beitrag von michael_33 » 28. Dez 2005, 16:08

Hallo,

ich will mich mal wieder in Videobearbeitung stürzen, aber irgendwie werde ich hier behindert... :)

Code: Alles auswählen

thor:~ # apt install ffmpeg
Lese Paketlisten... Fertig
Erzeuge AbhÀngigkeitsbaum... Fertig
Einige Pakete konnten nicht installiert werden. Dies könnte bedeuten,
dass Sie eine unmögliche Situation angefordert haben oder, falls Sie die
instabile Distribution verwenden, dass einige benötigte Pakete noch nicht
erzeugt oder aus 'Incoming' verschoben worden sind.

Da Sie nur eine einzelne Operation angefordert haben, ist es extrem
wahrscheinlich, dass das Paket schlichtweg nicht installierbar ist und
ein Bugreport ÃŒber dieses Paket eingereicht werden sollte.
Die folgende Information könnte helfen die Sitation zu beheben:

Die folgenden Pakete besitzen unerfÌlte AbhÀngigkeiten:
  ffmpeg: HÀngt ab von: faac aber es ist nicht installierbar
          HÀngt ab von: libfaac.so.0 aber es ist nicht installierbar
E: Fehlerhafte Pakete
thor:~ # apt install faac
Lese Paketlisten... Fertig
Erzeuge AbhÀngigkeitsbaum... Fertig
Package faac has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and
never uploaded, has been obsoleted or is not available with the contents
of sources.list
E: Paket faac hat keinen Installationskanditaten
So wie es aussieht gibt es kein faac mehr!? Was nun? Den Maintainer anschreiben?
.| 2.6.15-gentoo-r1 | .. fluxbox 0.9.14 ..|.
.| AMD Athlon(tm) XP 2400+ | GSA-4040B | Elitegroup K7S5A | Matrox Millennium G400 |.

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 28. Dez 2005, 16:11

prüfe mal mit apt policy ffmpeg, welche Versionen es gibt und probiere eine andere Version aus.

Ansonsten, den maintainer anschreiben.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

taki
Advanced Hacker
Advanced Hacker
Beiträge: 974
Registriert: 30. Apr 2004, 17:40
Wohnort: Berlin
Kontaktdaten:

Beitrag von taki » 28. Dez 2005, 16:16

Wenn mich nicht alles täuscht, ist die libfaac bei SUSE schon auf der DVD dabei (oder ggf. im base-Repository, falls Du eine SUSE aus dem Netz zu laufen hast).

Ein Tipp: Man kann apt-get mit einem Parameter eine alternative sources.list angeben. Ich habe mir eine zweite sources.list erstellt, in der ich weitere Repositories eingetragen habe, u.a. auch base (/etc/apt/sources.listall). Beachte: Diese Liste muss im gleichen Pfad stehen wie die Standard-Liste (/etc/apt).

Wenn ich ein Paket haben möchte, welches nur in einem Repository steht, das ich nicht in den automatischen Upgrade einbinden will, verwende ich die alternative Liste.

Code: Alles auswählen

apt-get --source source.listall update
apt-cache --source source.listall search irgendwas
apt-get --source source.listall install irgendwas
SuSE 12.3 kernel 3.7.10-1.16-desktop, K Desktop Environment Version 4.10.5 r1 - Medion Titanium Aldi v. 03/2009

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 28. Dez 2005, 16:47

faac bzw. libfaac.so.0 gibt es bei PackMan.

taki
Advanced Hacker
Advanced Hacker
Beiträge: 974
Registriert: 30. Apr 2004, 17:40
Wohnort: Berlin
Kontaktdaten:

Beitrag von taki » 28. Dez 2005, 16:52

Möglicherweise wurde faac nach dem letzten apt-get update und vor dem install-Versuch auf dem Server aktualisiert. Dann musst Du erneut die Listen einlesen (apt-get update). Um nicht alle Pakete, sondern nur die neueren neu übers Netz zu ziehen verwende die Option --fix-missing. Wenn meine Vermutung stimmt, solltest Du so zum Ziel kommen:

Code: Alles auswählen

apt-get update && apt-get --fix-missing install ffmpeg
SuSE 12.3 kernel 3.7.10-1.16-desktop, K Desktop Environment Version 4.10.5 r1 - Medion Titanium Aldi v. 03/2009

Benutzeravatar
michael_33
Member
Member
Beiträge: 70
Registriert: 20. Jul 2004, 09:58

Beitrag von michael_33 » 28. Dez 2005, 17:22

Hi,

fangen wir mal an:

Code: Alles auswählen

thor:~ # apt policy ffmpeg
ffmpeg:
  Installiert: (nichts)
  Kandidat: 0.4.9_0.0_20050613-1.guru.suse93
  Versionstabelle: 
     0.4.9_0.0_20050613-1.guru.suse93 0
        500 ftp://ftp.gwdg.de SuSE/9.3-i386/suser-guru pkglist
     0.4.9-4.pm.cvs20051016 0
        500 ftp://ftp.gwdg.de SuSE/9.3-i386/packman pkglist
Hmm, wenn ich jetzt per synaptic die Version von packman erzwinge, dann will er faad2 und xvid aktualisieren, kann er ja, hab nix dagegen, aber:

Code: Alles auswählen

E: Unable to correct problems, you have held broken packages.
E: Das Download-Verzeichnis konnte nicht gesperrt werden
und er bricht ab.....

@traffic, wenn das so einfach wäre! Ich hab packman mit drin und nix iss....
.| 2.6.15-gentoo-r1 | .. fluxbox 0.9.14 ..|.
.| AMD Athlon(tm) XP 2400+ | GSA-4040B | Elitegroup K7S5A | Matrox Millennium G400 |.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 28. Dez 2005, 17:37

und was steht vor den "E:...." Meldungen ?

evtl nutzt es mal den suser-guru temporär ganz zu deaktivieren. Und dann das gewünschte update fahren?
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
michael_33
Member
Member
Beiträge: 70
Registriert: 20. Jul 2004, 09:58

Beitrag von michael_33 » 28. Dez 2005, 18:20

oc2pus hat geschrieben: evtl nutzt es mal den suser-guru temporär ganz zu deaktivieren. Und dann das gewünschte update fahren?
Das sieht dann so aus:

Code: Alles auswählen

thor:~ # apt install ffmpeg
Lese Paketlisten... Fertig
Erzeuge AbhÀngigkeitsbaum... Fertig
Einige Pakete konnten nicht installiert werden. Dies könnte bedeuten,
dass Sie eine unmögliche Situation angefordert haben oder, falls Sie die
instabile Distribution verwenden, dass einige benötigte Pakete noch nicht
erzeugt oder aus 'Incoming' verschoben worden sind.

Da Sie nur eine einzelne Operation angefordert haben, ist es extrem
wahrscheinlich, dass das Paket schlichtweg nicht installierbar ist und
ein Bugreport ÃŒber dieses Paket eingereicht werden sollte.
Die folgende Information könnte helfen die Sitation zu beheben:

Die folgenden Pakete besitzen unerfÌlte AbhÀngigkeiten:
  ffmpeg: HÀngt ab von: libffmpeg0 (= 0.4.9-4.pm.cvs20051016) aber 0.4.9-3.pm.pre1 wird installiert werden
          HÀngt ab von: faac aber es ist nicht installierbar
          HÀngt ab von: libavutil.so
          HÀngt ab von: libfaac.so.0 aber es ist nicht installierbar
E: Fehlerhafte Pakete
packman anschreiben?
.| 2.6.15-gentoo-r1 | .. fluxbox 0.9.14 ..|.
.| AMD Athlon(tm) XP 2400+ | GSA-4040B | Elitegroup K7S5A | Matrox Millennium G400 |.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast