rpms: "Folgende Pakete wurden auf dem Medium nicht gefu

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Gesperrt
suleiman78
Newbie
Newbie
Beiträge: 6
Registriert: 27. Dez 2005, 18:50

rpms: "Folgende Pakete wurden auf dem Medium nicht gefu

Beitrag von suleiman78 » 27. Dez 2005, 19:01

Hallo,

ich habe gerade angefangen mich mit Linux zu beschäftigen, komme aber nicht mehr weiter weil ich keine neuen Programme installieren kann (nur über 'make install' funzts).
Wenn ich ein rpm habe (wie z.B. jetzt gerade "acroread-7.0.1-4.nosrc.rpm") und anklicke bekomme ich ein Fenster mit einem Button "Install Package with yast" und einem Button "Use Directory as Source with yast". Ich klicke also auf ersteren, dadurch startet yast und es gibt mir "Paketinformationen werden eingelesen" und dann ein "Folgende Pakete wurden auf dem Medium nicht gefunden: acroread". Diese Meldung bekomme ich auch bei anderen rpms.
Habs auch schon mit rpm -ivh <datei> probiert, das gibt dann allerdings überhaupt keine Meldungen aus. Ist das Programm jetzt installiert worden oder nicht? Falls ja, wohin (suche nach acroread ergibt kein Ergebnis)?
Wie gesagt, 'make install' (mit dem Quellcode) funktioniert, ich will aber endlich auch rpms ganz einfach installieren können.
Ich hoffe mir kann jemand helfen, vielen Dank schonmal.

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 27. Dez 2005, 19:07

acroread-7.0.1-4.nosrc.rpm
Pakete die mit nosrc.rpm enden, sind keine installierbaren Pakete. Das sind nur die Baupläne um ein RPM zu erstellen. Die Source, in diesem Fall das acroread*.* musst du dir selber von der Homepage herunterladen.

du solltest nach i586 oder i686.rpm Ausschau halten und diese mit rpm -Uhv oder rpm -i installieren.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

suleiman78
Newbie
Newbie
Beiträge: 6
Registriert: 27. Dez 2005, 18:50

Beitrag von suleiman78 » 27. Dez 2005, 19:10

Habe gerade eine nicht 'nosrc'.rpm ausprobiert und die funktioniert. Liegt also wirklich daran. Gilt scheinbar auch für sowas wie "flash-player-7.0.25.0-4.src.rpm".
Vielen Dank.

flatron
Member
Member
Beiträge: 114
Registriert: 26. Dez 2005, 16:43

Re: rpms: "Folgende Pakete wurden auf dem Medium nicht

Beitrag von flatron » 27. Dez 2005, 20:30

suleimann wie meinst du dass mit make install installiert er dann alles was du willst mit make install musst du nur den befehl make install geben oder was is los mit dem make install

Benutzeravatar
oddikurt
Hacker
Hacker
Beiträge: 597
Registriert: 8. Mai 2005, 01:39
Wohnort: BW i.d.N.v. Pforzheim

Beitrag von oddikurt » 27. Dez 2005, 21:14

Hallo flatron,
ich glaube doch, Du solltest dich dringend etwas mit den Grundlagen beschäftigen. :wink:

Literatur für neue (SUSE)-Linux User:
Die Linuxfibel
Selflinux
pro linux newbie Hilfe
Gerade der letzte Link ist zu empfehlen.
gruss Roger >>>Linuxer #389900<<<
Manage Your Packages, or They Will Manage You

© 2000 Red Hat, Inc.
Edward C. Bailey: Taking the RPM Package Manager to the Limit

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste